ASUS ET8 Roaming Assistant Disconnecting 2 nodes from each other (possible fix)

ROBYER1

New Around Here
This is a tip post as I was noticing my 2 ET8 AiMesh nodes would disconnect randomly from each other. Hope this helps others or comment if it did/you have any tips!

I have a setup of 2 ET8 notes and I would notice occasionally I would have the non-router node upstairs disconnecting. In the system logs I would see 'disconnected weak signal strength station'. After some reading, I realised this could be the Roaming Assistant feature which disconnects devices that are below a certain strength of connection. Rather than raising the threshold of the roaming assistant, I went to the Wifi settings on the web dashboard > Roaming block list and added the two nodes to that list.

This means that now the nodes won't forcibly disconnect themselves if there is a slight fluctuation of wireless connection for a second or two which I assume was happening.

This seems to have solved the disconnecting node issue I was having but I am surprised the firmware doesn't already deal with this scenario if there are only 2 connected nodes in the network.
 

tgl

Regular Contributor
I'm hardly an expert, but there are a lot of recommendations on these boards to just disable the roaming assistant altogether. WiFi clients are perfectly capable of switching to a stronger signal by themselves; if the router tries to force the matter by disconnecting them, that just shows up as a connection drop, and your perceived quality of service gets worse not better.
(Besides which, the client may bullheadedly connect to the same signal again; the router cannot really force this.)

My own network monitoring seems to bear this out, though I only have a few weeks' worth of experience with the XT8 nodes. I disabled roaming assistant about a week ago and local ping reliability seems to be better since then. If you are using the 5GHZ-2 band as dedicated backhaul, I'd definitely disable it on that band --- there isn't going to be any better signal for the upstairs node to reconnect to.
 

Mikejd1

New Around Here
This is a tip post as I was noticing my 2 ET8 AiMesh nodes would disconnect randomly from each other. Hope this helps others or comment if it did/you have any tips!

I have a setup of 2 ET8 notes and I would notice occasionally I would have the non-router node upstairs disconnecting. In the system logs I would see 'disconnected weak signal strength station'. After some reading, I realised this could be the Roaming Assistant feature which disconnects devices that are below a certain strength of connection. Rather than raising the threshold of the roaming assistant, I went to the Wifi settings on the web dashboard > Roaming block list and added the two nodes to that list.

This means that now the nodes won't forcibly disconnect themselves if there is a slight fluctuation of wireless connection for a second or two which I assume was happening.

This seems to have solved the disconnecting node issue I was having but I am surprised the firmware doesn't already deal with this scenario if there are only 2 connected nodes in the network.
Hey there. I wanted to give this a shot too but struggling to find the two nodes in the drop down list in the roaming block list menu. How did you add the nodes, I see all of my devices except the nodes. Thanks!
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top