Wireguard Asus GT-AC2900 Wireguard Problem !!

Funnyland123

Regular Contributor
Hello, everyone,

I use a GT-AC2900 with the Merlin Verion 386.7 2 and so far everything is going quite well.

Now I wanted to test Wireguard as well, but I absolutely can't get it to work. Could someone possibly help me?

Unfortunately it doesn't work with the addon at all to get something to run because most of the buttons are without function (or I'm doing something wrong) If I try to import the config, it also shows everything but imports them.

Manual entry of the data is only possible to a limited extent:
For example, private key and server public key cannot be entered there.


Please help
 

Attachments

  • Bildschirmfoto 2022-08-20 um 18.54.53.png
    Bildschirmfoto 2022-08-20 um 18.54.53.png
    66.1 KB · Views: 93
  • Bildschirmfoto 2022-08-20 um 18.54.53.png
    Bildschirmfoto 2022-08-20 um 18.54.53.png
    66.1 KB · Views: 89
  • Bildschirmfoto 2022-08-20 um 18.55.01.png
    Bildschirmfoto 2022-08-20 um 18.55.01.png
    116.3 KB · Views: 91
  • Bildschirmfoto 2022-08-20 um 18.55.11.png
    Bildschirmfoto 2022-08-20 um 18.55.11.png
    124.4 KB · Views: 90

Martineau

Part of the Furniture
Now I wanted to test Wireguard as well, but I absolutely can't get it to work. Could someone possibly help me?

Unfortunately it doesn't work with the addon at all to get something to run because most of the buttons are without function (or I'm doing something wrong) If I try to import the config, it also shows everything but imports them.

Manual entry of the data is only possible to a limited extent:
For example, private key and server public key cannot be entered there.
The WebUI is an after-thought, and is effectively still a crude Beta/Work-in-progress, but fully functional (and tested) Advanced configuration is available via the command prompt or WebUI wgm dialog box.

For WebUI v1.04 (GitHub dev branch last updated 1st Aug. 2022) use
Code:
e  = Exit Script [?]

E:Option ==> uf dev
to upgrade, and IIRC, apart from the greyed-out non-existent Tabs e.g. VPNDirector etc.; only the export and Dummy Save Button buttons are non-functional?

The Public/Private Keys are not modifiable via the WebUI, but if you have the need to alter those complex fields (usually auto-generated by the WireGuard ISP or) custom keygen created by you, then you would/should already know how to use nano/vi to directly modify the appropriate '.conf' and and/or reimport as required?

If the 'client' Peer import function fails then you need to provide diagnostic details i.e. either error messages during the Peer import, or error messages when you attempt to start the imported 'client' Peer.
 
Last edited:

Funnyland123

Regular Contributor
Sorry the translation into my language is so messed up that I understood absolutely nothing of what you mean.

I'm an absolute novice in this area so much in advance.

So far I haven't found any understandable explanation to install it and get it running.
 

L&LD

Part of the Furniture
Find a student of English willing to help you.

Translating technical 'stuff' into another language 'blind' is an exercise in futility.

The help offered so far is as basic as it can be.
 

Funnyland123

Regular Contributor
Find a student of English willing to help you.

Translating technical 'stuff' into another language 'blind' is an exercise in futility.

The help offered so far is as basic as it can be.
I don't need a student for that, my English neighbor has so many? like me.

So again there is a comprehensible guide that I may not have found yet?
 

L&LD

Part of the Furniture
No guides. Re-read what has been offered to you already.

You stated you didn't understand a word, btw...
 

L&LD

Part of the Furniture
Don't give up so easily! Maybe others can make it understandable for you.
 

ZebMcKayhan

Very Senior Member
Last edited:

Funnyland123

Regular Contributor
Ich habe alles Nötige per SSH auf dem Router installiert. Swapfile 2 gb entware und auch wireguard. Aber leider bekomme ich es überhaupt nicht zum Laufen.

Aus Unwissenheit und der Vorstellung, dass ich das hinbekomme, habe ich mich geirrt und denke "Tech9" ist richtig und sollte auf Version 388 warten.
 

ZebMcKayhan

Very Senior Member
Ich habe alles Nötige per SSH auf dem Router installiert. Swapfile 2 gb entware und auch wireguard. Aber leider bekomme ich es überhaupt nicht zum Laufen.

Aus Unwissenheit und der Vorstellung, dass ich das hinbekomme, habe ich mich geirrt und denke "Tech9" ist richtig und sollte auf Version 388 warten.
Alright, good luck with your choice.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top