FlexQoS Asus Merlin and Flexqos

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

rlj2

Regular Contributor
Do any of you guys use flexqos on a AX86u? Ive used it on a AC86U forever. I set a custom rule in flex to put certain ip addresses to a specific class. example: Nvidia Shield nomatter what it is doing is always considered streaming. This does not work on a AX. its like the rules are ignored.
But Im surprised i havent heard anyone else mention it. Pretty easy to test. Set any ip to a class, make that ip use bandwidth, like a file download. And see where flex graphs show it going.(it doesnt show it period)
 

dave14305

Part of the Furniture
Does Adaptive QoS without FlexQoS work properly and show traffic from the same device in the default classes on the Merlin Classification page?
 

rlj2

Regular Contributor
Dave, we have spoke of this. Was trying to see if other AX users noticed.This keeps me from using the AX86 as main. Kept hoping it would get fixed once 386 was basically stable.
Without flex. Classification page shows appdb items correctly. With Flexqos flex graph and classification page shows appdb items correctly. But when adding the following iptables
rule,

3.png


Then flex shows a very small amount of traffic moving (This was running a speed test)
1.png

As does Classification page.
2.png

If i disable the rule, both classification/flex show the bandwidth correctly in the correct appdb class.
With the rule enabled, i just started a download that uses all my bandwidth 25Mbit. Bandwidth monitor shows 25Mbit being used. flex only shows that at
around 500kb, classification the same roughly in bit.

That rule works perfectly fine on a AC86U. Even if I make a rule using a mark, it does not work.
Hope this makes sense.
 
Last edited:

rlj2

Regular Contributor
Just a bump, no AX users seeing this type of issue?
 

rlj2

Regular Contributor
I must be the only one that has this issue with a ax86, or the only one that uses that type of rule :(
 

dave14305

Part of the Furniture
I see a few posts of unexplained QoS behavior from AX users. Nothing I could point a finger at, but it’s been notable to me.

As a test, I setup a rule on my AC86U just to prove it worked still, and my speedtest didn’t go where I thought it should. Turned out the speedtest ran over IPv6, so the IPv4 rule didn’t catch it. Beware of your own setup.

There can always be something outside our control with Broadcom and Trend Micro and Asus, especially on a new model.

If you disable fc or runner, does it behave better? Seems like packets are bypassing the netfilter layer of the kernel.
 

rlj2

Regular Contributor
I see a few posts of unexplained QoS behavior from AX users. Nothing I could point a finger at, but it’s been notable to me.

As a test, I setup a rule on my AC86U just to prove it worked still, and my speedtest didn’t go where I thought it should. Turned out the speedtest ran over IPv6, so the IPv4 rule didn’t catch it. Beware of your own setup.

There can always be something outside our control with Broadcom and Trend Micro and Asus, especially on a new model.

If you disable fc or runner, does it behave better? Seems like packets are bypassing the netfilter layer of the kernel.
i will definitely give it a test, and i also understand being outside of control, closed source,etc. Wish one kind soul would try it on a ax86, pretty simple rule.
 

rlj2

Regular Contributor
I see a few posts of unexplained QoS behavior from AX users. Nothing I could point a finger at, but it’s been notable to me.

As a test, I setup a rule on my AC86U just to prove it worked still, and my speedtest didn’t go where I thought it should. Turned out the speedtest ran over IPv6, so the IPv4 rule didn’t catch it. Beware of your own setup.

There can always be something outside our control with Broadcom and Trend Micro and Asus, especially on a new model.

If you disable fc or runner, does it behave better? Seems like packets are bypassing the netfilter layer of the kernel.
@dave14305 Looks like you found the underlying issue. I have to disable both flow cache and runner, instantly speeds are reported correctly, and the rule works. Asus bug or feature? :) I was also never convinced straight qos worked 100% correctly, maybe it effects that also.
 
Last edited:

dave14305

Part of the Furniture
@dave14305 Looks like you found the underlying issue. I have to disable both flow cache and runner, instantly speeds are reported correctly, and the rule works. Asus bug or feature? :)
At your speeds it’s probably cool to leave them disabled. Or go back to the AC86U.
 

rlj2

Regular Contributor
@dave14305 just a fyi it does not affect local (I should have known that as it would have shown when using cake). Ill probably be putting the AC86u back as the main. Im sure i gain nothing using the AX86u as main other then the mental thing of wanting the newest as first.
When using the AX86u and adaptive qos bufferbloat is terrible, and manually changing bandwidth doesnt help, doesnt matter if runner and flowcache or enabled disabled. Cake does fix the bufferbloat. But yet again. With the AC, adaptive and correct bandwidth has A+ bufferbloat.
 

dezzm5

New Around Here
Hello,
my ax86u behaves the same way. Does it mean that the rule doesn't work at all or is it just the graph not displaying things correctly ? Is there a way to find out?
 

rlj2

Regular Contributor
Hello,
my ax86u behaves the same way. Does it mean that the rule doesn't work at all or is it just the graph not displaying things correctly ? Is there a way to find out?
@dezzm5 I questioned that also, but from the testing i did, and its kind of a pain. Basically seeing if something I have set as lower priority overpowers the high priority. Since graphs dont work, i used iftop from command line . And far as I can tell it does. Meaning the iptables rules dont work at all. Appdb rules do work. How is your bufferbloat when using adaptive?
 

dezzm5

New Around Here
My bufferbloat is always bad (wireless isp, in the middle of nowhere). My speed varies alot (25-40Mbit). Adaptive seem to be worse than cake but I would have to cut my speed by alot to get acceptable load latency. I gave up on that...
 

rlj2

Regular Contributor
My bufferbloat is always bad (wireless isp, in the middle of nowhere). My speed varies alot (25-40Mbit). Adaptive seem to be worse than cake but I would have to cut my speed by alot to get acceptable load latency. I gave up on that...
gotcha, well if you didnt see above, at least disabling flowcache will fix the iptables rule, and wont affect you with those speeds.
 

Xrsenal

Senior Member
gotcha, well if you didnt see above, at least disabling flowcache will fix the iptables rule, and wont affect you with those speeds.
If I have gig, disabling fc hurts me :(

I can get away w turning off runner and STP but not fc.

something weird is going on w the hardware accels on the ax86u
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top