1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Asus RT-AC3200 Smart Connect Rules Fine Tuning

Discussion in 'ASUS AC Routers & Adapters' started by dlandon, Feb 15, 2015.

  1. dlandon

    dlandon Regular Contributor

    Joined:
    Feb 5, 2015
    Messages:
    100
    Another attempt at tuning settings

    I've been experimenting with the Smart Connect settings some more after I had an iPad start dropping out and not keeping a connection when in a weak signal area of the house.

    I loaded the default settings and just adjusted the PHY Rate settings a bit and it looks like the iPads we have connect faster and don't hesitate when they switch bands.

    Right now it looks like the devices end up on the bands as I expect.

    I know some would just like settings that will work in all wireless environments, but I think that is unrealistic. I am trying to give some information on what works for me so others will try some adjustments on their router. Wireless is affected by way too many factors to come up with generic settings that will work in all environments.

    Let me know if these settings make any difference for you.
     

    Attached Files:

  2. joe012594

    joe012594 Regular Contributor

    Joined:
    Feb 18, 2015
    Messages:
    91
    I, too, have been playing around with the settings to no avail. All of my 5GHz clients wind up connecting to one band while the other band remains without any clients at all. Was really hoping to keep my N and AC devices seperate. Some settings make it near impossible for any clients to connect at all (2.4GHz and 5GHz). In my opinion, I don't think all of the Smart Connect settings were fully implemented into the firmware for support and we're all just going to have to wait until ASUS releases an update to fix and add support to the feature for more stability. From what I've been reading, ASUS plans to release a firmware update soon to address the Smart Connect issues. Hopefully, that'll be within the next couple of weeks or I'll have to return this router before my family kills me. :/
     
  3. dlandon

    dlandon Regular Contributor

    Joined:
    Feb 5, 2015
    Messages:
    100
    For the moment, turn off Smart Connect.
     
  4. joe012594

    joe012594 Regular Contributor

    Joined:
    Feb 18, 2015
    Messages:
    91
    Yah, that's what I've been doing for the past few days now. Problem is, all of my wireless clients on all bands get booted off every 15 minutes or so, even with Smart Connect disabled. Drove all of us nuts while trying to watch Netflix, so I disabled all wireless bands on the RT-AC3200, connected my RT-AC87U as an AP for AC clients only, and connected my old RT-AC66U as an AP for 5GHz N + 2.4GHz (A/B/G/N) clients. Made sure all routers were up to date on the most recent firmware releases and all is good right now. Just hope ASUS releases that firmware update for the RT-AC3200 soon.
     
    Last edited: Feb 26, 2015
  5. moemayne

    moemayne New Around Here

    Joined:
    Mar 1, 2015
    Messages:
    1
    Location:
    California
    Has anyone tested his configurations yet... if not i am about to try them shortly and let you guys knows
     
  6. joe012594

    joe012594 Regular Contributor

    Joined:
    Feb 18, 2015
    Messages:
    91
    Yes. I've tested both settings that were posted here and, though they seemed to work much better than stock, there was still the constant wireless drops and reconnects that's present in all units, whether Smart Connect is enabled or disabled. I've been in contact with higher level tech support agents/engineers at ASUS getting to the core of the issue and hopefully they'll have a solution out for all of us soon.
     
  7. dlandon

    dlandon Regular Contributor

    Joined:
    Feb 5, 2015
    Messages:
    100
    Merlin has posted a wifi troubleshooting guide here: http://www.snbforums.com/threads/guide-troubleshooting-wifi-issues.12825/

    Towards the bottom he suggests setting Wireless -> Professional "Regulation Mode" to 802.11h for 5GHz bands. He shows how to do that through a telnet session by changing NVRAM settings, but it can be done in the webgui on the AC3200.

    I changed the "Regulation Mode" on both 5GHz bands to 802.11h and it seems to have helped with the excessive searching for a band on devices on my network, especially Apple devices.
     
  8. joe012594

    joe012594 Regular Contributor

    Joined:
    Feb 18, 2015
    Messages:
    91
    Wanted to check in real quick and report some findings of my own regarding Smart Connect settings. I've played with them all for days now and finally found a pretty solid/stable configuration for all of my devices. Both N and AC clients are successfully split between the two 5GHz bands. All clients have been connected without interruption for over an hour now, so no disconnects every 15 minutes or so. Here's my settings, if anyone wants to try them out and report back.


    SmartConnect.PNG
     
  9. Enzo

    Enzo Occasional Visitor

    Joined:
    Mar 4, 2015
    Messages:
    23
    Location:
    CA
    Attached is a PDF of the AC3200 Smart Connect Rules page from my router.

    I can't seem to find this page on .3883 or .4149

    Pls direct
     
  10. joe012594

    joe012594 Regular Contributor

    Joined:
    Feb 18, 2015
    Messages:
    91
    I don't see any attachments in your post. :eek:

    You can find the Smart Connect rules in Network Tools > Smart Connect Rule.
     
  11. joe012594

    joe012594 Regular Contributor

    Joined:
    Feb 18, 2015
    Messages:
    91
    Bounce Detect appears to be the amount of times a device can attempt to "bounce" to another band before giving up. ASUS just released a new firmware yesterday which changes the Bounce Detect setting from 4 to 1. I suspect this has to due with all of the wireless disconnects and instabilities that were reported all over the net when this thing hit the market. Though, changing that setting hasn't fixed the underlying problem, which is that Smart Connect doesn't separate the N only and AC capable clients between the 2 bands. All of the 5GHz clients wind up getting piled onto the 5GHz-1 band leaving 5GHz-2 completely unoccupied. Also, I'm still getting random disconnects with wireless clients. some firmware update that was... :(
     
  12. dpickens

    dpickens New Around Here

    Joined:
    Feb 3, 2015
    Messages:
    4
    My Apple TV's have settled in on the 5GHz-1 band while my iPhone 6 and iPad Air 2 have landed on 5GHz-2 which is what I expected. Of course when I go to the back of the house they move to the 2.4Ghz band since I'm out of range. Overall I'm pretty happy with the 4145 firmware and how it's handling smart connect so far. Only issue I've seen is on the Dell XPS 12 laptop, it does disconnect the RDP session we have with a remote server more often than when I had smart connect turned off, but I don't see my iOS devices struggle to acquire wi-fi like it did on the 4129 firmware.
     
  13. joe012594

    joe012594 Regular Contributor

    Joined:
    Feb 18, 2015
    Messages:
    91
    Interesting. So your AC capable clients are successfully connecting to 5GHz-2 and N only clients to 5GHz-1? Even when they downgrade to 2.4GHz and reconnect back? Wish I had that much luck.
     
  14. Jwagner010

    Jwagner010 Occasional Visitor

    Joined:
    Jan 4, 2015
    Messages:
    24
    Any further information on when we will see this release to address the drops?

    I too have constant disconnects with Smart Connect off. Never had an issue with my old router.
     
  15. mbze430

    mbze430 Occasional Visitor

    Joined:
    Feb 1, 2015
    Messages:
    35
    I'm also having major drop off with my AC devices. Mainly my Surface Pro 3. Doesnt' seem to matter if Smart Connect is on or off for me. My LG G3 (AC Device) loves searching between 5ghz-1 and 5ghz-2
     
  16. Jwagner010

    Jwagner010 Occasional Visitor

    Joined:
    Jan 4, 2015
    Messages:
    24
    Unfortunately its my 2.4G devices that are constantly dropping when they never did before on an old N900 Netgear.
     
  17. thiggins

    thiggins Mr. Easy Staff Member

    Joined:
    May 18, 2008
    Messages:
    13,959
  18. scottegos2

    scottegos2 Occasional Visitor

    Joined:
    Aug 22, 2012
    Messages:
    37
  19. trichard

    trichard Occasional Visitor

    Joined:
    Jan 3, 2015
    Messages:
    17
    Any new updated regarding about the smart connect???
     
  20. joe012594

    joe012594 Regular Contributor

    Joined:
    Feb 18, 2015
    Messages:
    91
    Yes. These settings seem to work the best for me as of now. No disconnects with 2.4GHz and 5GHz-2 (802.11ac) clients. Some disconnects occur with 5GHz-1 (802.11n) clients though. Still am going to play around with the settings to see if that can be fixed. Also, be sure to set "Network Key Rotation Interval" to "0" in the Wireless settings page. This fixes the hourly wireless drops to all clients that everyone is still experiencing.
     

    Attached Files:

    Jayvee likes this.