What's new

ASUS RT-AC68U + ASUS ZenWiFi AX (XT8) configuration

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

With less than 1,000 SqFt area, you definitely have too much WiFi going on within your home.

Use a single, well-placed (I would test it as close to the door in Room 1 as possible), main AX class router, along with a router in Media Bridge mode for the wired devices you need connected in Room 2.

Or, you can also consider a single main AX class router in Room 2 (as close as possible to the door to Room 3) for an even better setup.
 
You're much too close to the router to obtain optimal results.

WiFi needs space to fully form the signal for our client devices. I find that 10 feet or more is optimal.

Your actual speeds will be determined by the server you're connected to during the speed test, and the congestion of the ISP and your immediate environment.

Right now, I would be testing different Control Channels in a systematic manner to get better results.

And be sure to test 160MHz Bandwidth too, now that you see what a difference AC power on a laptop makes.

I would remove the 'killer' software from the WiFi adapter too.

Ok, I tried all the possible combinations, here the results:

  • XT8 stock firmware, placed in the room number 1, no other devices turned on, only 1 laptop and 1 phone connected. Stock configuration. Result: 420mb in speed test.
  • XT8 Merlin* firmware (388.2_2_0-gnuton1), placed in the room number 1, no other devices turned on, only 1 laptop and 1 phone connected. Stock configuration. Result: 460mb in speed test.
  • XT8 Merlin* firmware (388.2_2_0-gnuton1), placed in the room number 1, RT-AC68U in the room number 2 configured as Media Bridge, few devices connected. Custom configuration with VPN + Killswitch, DHCP etc. Result: 360mb in speed test.
  • XT8 Merlin* firmware (388.2_2_0-gnuton1), placed in the room number 1, RT-AC68U in the room number 2 configured as Media Bridge, XT8 on the room number 3 configured as NODE, few devices connected. Custom configuration with VPN + Killswitch, DHCP etc. Result: 280mb in speed test.
It seems that any router device turned on "disturb" the main router, causing drop in terms of speed.

I'm wondering at this point if buy a high end router, placed in the room number 2, will solve definitely the issue.
 
Last edited:
It's Merlin, not Marlin. ;)

If your devices are going through OpenVPN then you can expect that sort of speed limitation.

I'm wondering at this point if buy a high end router, placed in the room number 2, will solve definitely the issue.
Almost certainly not.
 
Hard to tell what your results indicate when they're not accompanied by the locations you're testing from and the location of the main router and the nodes.

Were these tests all done with the laptop plugged in? Where was the laptop in relation to the router/node it was connecting to?

When you flashed different firmware, did you do a full reset to factory defaults?

Are you importing any saved backup config files to set up the router/network?

Your custom configurations with VPN + Killswitch tests aren't valid for how much (maximum) throughput the router can do.

To fully reset the router, use the appropriate method for your specific model from the link below.



Do not import any saved backup config files. It will effectively render the full reset invalid. In particular, do not import backup config files from one firmware version onto a different version. Particularly different forks (i.e. stock vs. GNUton).

Your environment won't benefit from an additional router to the current main unit.

Replacing all the routers you have may give you a more performant network overall.

The RT-AX88U, or the GT-AX6000, along with an RT-AX68U to be used as a Media Bridge for room 2 will greatly outperform what you currently have.
 
It's Merlin, not Marlin. ;)

If your devices are going through OpenVPN then you can expect that sort of speed limitation.


Almost certainly not.

Forgive me, after more than 12 hours fighting with routers, I feel done :)

Only one device is connected via VPN, and it's a TV decoder.

Were these tests all done with the laptop plugged in? Where was the laptop in relation to the router/node it was connecting to?
Yes, the laptop was always connected and placed in the room number 3 as shown in the picture.

When you flashed different firmware, did you do a full reset to factory defaults?
Yes, I read multiple post for different topic, in all of them is suggested to reset the router after updating the firmware :)

Are you importing any saved backup config files to set up the router/network?
No, every time I set everything manually from scratch.

Your custom configurations with VPN + Killswitch tests aren't valid for how much (maximum) throughput the router can do.
Yes, VPN is not taken into consideration, and it's anyway active only for one device which is connected to the TV.

The RT-AX88U, or the GT-AX6000, along with an RT-AX68U to be used as a Media Bridge for room 2 will greatly outperform what you currently have.
Thank you for the advice, I was already looking for the ROG Rapture GT-AXE16000 but it seems a bit OP for the purpose :)
 
The VPN (active) may still be affecting clients that are not connecting through it too, just FYI. Better to be testing with it not enabled.

An AXE Class router isn't a good purchase today if it isn't actually needed. The models I suggested previously are available at very good prices (particularly when on sale) and the RT-AX68U was starting at only $75, just a few days ago.

Of course, please note that the recommendations made here are just conjecture right now until you can test them in your own environment.

The environment may ultimately be the biggest issue here for you. Are you living in a very densely populated area?

Are you using a single SSID for both 2.4GHz and 5GHz bands? Have you at least tested with a never-previously used SSID?

What actual ISP do you connect to? Cable? FTTH? Another ISP connection? Are you required to use the ISP's modem/router, or are you connecting directly via an ONT or similar?
 
The VPN (active) may still be affecting clients that are not connecting through it too, just FYI. Better to be testing with it not enabled.

Good day, after turning off the VPN, I get the same speed as when it was active:

1697350649561.png


Above, is the result of my laptop being connected from the room number 3 directly to the router. I have now activated once again the Media Bridge in the room number 2, and the NODE in the room number 3.

Instead, the NODE in the room number 3, placed at the end of the room, gives me the following result:

1697351013484.png
1697351026029.png


Unfortunately, relocating the NODE in room number 3 further is not a viable option, as it is already positioned at the room's extremity. The only potential alternative locations would be on the first floor or the second floor. Regrettably, with the current configuration, there is no signal reception on the first floor.

An AXE Class router isn't a good purchase today if it isn't actually needed. The models I suggested previously are available at very good prices (particularly when on sale) and the RT-AX68U was starting at only $75, just a few days ago.

Unfortunately the RT-AX68U it's out of stock everywhere around my country, and the few options available starts from 160€. I will probably have to find an alternative, unless the RT-AC68U will work properly along with the GT-AX6000. At the moment, the RT-AC68U connected via Media Bridge, it's working properly with the 2 devices connected via LAN, I'm wondering if would make sense replace it at this point.

Of course, please note that the recommendations made here are just conjecture right now until you can test them in your own environment.

Sure, I fully understand that. Worse scenario I will return the device, so no worries :)

The environment may ultimately be the biggest issue here for you. Are you living in a very densely populated area?

I reside in a suburban area outside the city, comprised of independent houses. While it may not be highly populated, there are certainly residents in the vicinity. Naturally, each house has its own Wi-Fi network.

Are you using a single SSID for both 2.4GHz and 5GHz bands? Have you at least tested with a never-previously used SSID?

I have 2.4GHz and 5GHz separate, as well 5GHz-2, as the smart connect wasn't working properly imo. I have used a totally new SSID comparing to the previous configuration.

What actual ISP do you connect to? Cable? FTTH? Another ISP connection? Are you required to use the ISP's modem/router, or are you connecting directly via an ONT or similar?

The ISP installed a fiber cable directly from their central, which is situated at the end of the road, approximately 25 to 30 meters from my house. They then connected their MicroTik device to the optic fiber cable. While I'm not obligated to use their provided device, the MicroTik router they supplied has been working quite effectively and doesn't seem to have many restrictions, as far as I can tell.
 
As I've indicated in the links I've provided, a node using wireless backhaul needs to be much closer to the main router than a node using wired backhaul.

From the following link:

AiMesh Ideal Placement

Code:
Here's some further information on how an ideal setup wired AiMesh setup would work.



If you're wired, the best placement would be as close to the following diagram as possible.



This is looking at the entire area you wish covered from a birds-eye (top) view.



AiMesh router----------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------

-----------------------------------------------------------------------------------AiMesh Node







Looking at the same area coverage but from a wireless AiMesh configuration, the following works the best for my customers, in most Wi-Fi environments.



AiMesh router----------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------

---------------------------------------AiMesh node--------------------------------------------

--------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------





The takeaway of the above suggestions is that the wired AiMesh setup works best when the routers are as far apart as possible in every dimension (width, length, height/floors).



The wireless AiMesh setup seems to work best when there is a clear need to extend the range of the main router's Wi-Fi and the node is serving a unique area of its own. The stronger the signal for the AiMesh node, the greater the throughput it can provide to the client devices too.


If the RT-AC68U is working as you expect (what actual speeds do you get on this connection?) then there is no reason to replace it.

If your laptop is getting great speeds in Room 3 without an AiMesh node active, why else do you need a router in Room 3?

What are your paid-for ISP speeds?

What speeds do you get on your laptop, when plugged into AC power, when it is plugged directly into the ONT (the ISP MicroTik device)?

Maybe you can provide a better diagram of the multilevel floor areas that need coverage so we may better understand your needs.
 
If the RT-AC68U is working as you expect (what actual speeds do you get on this connection?) then there is no reason to replace it.

Hello, good Sunday and thank you for your answer. Via LAN cable, on the Media Bridge, I get the following speed:

1697386806510.png


Is not super fast, but it's more than enough speed to let the 2 devices connected via LAN to work properly.

If your laptop is getting great speeds in Room 3 without an AiMesh node active, why else do you need a router in Room 3?

My typical approach involves positioning the node in room number 3 with the expectation that it will improve signal coverage on the first floor to the next node usually (and not now) placed in the room number 2 (first floor).

What are your paid-for ISP speeds?

At the moment I pay around 22€ for 300mb, however, the upgrade to 600mb will cost me 31€ per month.

What speeds do you get on your laptop, when plugged into AC power, when it is plugged directly into the ONT (the ISP MicroTik device)?

Here it is:
1697387694578.png


Maybe you can provide a better diagram of the multilevel floor areas that need coverage so we may better understand your needs.

Here it is:

1697387739768.png


As a rule, I position the XT8 node in room number 2 on the first floor (on the old configuration).

In the previous configuration, which featured the RT-AC68U router in ground floor room number 1, the first XT8 node in ground floor room number 2, the second XT8 node in ground floor room number 3, and the third and final node in room number 2 on the first floor, I achieved speeds of approximately 220/250 Mbps, even though my connection was 300 Mbps. However, it's worth emphasizing that under the present speed, I won't be able to fully capitalize on the advantages of my 600 Mbps connection due to the RT-AC68U acting as a bottleneck.

I have yet to experiment with placing a WiFi node on the first floor in room number 2, as I've been exclusively following your recommendations.

The current configuration includes only a XT8 router in the ground floor room number 1 and a Media Bridge in the ground floor room number 2.

Thank you for your assistance
 
Good Sunday to you too, and you're welcome.

It is very hard to make heads or tails of the additional details you provide.

Your first diagram doesn't seem to match the latest one you provided.

Are the Rooms 1, 2, and 3 all on one floor? Which floor is that? How many floors does your home have, in total, and do you need coverage on all of these floors?

I see that:

Connecting directly to the ONT, you are getting the speeds you pay for.

The RT-AC68U is not located ideally if that is the highest speed you can get through one wall. And/or, you are using devices that are severely limited over a wired connection (i.e. they don't have enough CPU power or a proper LAN card). Test the Media Bridge by plugging in your laptop to AC power and connecting directly to the RT-AC68Us LAN port(s), yes, try them all. Your expected speeds in this test should be almost identical to your direct connection to the ONT, above.

Additionally, did you merely change the mode of the RT-AC68U to Media Bridge mode? Without doing a full reset on it?


Be sure you follow the steps above for your model to fully reset it and then use it in the mode you want.

Is not the ground floor the first floor?

Can you provide plans for each floor you want/expect coverage on? The latest diagram you provided doesn't tell me much on its own.

A diagram of each floor, properly labeled (let's start with new room numbers so that we know which router/node is on what floor) and a written explanation of which areas need (additional) coverage over and above the single main router in use would be very helpful right now.
 
A diagram of each floor, properly labeled (let's start with new room numbers so that we know which router/node is on what floor) and a written explanation of which areas need (additional) coverage over and above the single main router in use would be very helpful right now.

My house comprises a ground floor, a first floor, and a second floor (what I'd describe as more of an attic, used for guest accommodations).

all map.png


The ground floor (so the base of the house) is where we spend the majority of our day and consists of three rooms, now mentioned as 1-g, 2-g, and 3-g. -g as ground floor. The router XT8 is located in the room 1-g, while the Media Bridge is located in the room 2-g.

The first floor is where we primarily spend our evenings and nights. It consists of five rooms, which I'll conveniently label as 1-1f, 2-1f, 3-1f, 4-f1, and 5-f1. The suffix -1f is added to specify the first floor.

Before going to sleep, I work on my laptop in bed or watch a movie, so the more speed and signal we can provide to the room 1-1f, the better. Other rooms on the first floor doesn't require a full super-speed.

The rooms on the first floor align from above with the ground floor in the following manner:

- Room 1-g aligns with 4-f1.

- Room 2-g aligns with 5-f1.

- Room 3-g aligns with 1-f1, 2-f1, and 3-f1.

The second floor, which I refer to as the attic (1-f2), is rarely used. It align from above with the first floor in the following manner:

5-f1, 1-f1, and 2-f1.

Given the infrequent use of the attic, I would be happy it if guests could also have access to a decent internet connection, not necessarily super fast.

I hereby confirm that I've reset the Media Bridge located in room 2-g in accordance with the official instructions provided by you. Regrettably, this specific positioning is necessary, as the devices requiring LAN connections cannot be relocated.

Currently, the average speed I'm obtaining from all the LAN sockets of the Media Bridge is 110 Mbps for downloads and 50 Mbps for uploads.

In terms of ideal speed percentages, my preference would be to achieve 100% speed on the ground floor, 75-100% speed on the first floor, and 30-60% speed on the second floor (attic).

I hope this explanation is clear, and if not, please let me know.

Thank you once again for your understanding and patience.
 
I'm not sure why you can't adjust the location of the Media Bridge in room 2-g. Surely you can use a 10' or 25' Ethernet cable to connect the required devices. At this point, I can only conclude that the location of the router is lacking here. The RT-AC68U is surely capable of more. Maybe it's also worth trying new Cat5e cables from the Media Bridge to the client devices. And, double-checking here, did you try the plugged-into-AC-power laptop on the Media Bridge too? Is the Media Bridge 'behind' anything, from the perspective of the main router? If it is, use longer Ethernet cables and face it more directly towards the main router with as few obstructions between them as possible. What speeds does the plugged-into-AC laptop get in room 2-g? The RT-AC68U should be close to those speeds.

With regards to your performance ideals, you will not achieve 100% speed coverage wirelessly on the ground floor unless you're within line-of-sight of the main router, and relatively close to it too, or, you enable a wired backhaul to an AiMesh node.

The above also applies to the 75% to 100% expected speeds on the first floor too. Having a node on the ground floor to supply coverage for the first floor doesn't make too much sense here.

Test with an AiMesh node on the first floor located within rooms 3-f1 and 5-f1. Doing so will also give you enough reach and throughput for the second floor/attic too. Using only a single additional AiMesh node.

What, if anything is stopping you from locating the main router in room 3-g? Ideally, in the area roughly behind the door (between 2-g and 3-g)? That single change should make a huge difference and will not require you to have so many nodes (one in 5-fl or 1-f1 should be all that is needed).


To re-cap, without a wired backhaul and properly located nodes, you will not achieve your expected speeds ever, even with multiple, nodes. Keep in mind how finicky WiFi is, and beginning with (and only) the main router, make small adjustments (even inches help) for maximum coverage, the lowest latency of connected devices, and lastly, the highest throughput. Balance the location with the Control Channel used. Adjust as necessary.

And once more, to be 100% on the same page, you did perform a full reset to factory defaults on the main router you're using now, correct? Without importing any saved backup config files (particularly not ones from another router)?

The following links may be of help too.



 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top