What's new

ASUS RT-AC68U + ASUS ZenWiFi AX (XT8) configuration

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

_Dan_

Occasional Visitor
Greetings everyone,

First of all, I would like to thank all the community around the Merlin project. I've been using this amazing firmware since years, I genuinely appreciate your effort.

After grappling with this issue for over a month, I've decided to reach out to this knowledgeable community for assistance. It's clear that many of you have more expertise in this area, and I'm hoping to tap into your insights.

I recently contacted my internet service provider with the intention of boosting my internet speed to 600mb in the hopes of improving my daily work efficiency.

Unfortunately, the results have been quite disappointing, even after experimenting with various configurations. The primary concern lies in the speed discrepancy I've observed, both through cable connections and Wi-Fi, across different rooms on the ground floor. The speed seems to diminish as it traverses each node.

For a clearer understanding, here's a visual representation:

Untitled.png


I tried 2 configurations.

Configuration number 1:
  • ASUS RT-AC68U as main router with latest version of Merlin
  • ASUS ZenWiFi AX (XT8) with official firmware and configured as NODE
  • ASUS ZenWiFi AX (XT8) with official firmware and configured as NODE
Configuration number 2:
  • ASUS ZenWiFi AX (XT8) as main router with latest version of Merlin (388.2_2_0-gnuton1)
  • ASUS ZenWiFi AX (XT8) with official firmware and configured as NODE
  • ASUS ZenWiFi AX (XT8) with official firmware and configured as NODE
In both scenarios, achieving the expected speed has proven elusive, whether it be through Wi-Fi or a wired LAN connection.

In room number 1, I can attain the full 600mb speed through a cable connection, while the Wi-Fi performance hovers around 550 to 580mb. The router in the room number 1, is connected directly via LAN to the Microtik device provided by the internet provider.

I find it perplexing that the issue persists, as the walls in my residence aren't notably thick. This leaves me puzzled as to why our devices experience such significant speed degradation when connected through a mesh Wi-Fi network.

Regrettably, my house lacks LAN sockets, so all connections via the mesh network must rely solely on Wi-Fi.

In the room number 2, I get via WiFI 380/400mb, while via cable connection, I can get around 450mb.

In the room number 3, I get via WiFI 250mb, while via cable connection, I can get around 320mb.

I'm wondering if there is any way to make my configuration better with taking into consideration that I can't install cables around the house. If a potential solution might involve investing quite a lot of money on a new device, I'm OK with that.

I have around 20 devices connected to my network, 4 of them have a manually assigned IP around the DHCP list, and another device is connected via VPN + Killswitch.

Most of my devices support WiFi 5 or they are equipped with Wi-Fi 6E card. 3 of the 20 devices supports only WiFi 2.4GHz.

I genuinely appreciate any advice or suggestions you might have to help me resolve this issue.

Thank you in advance for your support.
 
The router in the room number 1, is connected directly via LAN to the Microtik device provided by the internet provider.
Can you just confirm it is the Asus router's WAN port that is connected to the Microtik's LAN port?

Theoretically you should be using the XT8 as your main router instead of the RT-AC68U. This should allow you to use the 5GHz-2 band as a dedicated backhaul to the node with a link speed of up to 4804 Mbps. If you use the RT-AC68U you will be creating a bottleneck as it will be operating at a lower speed and the airtime will be shared with client devices.

There is no scale to your diagram but it looks like you might be able to get away with only using one satellite node rather than two by moving the second node to somewhere more central. It's possible you have "too much" Wi-Fi and they are competing with each other for airtime.

As an experiment I suggest you turn off the second node and check what "PHY rate" you are getting for backhaul between the main router and the first node.
 
Welcome to the forums @_Dan_.

Without knowing the dimensions of the rooms you provided, my first thought is that you have too much WiFi in your home (with the two nodes you are trying to add to it).

In keeping with this, room 2 most likely doesn't need a node inside it. And the node in room 3 is most likely too far away to be beneficial if needed at all too. (Again, depending on the dimensions here).

I would remove/power down the nodes and test the main router as-is right now throughout the home. If needed, I would then test different locations of the main router (in all axes, x, y, and z) and see how much improvement you get).

I would also not be using the rather ancient RT-AC68U today as a main router. It is more than likely detrimental to your speed, latency, and network performance efforts. An RT-AX68U will be a huge upgrade, and depending on your expected ISP speeds in the future, an RT-AX88U or a GT-AX6000 may be the better buy for the long term.

The negative aspects you're seeing in your network are as expected when using wireless backhaul and improperly placed nodes. Each node is cutting the available bandwidth in half (when used simultaneously), and that 'half' is based on the maximum throughput it receives too (so the node in room three which is incorrectly placed, may be only 1/3 or less of your maximum, paid-for speeds).

Here is a quick point list of what I would do in your environment.
Hope this helps.
 
Theoretically you should be using the XT8 as your main router instead of the RT-AC68U. This should allow you to use the 5GHz-2 band as a dedicated backhaul to the node with a link speed of up to 4804 Mbps. If you use the RT-AC68U you will be creating a bottleneck as it will be operating at a lower speed and the airtime will be shared with client devices.
Hello Colin, thank you for your answer.

I can confirm as written in the configuration number 2 that I tried using the XT8 as main router as well, unfortunately, with the same result.

The node in the room number 2 is unfortunately necessary, as I have some devices running via LAN and can't be connected via Wi-Fi.

The house is not small, but not huge, so I agree with you the range of the XT8 should be more than enough.

The LAN cable of the XT8 it was indeed connected to the "Blue" LAN socket (
1697301418461.png
), while the Microtik cable was connected to the PoE in and not the PoE LAN out (
1697301320693.png
), now I changed.

The cable is recognized correctly:

1697301344479.png
 
I would remove/power down the nodes and test the main router as-is right now throughout the home. If needed, I would then test different locations of the main router (in all axes, x, y, and z) and see how much improvement you get).
Hello L&LD, thank you very much for your detailed explanation, really appreciated.
As a first quick test, since the XT8 was set today with a new fresh configuration, I turned off the 2 nodes in the room number 2 and 3, and I'm now connected to the router only (XT8) located in the room number 1.

I'm connected to the Wi-Fi 5GHz-2 with a Wi-Fi 6E laptop, and this is the result I get now while working with my laptop in the middle of room number 3:

1697301978173.png


That's indeed a big improvement considering I was getting around 250mb before. However, this is what I get with the same laptop if I move to the room number 2:

1697302203977.png


And this is what I get with the same laptop if I move to the room number 1:

1697302321855.png


How come that if I get closer to the router I get less speed? It doesn't make any sense 😆
 
That is indeed strange that the speeds get slower when you're closer to the router.

Be sure your laptop is set to High Performance mode and double check that the WiFi adaptor doesn't have any power savings settings enabled either in its driver properties. Or, simply plug in the router to AC power wherever you want to test the speeds with.
 
Set the Channel Width to 80MHz for more consistent performance in a small space.
 
Then that suggests there's something wrong with your testing method. Try using a different speed test site and run it multiple times. Ensure that there aren't other devices on your network that are downloading lots of data. Can you confirm that your laptop is not using a VPN of any kind?

Was that screenshot taken with the laptop close to the router? Its signal strength is very weak if it was.
 
If you need a node in room 2 for wired devices, then use the RT-AC68U in Media Bridge mode for them.

Media Bridge Mode

You will still have WiFi from the main router, but you will eliminate the interference and 'too much WiFi' caused by a wireless repeater at such close quarters.
 
Was that screenshot taken with the laptop close to the router? Its signal strength is very weak if it was.

Thank you for your suggestion.

I can confirm that now I have only my laptop connected to the 5GHz-2 Wi-Fi, I changed the Channel Width to 80MHz and I'm located in the middle of the room number 3.

1697303559161.png


This is what I get:

1697303519871.png


1697303603969.png
 
Thank you for your suggestion.

I can confirm that now I have only my laptop connected to the 5GHz-2 Wi-Fi, I changed the Channel Width to 80MHz and I'm located in the middle of the room number 3.

View attachment 53632

This is what I get:

View attachment 53631

View attachment 53633
The idea was to check the signal strength and link rates when you were experiencing the reduced speeds (room 1), not when it's working as expected (room 3).
 
The idea was to check the signal strength and link rates when you were experiencing the reduced speeds (room 1), not when it's working as expected (room 3).
I see, sorry I completely misunderstood the idea.

Now I'm located in the room number 1, close to the router:

1697304001562.png


1697304121593.png


1697304167218.png
 
OK so you now have a 1200Mbps Wi-Fi connection so there's no reason why you shouldn't be getting your full 600Mbps speed. Given the apparent variability of your results I'm inclined to think this might congestion on your ISP's side. Can you verify again what speed you get if you plug your laptop into the XT8's LAN port.

EDIT: Are you using QoS on either of your routers (Microtik or XT8)?
 
OK so you now have a 1200Mbps Wi-Fi connection so there's no reason why you shouldn't be getting your full 600Mbps speed. Given the apparent variability of your results I'm inclined to think this might congestion on your ISP's side. Can you verify again what speed you get if you plug your laptop into the XT8's LAN port.

EDIT: Are you using QoS on either of your routers (Microtik or XT8)?

This is the speed I get via LAN to the XT8 router:

1697305256745.png


I can confirm that Enable QoS on the router it's OFF
1697305311962.png
 
What WiFi card is in your laptop? Have you tried connecting it to AC power and putting Windows into High-Performance mode too?
 
What WiFi card is in your laptop? Have you tried connecting it to AC power and putting Windows into High-Performance mode too?

This is the Wi-FI card on my Windows laptop:


I checked the Power Plan and everything is set properly. I tried anyway with the charger on the laptop, room number 1, here is the result:

1697306944365.png


Without the charger I get this:

1697307045304.png


Your theory was right, sorry for the time wasted.

My MacBook Air 2019, in the room number 1, connected to the power gets 386mb in speedtest, almost the same as the Windows laptop.

I believe it's still weird I can't get around 550/600mb in speedtest via Wi-Fi when I literally have my laptop on top of the router :/

EDIT: I moved the MacBook Air in the room number 3 and I get in speedtest 450mb, 60mb more comparing to the room number 1, unbelievable lol
 
You're much too close to the router to obtain optimal results.

WiFi needs space to fully form the signal for our client devices. I find that 10 feet or more is optimal.

Your actual speeds will be determined by the server you're connected to during the speed test, and the congestion of the ISP and your immediate environment.

Right now, I would be testing different Control Channels in a systematic manner to get better results.

And be sure to test 160MHz Bandwidth too, now that you see what a difference AC power on a laptop makes.

I would remove the 'killer' software from the WiFi adapter too.
 
Last edited:
Thank you for the advice, I will switch the 5GHz-2 to 160 and make some test.

In the meantime, I took some measurements of the room, here is the updated version.

Measurements are not really precise, but definitely can be taken into consideration:

map.png
 
Last edited:

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top