1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Asus RT AX88U - Strange disconnection with ChromeCast

Discussion in 'ASUS AX Routers & Adapters' started by TheBarzFR, Jun 12, 2019.

  1. TheBarzFR

    TheBarzFR New Around Here

    Joined:
    Jun 12, 2019
    Messages:
    2
    Hi to all
    I have some trouble with router freshly bought, unpack and setting.

    The symptom is always the same, arrived at one hour of used, my ChromeCast was disconnected. No ping works.
    Acting on the Asus Wifi Box, like making Wifi change, to ask to the Wifi Box to restart Wifi services, the ChromeCast is accessible again for one hour.

    What i have already done:
    - Cold Restart
    - Defaut Setting and cold restart
    - Upgrading firmware
    - Downgrading firmware
    - Upgrading beta version firmware, (to get Wifi Insight reports)

    I looking for about settings should close to 3600 sec like the Wifi security keys rotations. Disable Wifi Trame Power Save, set to 0.

    I activated the SmartConnect function, in the case of bad Wifi signal, and helping device to switch to 2GHz in case of.
    With Wifi Insight network tools, ChromeCast was connected in 5GHz with a signal quality at -77/71 DBm.

    So now, HELP !
    :)
     
  2. InternetAficionado

    InternetAficionado New Around Here

    Joined:
    Mar 10, 2016
    Messages:
    5
    Unfortunately, I cannot add anything more to help but I did contact ASUS support as my RT-AX88U has been having the same issues with my Chromecasts as well as auto-rebooting and dropping the 2.4GHz. After doing the recommended rescue (https://www.asus.com/support/FAQ/1000814/) the rebooting and 2.4GHz dropping has seemed to stop but the Chromecasts still don't show up to cast and their settings are unavailable in the Home app even though the router shows them connected. After changing the Preamble Type from Short to Long they worked for a few hours but this morning are not castable even though again the router shows them connected. ASUS support has authorized a repair/replacement under warranty and I am waiting to hear back on stock for an advanced replacement. They collected ample logs and configuration files from me and concluded the hardware needed replacing. I'll report back if/when I ever get this new hardware.
     
    Last edited: Jul 16, 2019
  3. TheBarzFR

    TheBarzFR New Around Here

    Joined:
    Jun 12, 2019
    Messages:
    2
    No compliance with ChromeCast, confirm by Google Support. I have returned the Asus....
     
  4. Daro

    Daro New Around Here

    Joined:
    May 7, 2019
    Messages:
    7
    Chromecast has issues with Airplay Fairness setting. Turn that off and you should be good.
     
  5. InternetAficionado

    InternetAficionado New Around Here

    Joined:
    Mar 10, 2016
    Messages:
    5
    My Shield TV works fine but it's hardwired to the router, the first and 2nd gen Chromecasts are giving me trouble but worked perfectly on my RT-AC88U. I'll see what if anything the replacement RT-AX88U does but I might just have to pull out the reliable RT-AC88U again.
     
  6. InternetAficionado

    InternetAficionado New Around Here

    Joined:
    Mar 10, 2016
    Messages:
    5
    Just to update I received a new RT-AX88U from ASUS with an RMA for the old one I also purchased a new 3rd generation Chromecast and still experienced the same behavior of the Chromecast disappearing from the list of castable devices. Cycling the wifi radio on the router or rebooting it fixes it for a while but it will disappear again usually within an hour or so. Oddly it can still be cast to via Google Assistant voice control just not manually as it doesn't show up on any local devices. I suspect a setting on my router or combination of that and a bug in the firmware. I have attached screenshots of my 2.4GHz settings I do have a wifi password but removed it for the screenshot. I am on channel 11 because it is the least crowded non-overlapping channel for my environment but as I stated before I didn't have these issues with the RT-AC88U and it was set up the same way.

    rt-ax88u-24ghz-1.png rt-ax88u-24ghz-2.png
     
  7. Grisu

    Grisu Part of the Furniture

    Joined:
    Aug 28, 2014
    Messages:
    2,296
    change to WPA2 only and modulation upto MCS9, then reboot
     
    InternetAficionado likes this.
  8. rickygao

    rickygao Occasional Visitor

    Joined:
    Mar 1, 2015
    Messages:
    32
    preamble change to long, disable ptimize AMPDU aggregation and try again
     
    InternetAficionado likes this.
  9. InternetAficionado

    InternetAficionado New Around Here

    Joined:
    Mar 10, 2016
    Messages:
    5
    Grisu's recommendation has worked so far.

    Not sure why Long preamble would work since it says to use Short for high network traffic areas which I am in and Long is for older devices or so ASUS says which the 3rd Gen Chromecast is not.

    I have played with the Preamble before and it didn't seem to matter one way or the other can't recall if I've tried changing the Optimize AMPDU aggregation.

    Anyway, I do appreciate all the help and I'll report back after a couple of days what settings I've finally landed on, probably just in time to do it all again for the next firmware. :)
     
    L&LD likes this.
  10. InternetAficionado

    InternetAficionado New Around Here

    Joined:
    Mar 10, 2016
    Messages:
    5
    I guess I can claim it's fixed, thank you Grisu and everyone that contributed suggestions.

    The issue seemed to be WPA2 as I had WPA-Auto-Personal set to support a few older devices like my old PlayStation Portable. I had set the modulation back MCS 11 and the Chromecast kept working. I suppose I'll set up a "Guest" network on WPA-Auto-Personal to support the older devices.

    So for anyone that finds this thread don't discount any of the suggestions here because I can say from experience some of the suggestions here fixed this issue on the RT-AC88U and some on the RT-AX88U but it can be a slow process to troubleshoot and resolve.
     
    L&LD likes this.