Release Asuswrt-Merlin 386.2 is now available

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

Centrifuge

Senior Member
RT-86U. I was previously using 381.xx
That's some dated firmware.

Merlin posts a changelog for his firmware, really interesting reading:

- NOTE: Some users upgrading might have to go through some
database maintenance on first boot, which means the
router might be slower or have a non-responsive webui
for a while.
This can take anywhere from 5 minutes up to an hour,
depending on your model, just give it time to complete
the process.
 

Wisiwyg

Senior Member
Is the only option to try to factory rest/flash the router? Has anyone else had issues logging in after an upgrade? I don’t really want to lose my extensive config (which I haven’t backed up) if I can help it... :(
In addition to all of the other recommendations above, if you didn't perform a reset, then yes, you should perform a backup (really nice AMTM script to do this from SSH & command line), perform factory reset, then restore. If at all possible, restore everything by hand instead. If things go south you may have to do this anyway. This assumes that you've waited a day or so and have been able to get to the GUI indicating things have settled down and that you've been able to enable SSH. Good Luck!
 

StR

Regular Contributor
The issue seem to be specific to HND models. It's probably caused by the closed source nvram validation that is part of HND models, and since Asus's closed source portion is compiled without Tor support, then this variable gets lost on reboots (as the nvram version is out of sync with the jffs version).

Not sure how I can resolve this without resorting to a dirty hack. You're the first person to report this in all the years since I introduced support for the first HND model, which shows how little used Tor is.
I am using Tor on RT-AC86U, but not constantly, just for periods of time, enabling it every so often, but not daily. I didn't have a chance to update to 386.2 yet, but it was very recently (in late March) that I updated from 384.19 to 386.1_2.

With 384.19, I was using Tor - for just one Mac address, and when I was switching from "enable" to "disable", the specific Mac address was preserved (as well as through reboots). Upon updating to 386.1_2, I've found that this Mac address was lost in the settings. I haven't used the Tor since the that, so, I didn't have a chance to check how it works.

So, I am guessing the difference was introduced somewhere in 386, right?
 

MvW

Senior Member
In addition to all of the other recommendations above, if you didn't perform a reset, then yes, you should perform a backup (really nice AMTM script to do this from SSH & command line), perform factory reset, then restore. If at all possible, restore everything by hand instead. If things go south you may have to do this anyway. This assumes that you've waited a day or so and have been able to get to the GUI indicating things have settled down and that you've been able to enable SSH. Good Luck!

I would strongly advise against restoring a backup, I would definitely start from scratch and you'll have a stable a router in no time at all. For now, just wait for the Asus maintenance (the reason you can't login) to be done, so that won't take as long when you start over. When you start over (yes 'when', not 'if') follow the guide by forum member @L&LD, it help you to get a good, fresh start:

Best Practice Update/Setup Router/AiMesh Node(s) 2021
 

doc octopus

Senior Member
I have installed 386.2 on GT-AX11000 and I report that it is impossible to activate the "optimized for xbox" function
 

KingBravery

Senior Member
I have installed 386.2 on GT-AX11000 and I report that it is impossible to activate the "optimized for xbox" function
That function is only for Xbox 360
 

doc octopus

Senior Member
it doesn't work anyway, I didn't say it doesn't work with a particular console
 

Igor-KC

New Around Here
Hello everyone just the problems on the RT-AC68U speeds have dropped and I barely got into the router settings so the router worked so slowly
When I start microsoft teams and after half an hour the router freezes and it is very difficult to enter the router settings
Firmware RT-AC68U_386.2

I noticed when i do two streaming and the router freezes and the internet speed drops

-----------------------------------------------------------------------------------------------------------------------------------------------------


I solved the problem, I returned the previous firmware 386.1_2 and look at the miracles, lower CPU loads and lower RAM consumption and works more stably
 

Attachments

  • image2.PNG
    image2.PNG
    543.7 KB · Views: 108
  • image.jpg
    image.jpg
    102.9 KB · Views: 109
Last edited:

Sacco_Belmonte

New Around Here
Hi folks.

I'm trying to update from Merlin 386.1_2 to 386.2 on my AX86U

However, it says the image file is invalid. What should I do?

I'm trying to upload the "RT-AX68U_386.2_0_cferom_pureubi.w" file extracted from the zip using the manual firmware update option in the router.

I'm probably missing something as this is only the second time I use a Merlin FW.

Thank you.
 

mizwdev

Occasional Visitor
it doesn't work anyway, I didn't say it doesn't work with a particular console
Don't know if it helps, but I always putted my console in DMZ. And never had issues. The only issue I've now is my Nvidia Shield, where I see sometimes bad streaming, but first I've to rule out it is coming from my AX86u
 

XIII

Very Senior Member
For Android it can also change again when you restart your device, so I wouldn't count on it leaving that feature on for your own private network.
For iOS it works pretty good, it seems.

I use it at home; the IP address has survived modem/router/iPhone/iPad reboots and router/iPhone/iPad firmware updates.
 

wiz

Regular Contributor
I've updated my aimesh RT-ac68u and then changed the 5 G wireless channel to 104. Now the 5 Ghz works again on the aimesh node.

But if I look at the aimesh node it states there are devices connected wired that are connected to my ac5300. So it does not keep track on what is actually connected to a node or to main router. Not a big issue, but at least it now works :)

edit: typo
 
Last edited:

vit5421

Regular Contributor
Dear Merlin,
Can you consider option to set 0 in Upload/Download Bandwidth manual setting in order to disable upload (edgress) shaping or download (ingress) shaping separately for QoS?
 

Tuneboy2005

Occasional Visitor
Upgraded my GT-AX11000 last night and so far so good. Everything stable. And thank god i can use VPN server and client at the same time again. This is not possible with the ROG firmware of this router.
Keep up the good work and thx.
 

brummygit

Very Senior Member
Dear Merlin,
Can you consider option to set 0 in Upload/Download Bandwidth manual setting in order to disable upload (edgress) shaping or download (ingress) shaping separately for QoS?
It's a bug in the Cake implementation that has been fixed here https://github.com/RMerl/asuswrt-merlin.ng/commit/b334f7df256a9763a90a9ee80e6b01979b44449b and should be in the next release.

In the meantime you can install CakeQOS-Merlin alpha and use the Custom Download/Upload Parameter "unlimited" instead
 

Zork

Occasional Visitor
Just Upgrade from 384.19 to 386.2 on AC86U, all ok with the process and setting. Want to use Dnsfilter, which one is recommended or common to set?
 

Mutzli

Very Senior Member
Where is the build located?
 
Status
Not open for further replies.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top