What's new

FlexQoS Best method to optimise flex for gaming

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Not sure but maybe the PC has hardware limitations? Also remove any rules (if any) under Gear Accelerator under the Game tab. This will cause issues with QoS. It should reflect as "ON" but not rules created under.

Or try disabling the H/W acceleration and Flow Cache but due to your speeds it might not be useful (there was an issue with certain newer AX models and having these 2 features enabled caused some QoS issues). The downfall that it limits your speeds to about 300mbps.

Post in thread 'FlexQoS 1.3.2 - Flexible QoS Enhancement Script for Adaptive QoS' https://www.snbforums.com/threads/f...ent-script-for-adaptive-qos.75620/post-724769

I can only recommended testing without QoS enabled and see if you're still having issues. You might not even need QoS with your speeds.
 
Last edited:
Not sure but maybe the PC has hardware limitations? Also remove any rules (if any) under Gear Accelerator under the Game tab. This will cause issues with QoS. It should reflect as "ON" but not rules created under.

Or try disabling the H/W acceleration and Flow Cache but due to your speeds it might not be useful (there was an issue with certain newer AX models and having these 2 features enabled caused some QoS issues). The downfall that it limits your speeds to about 300mbps.

Post in thread 'FlexQoS 1.3.2 - Flexible QoS Enhancement Script for Adaptive QoS' https://www.snbforums.com/threads/f...ent-script-for-adaptive-qos.75620/post-724769

I can only recommended testing without QoS enabled and see if you're still having issues. You might not even need QoS with your speeds.
i been trying to find above settings but i can not locate HW Accelration and Flow cache settings. also attached is how i assigned Static IP. all three devices are using Real MAC Address too. just can't figure out what i am doing wrong. Connection speed is a little better on Wired PC taking it out of assingned devices list. below is a log

Code:
FlexQoS v1.3.3 released 2022-10-12
 Development channel

Debug date      : 2023-07-30 21:02:49+1000
Router Model    : GT-AX6000
Firmware Ver    : 388.4_beta1
DPI/Sig Ver     : 2.0.3 / 2.362
WAN iface       : ppp0
tc WAN iface    : eth0
IPv6            : disabled
Undf Prio       : 2
Down Band       : 471040
Up Band         : 163840
*****************
Net Control     : 1:10
Work-From-Home  : 1:17
Gaming          : 1:11
Others          : 1:15
Web Surfing     : 1:12
Streaming       : 1:13
File Transfers  : 1:16
Learn-From-Home : 1:14
*****************
Downrates       :   23552,  235520,   47104,   23552,   23552,   47104,   23552,   94208
Downceils       :  471040,  471040,  471040,  471040,  471040,  471040,  471040,  471040
Uprates         :    8192,   81920,   16384,    8192,    8192,   49152,    8192,   32768
Upceils         :  163840,  163840,  163840,  163840,  163840,  163840,  163840,  163840
*****************
iptables settings: <>>udp>>500,4500>>3<>>udp>16384:16415>>>3<>>tcp>>119,563>>5<>>tcp>>80,443>08****>5<192.168.50.47>>both>>!80,443>000000>1<192.168.50.155>>both>>!80,443>000000>1
-A FlexQoS_down -p udp -m multiport --sports 500,4500 -j MARK --set-mark 0x8006ffff/0xc03fffff
-A FlexQoS_up -p udp -m multiport --dports 500,4500 -j MARK --set-mark 0x4006ffff/0xc03fffff
-A FlexQoS_down -p udp -m multiport --dports 16384:16415 -j MARK --set-mark 0x8006ffff/0xc03fffff
-A FlexQoS_up -p udp -m multiport --sports 16384:16415 -j MARK --set-mark 0x4006ffff/0xc03fffff
-A FlexQoS_down -p tcp -m multiport --sports 119,563 -j MARK --set-mark 0x8003ffff/0xc03fffff
-A FlexQoS_up -p tcp -m multiport --dports 119,563 -j MARK --set-mark 0x4003ffff/0xc03fffff
-A FlexQoS_down -p tcp -m multiport --sports 80,443 -m mark --mark 0x80080000/0xc03f0000 -j MARK --set-mark 0x8003ffff/0xc03fffff
-A FlexQoS_up -p tcp -m multiport --dports 80,443 -m mark --mark 0x40080000/0xc03f0000 -j MARK --set-mark 0x4003ffff/0xc03fffff
-A FlexQoS_down -d 192.168.50.47 -p tcp -m multiport ! --sports 80,443 -m mark --mark 0x80000000/0xc03fffff -j MARK --set-mark 0x8008ffff/0xc03fffff
-A FlexQoS_up -s 192.168.50.47 -p tcp -m multiport ! --dports 80,443 -m mark --mark 0x40000000/0xc03fffff -j MARK --set-mark 0x4008ffff/0xc03fffff
-A FlexQoS_down -d 192.168.50.47 -p udp -m multiport ! --sports 80,443 -m mark --mark 0x80000000/0xc03fffff -j MARK --set-mark 0x8008ffff/0xc03fffff
-A FlexQoS_up -s 192.168.50.47 -p udp -m multiport ! --dports 80,443 -m mark --mark 0x40000000/0xc03fffff -j MARK --set-mark 0x4008ffff/0xc03fffff
-A FlexQoS_down -d 192.168.50.155 -p tcp -m multiport ! --sports 80,443 -m mark --mark 0x80000000/0xc03fffff -j MARK --set-mark 0x8008ffff/0xc03fffff
-A FlexQoS_up -s 192.168.50.155 -p tcp -m multiport ! --dports 80,443 -m mark --mark 0x40000000/0xc03fffff -j MARK --set-mark 0x4008ffff/0xc03fffff
-A FlexQoS_down -d 192.168.50.155 -p udp -m multiport ! --sports 80,443 -m mark --mark 0x80000000/0xc03fffff -j MARK --set-mark 0x8008ffff/0xc03fffff
-A FlexQoS_up -s 192.168.50.155 -p udp -m multiport ! --dports 80,443 -m mark --mark 0x40000000/0xc03fffff -j MARK --set-mark 0x4008ffff/0xc03fffff
*****************
appdb rules: Defaults
filter change dev br0 prio 2 protocol all handle 828::800 u32 flowid 1:15
filter change dev eth0 prio 2 protocol all handle 828::800 u32 flowid 1:15
filter add dev br0 protocol all prio 2 u32 match mark 0x8000006B 0xc03fffff flowid 1:15
filter add dev eth0 protocol all prio 2 u32 match mark 0x4000006B 0xc03fffff flowid 1:15
filter add dev br0 protocol all prio 15 u32 match mark 0x800D0007 0xc03fffff flowid 1:16
filter add dev eth0 protocol all prio 15 u32 match mark 0x400D0007 0xc03fffff flowid 1:16
filter add dev br0 protocol all prio 15 u32 match mark 0x800D0086 0xc03fffff flowid 1:16
filter add dev eth0 protocol all prio 15 u32 match mark 0x400D0086 0xc03fffff flowid 1:16
filter add dev br0 protocol all prio 15 u32 match mark 0x800D00A0 0xc03fffff flowid 1:16
filter add dev eth0 protocol all prio 15 u32 match mark 0x400D00A0 0xc03fffff flowid 1:16
filter add dev br0 protocol all prio 20 u32 match mark 0x8012003F 0xc03fffff flowid 1:12
filter add dev eth0 protocol all prio 20 u32 match mark 0x4012003F 0xc03fffff flowid 1:12
filter change dev br0 prio 22 protocol all handle 802::800 u32 flowid 1:12
filter change dev eth0 prio 22 protocol all handle 802::800 u32 flowid 1:12
filter change dev br0 prio 23 protocol all handle 804::800 u32 flowid 1:12
filter change dev eth0 prio 23 protocol all handle 804::800 u32 flowid 1:12
class change dev br0 parent 1:1 classid 1:10 htb overhead 40 linklayer atm prio 0 rate 23552Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:10 htb overhead 40 linklayer atm prio 0 rate 8192Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:11 htb overhead 40 linklayer atm prio 1 rate 235520Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:11 htb overhead 40 linklayer atm prio 1 rate 81920Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:12 htb overhead 40 linklayer atm prio 2 rate 47104Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:12 htb overhead 40 linklayer atm prio 2 rate 16384Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:13 htb overhead 40 linklayer atm prio 3 rate 23552Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:13 htb overhead 40 linklayer atm prio 3 rate 8192Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:14 htb overhead 40 linklayer atm prio 4 rate 23552Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:14 htb overhead 40 linklayer atm prio 4 rate 8192Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:15 htb overhead 40 linklayer atm prio 5 rate 47104Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:15 htb overhead 40 linklayer atm prio 5 rate 49152Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:16 htb overhead 40 linklayer atm prio 6 rate 23552Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:16 htb overhead 40 linklayer atm prio 6 rate 8192Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:17 htb overhead 40 linklayer atm prio 7 rate 94208Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:17 htb overhead 40 linklayer atm prio 7 rate 32768Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
 

Attachments

  • Screenshot 2023-07-30 205708.jpg
    Screenshot 2023-07-30 205708.jpg
    57 KB · Views: 100
just punched in below commands
runner disable
fc disable
fc flush
latency test is better on wired PC now but lost good test speed on Phone :(
its pretty much same as wired PC though
 

Attachments

  • Screenshot 2023-07-30 220016.jpg
    Screenshot 2023-07-30 220016.jpg
    75.7 KB · Views: 94
Last edited:
i been trying to find above settings but i can not locate HW Accelration and Flow cache settings. also attached is how i assigned Static IP. all three devices are using Real MAC Address too. just can't figure out what i am doing wrong. Connection speed is a little better on Wired PC taking it out of assingned devices list. below is a log

Code:
FlexQoS v1.3.3 released 2022-10-12
 Development channel

Debug date      : 2023-07-30 21:02:49+1000
Router Model    : GT-AX6000
Firmware Ver    : 388.4_beta1
DPI/Sig Ver     : 2.0.3 / 2.362
WAN iface       : ppp0
tc WAN iface    : eth0
IPv6            : disabled
Undf Prio       : 2
Down Band       : 471040
Up Band         : 163840
*****************
Net Control     : 1:10
Work-From-Home  : 1:17
Gaming          : 1:11
Others          : 1:15
Web Surfing     : 1:12
Streaming       : 1:13
File Transfers  : 1:16
Learn-From-Home : 1:14
*****************
Downrates       :   23552,  235520,   47104,   23552,   23552,   47104,   23552,   94208
Downceils       :  471040,  471040,  471040,  471040,  471040,  471040,  471040,  471040
Uprates         :    8192,   81920,   16384,    8192,    8192,   49152,    8192,   32768
Upceils         :  163840,  163840,  163840,  163840,  163840,  163840,  163840,  163840
*****************
iptables settings: <>>udp>>500,4500>>3<>>udp>16384:16415>>>3<>>tcp>>119,563>>5<>>tcp>>80,443>08****>5<192.168.50.47>>both>>!80,443>000000>1<192.168.50.155>>both>>!80,443>000000>1
-A FlexQoS_down -p udp -m multiport --sports 500,4500 -j MARK --set-mark 0x8006ffff/0xc03fffff
-A FlexQoS_up -p udp -m multiport --dports 500,4500 -j MARK --set-mark 0x4006ffff/0xc03fffff
-A FlexQoS_down -p udp -m multiport --dports 16384:16415 -j MARK --set-mark 0x8006ffff/0xc03fffff
-A FlexQoS_up -p udp -m multiport --sports 16384:16415 -j MARK --set-mark 0x4006ffff/0xc03fffff
-A FlexQoS_down -p tcp -m multiport --sports 119,563 -j MARK --set-mark 0x8003ffff/0xc03fffff
-A FlexQoS_up -p tcp -m multiport --dports 119,563 -j MARK --set-mark 0x4003ffff/0xc03fffff
-A FlexQoS_down -p tcp -m multiport --sports 80,443 -m mark --mark 0x80080000/0xc03f0000 -j MARK --set-mark 0x8003ffff/0xc03fffff
-A FlexQoS_up -p tcp -m multiport --dports 80,443 -m mark --mark 0x40080000/0xc03f0000 -j MARK --set-mark 0x4003ffff/0xc03fffff
-A FlexQoS_down -d 192.168.50.47 -p tcp -m multiport ! --sports 80,443 -m mark --mark 0x80000000/0xc03fffff -j MARK --set-mark 0x8008ffff/0xc03fffff
-A FlexQoS_up -s 192.168.50.47 -p tcp -m multiport ! --dports 80,443 -m mark --mark 0x40000000/0xc03fffff -j MARK --set-mark 0x4008ffff/0xc03fffff
-A FlexQoS_down -d 192.168.50.47 -p udp -m multiport ! --sports 80,443 -m mark --mark 0x80000000/0xc03fffff -j MARK --set-mark 0x8008ffff/0xc03fffff
-A FlexQoS_up -s 192.168.50.47 -p udp -m multiport ! --dports 80,443 -m mark --mark 0x40000000/0xc03fffff -j MARK --set-mark 0x4008ffff/0xc03fffff
-A FlexQoS_down -d 192.168.50.155 -p tcp -m multiport ! --sports 80,443 -m mark --mark 0x80000000/0xc03fffff -j MARK --set-mark 0x8008ffff/0xc03fffff
-A FlexQoS_up -s 192.168.50.155 -p tcp -m multiport ! --dports 80,443 -m mark --mark 0x40000000/0xc03fffff -j MARK --set-mark 0x4008ffff/0xc03fffff
-A FlexQoS_down -d 192.168.50.155 -p udp -m multiport ! --sports 80,443 -m mark --mark 0x80000000/0xc03fffff -j MARK --set-mark 0x8008ffff/0xc03fffff
-A FlexQoS_up -s 192.168.50.155 -p udp -m multiport ! --dports 80,443 -m mark --mark 0x40000000/0xc03fffff -j MARK --set-mark 0x4008ffff/0xc03fffff
*****************
appdb rules: Defaults
filter change dev br0 prio 2 protocol all handle 828::800 u32 flowid 1:15
filter change dev eth0 prio 2 protocol all handle 828::800 u32 flowid 1:15
filter add dev br0 protocol all prio 2 u32 match mark 0x8000006B 0xc03fffff flowid 1:15
filter add dev eth0 protocol all prio 2 u32 match mark 0x4000006B 0xc03fffff flowid 1:15
filter add dev br0 protocol all prio 15 u32 match mark 0x800D0007 0xc03fffff flowid 1:16
filter add dev eth0 protocol all prio 15 u32 match mark 0x400D0007 0xc03fffff flowid 1:16
filter add dev br0 protocol all prio 15 u32 match mark 0x800D0086 0xc03fffff flowid 1:16
filter add dev eth0 protocol all prio 15 u32 match mark 0x400D0086 0xc03fffff flowid 1:16
filter add dev br0 protocol all prio 15 u32 match mark 0x800D00A0 0xc03fffff flowid 1:16
filter add dev eth0 protocol all prio 15 u32 match mark 0x400D00A0 0xc03fffff flowid 1:16
filter add dev br0 protocol all prio 20 u32 match mark 0x8012003F 0xc03fffff flowid 1:12
filter add dev eth0 protocol all prio 20 u32 match mark 0x4012003F 0xc03fffff flowid 1:12
filter change dev br0 prio 22 protocol all handle 802::800 u32 flowid 1:12
filter change dev eth0 prio 22 protocol all handle 802::800 u32 flowid 1:12
filter change dev br0 prio 23 protocol all handle 804::800 u32 flowid 1:12
filter change dev eth0 prio 23 protocol all handle 804::800 u32 flowid 1:12
class change dev br0 parent 1:1 classid 1:10 htb overhead 40 linklayer atm prio 0 rate 23552Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:10 htb overhead 40 linklayer atm prio 0 rate 8192Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:11 htb overhead 40 linklayer atm prio 1 rate 235520Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:11 htb overhead 40 linklayer atm prio 1 rate 81920Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:12 htb overhead 40 linklayer atm prio 2 rate 47104Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:12 htb overhead 40 linklayer atm prio 2 rate 16384Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:13 htb overhead 40 linklayer atm prio 3 rate 23552Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:13 htb overhead 40 linklayer atm prio 3 rate 8192Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:14 htb overhead 40 linklayer atm prio 4 rate 23552Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:14 htb overhead 40 linklayer atm prio 4 rate 8192Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:15 htb overhead 40 linklayer atm prio 5 rate 47104Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:15 htb overhead 40 linklayer atm prio 5 rate 49152Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:16 htb overhead 40 linklayer atm prio 6 rate 23552Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:16 htb overhead 40 linklayer atm prio 6 rate 8192Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
class change dev br0 parent 1:1 classid 1:17 htb overhead 40 linklayer atm prio 7 rate 94208Kbit ceil 471040Kbit burst 58880b cburst 176640b quantum 58880
class change dev eth0 parent 1:1 classid 1:17 htb overhead 40 linklayer atm prio 7 rate 32768Kbit ceil 163840Kbit burst 20480b cburst 61440b quantum 20480
You can see under the Tools tab if "H/W Acceleration" and "Flow Cache" are enabled. However in order to disable it ..you will need to SSH into router using Putty or something similar. I see you're running the Beta fw...there was reports from the last version on the newer AX models that something was not working correctly. It may still be broken.

Also try to prioritize adaptive qos with Gaming on top. My setup is :

Gaming
Video/streaming
W-f-H
Web Surfing
Others
File transfer
L-f-H

You can setup this way (based from your debug):

Gaming*
W-f-H*
Others
Web
Streaming
File transfer
L-f-H

Lastly try testing without QoS enabled. You might not even need it.

Can you confirm no rules are under Gear Accelerator?

Best of luck.
 
Last edited:
You can see under the Tools tab if "H/W Acceleration" and "Flow Cache" are enabled. However in order to disable it ..you will need to SSH into router using Putty or something similar. I see you're running the Beta fw...there was reports from the last version on the newer AX models that something was not working correctly. It may still be broken.

Also try to prioritize adaptive qos with Gaming on top. My setup is :

Gaming
Video/streaming
W-f-H
Web Surfing
Others
File transfer
L-f-H

You can setup this way (based from your debug):

Gaming*
W-f-H*
Others
Web
Streaming
File transfer
L-f-H

Lastly try testing without QoS enabled. You might not even need it.

Can you confirm nonrukes are under Gear Accelerator?

Best of luck.
thanks. i will give it a try.
there are no rules in game options i only ever used it with default firware before i started using merlin
 
Last edited:
there is big difference between latency with FC On and Off on wirelessly connected Phone. with FC Enabled I get A+ but with FC disabled I get A. also different upload speed . Runner enable/disable doesn't really do anything for me at least for my setup for Ax6000.
I will test it on wired PC tomorrow again and report back. I know for sure that with FC disabled I get same ping response on both PC and Phone. However with FC Enabled PC is far behind Phone.
Also I have checked that I don't get a good latency by turning QoS/fw_codel off.
below screenshots are taken when no other device is using Bandwidth though.
 

Attachments

  • Screenshot_20230731-012618026~2.jpg
    Screenshot_20230731-012618026~2.jpg
    45.2 KB · Views: 67
  • Screenshot_20230731-024518356~3.jpg
    Screenshot_20230731-024518356~3.jpg
    47.2 KB · Views: 50
Last edited:
there is big difference between latency with FC On and Off on wirelessly connected Phone. with FC Enabled I get A+ but with FC disabled I get A. also different upload speed . Runner enable/disable doesn't really do anything for me at least for my setup for Ax6000.
I will test it on wired PC tomorrow again and report back. I know for sure that with FC disabled I get same ping response on both PC and Phone. However with FC Enabled PC is far behind Phone.
Also I have checked that I don't get a good latency by turning QoS/fw_codel off.
below screenshots are taken when no other device is using Bandwidth though.
If you're gaming, you definitely want to be wired if possible versus wireless.

In my environment, I do have 1 Xbox hooked up wireless upstairs with FlexQoS script installed in the router and it never lags while online gaming. My speeds are only 100/20mbps with Comcast.

Also....just remember that if you SSH into your router and disable those 2 options (H/W acceleration & FC), your speeds will be limited. So with your speeds I would definitely keep these options enabled for best results. Try to start setting the allocated bandwidth at 75% of your actual speeds for both upload & download speeds and test for a few hours.
 
Latency Below with FC enable and Disabled. it works opposite to how it works on Phone. atleast for me. Good latency on Phone FC Enabled. Good ltency on PC FC Disabled
 

Attachments

  • FC Disabled.jpg
    FC Disabled.jpg
    74.8 KB · Views: 46
  • FC Enabled.png
    FC Enabled.png
    192.7 KB · Views: 56
There will be differences on each device due to specific hardware used in these devices and testing wireless vs wired. I wouldn't focus too much on this. Due some testing while gaming, web surfing or streaming and see if you notice any lag/latency in real world.
 
Last edited:
There will be differences on each device due to specific hardware used in these devices and testing wireless vs wired. I wouldn't focus too much on this. Due some testing while gaming, web surfing or streaming and see if you notice any lag/latency in real world.
is there a work around to have FC Enabled permanently? it's automatically getting disabled randomly.
 
but isn't that something meant to be enable by default ? last thing I did was disabled it
 
Yes so if you disabled it you will need to enabled it again. Maybe a factory reset to the router will bring it back to default.
 
I did the factory reset and it's all back to normal as per FC enabled. just don't understand why PC starts to show latency when codel is on. my Hardware specs are pretty okay if not best.

PC SPECS
OS - Windows 11 Pro
MOBO- Asus TUF Gaming B550 PLUS (Wi-Fi)
CPU - AMD Razen 5 5600X
GPU - INNO 3D RTX 3050 Twin X2 OC 8GB
RAM - Corsair Vengeance 16GB DDR4 @ 3200MHz
PSU - Corsair RM-1000 Gold
KEYB- Steelseries Shift
MICE- Logitech G502 Proteus Core
SSDs - Seagate Firecuda530, TGMP34 4TB, Samsung 840 Pro
HDD - Seagate Baracuda 3 TB
PANEL - AOC Q27G2S G2 Series 155Hz G-Sync IPS
HEADSET- Razer BlackShark V2 Pro, (Steelseries H Wireless Retired)
CASE - CM Storm Trooper Stryker
COOLER- Cooler Master ML240L V2
 
I did the factory reset and it's all back to normal as per FC enabled. just don't understand why PC starts to show latency when codel is on. my Hardware specs are pretty okay if not best.

PC SPECS
OS - Windows 11 Pro
MOBO- Asus TUF Gaming B550 PLUS (Wi-Fi)
CPU - AMD Razen 5 5600X
GPU - INNO 3D RTX 3050 Twin X2 OC 8GB
RAM - Corsair Vengeance 16GB DDR4 @ 3200MHz
PSU - Corsair RM-1000 Gold
KEYB- Steelseries Shift
MICE- Logitech G502 Proteus Core
SSDs - Seagate Firecuda530, TGMP34 4TB, Samsung 840 Pro
HDD - Seagate Baracuda 3 TB
PANEL - AOC Q27G2S G2 Series 155Hz G-Sync IPS
HEADSET- Razer BlackShark V2 Pro, (Steelseries H Wireless Retired)
CASE - CM Storm Trooper Stryker
COOLER- Cooler Master ML240L V2
Is the PC wired? Also try testing with QoS off and on. Who's your ISP/modem brand and you have fiber or something else? I'm not sure what can be the problem.
 
Last edited:
Is the PC wired? Also try testing with QoS off and on. Who's your ISP/modem brand and you have fiber or something else? I'm not sure what can be the problem.
Yes bro. PC is connected to 2.5 port on ax6000. it's a fibre connection 500/50 but I do get about 550/190.
my provider is exetel it's Australian ISP. Modem is some Dasan H640Gr provided by Opticomm ( hardware provider )
and yes with QOS off I get okay kinda latency on PC but very high latency on Mobile. and I mostly play on mobile.
 
Last edited:
Yes bro. PC is connected to 2.5 port on ax6000. it's a fibre connection 500/50 but I do get about 550/190.
my provider is exetel it's Australian ISP.
and yes with QOS off I get okay kinda latency on PC but very high latency on Mobile. and I mostly play on mobile.
On the mobile, have u tried connecting to both 2.4ghz and 5ghz? Do they get the same issues. Also within FlexQoS tried to toggle the QoS mode from Fq_codel to the default (Asus) option and test again.
 
On the mobile, have u tried connecting to both 2.4ghz and 5ghz? Do they get the same issues. Also within FlexQoS tried to toggle the QoS mode from Fq_codel to the default (Asus) option and test again.
have not tried 2.4 on this modem no. will do testing on default and report
 
have not tried 2.4 on this modem no. will do testing on default and report
I get really bad latency on 2.4 GHz. I have switched to traditional QOS for now as a trial. but latency on 2.4 is bad regardless of what I do. however 2.4 is reserved for all the other devices except gaming devices
 

Attachments

  • Screenshot_20230805-144423019.jpg
    Screenshot_20230805-144423019.jpg
    47.3 KB · Views: 80

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top