Solved Cannot Add/Remove Users from OpenVPN Server

wingman1487

New Around Here
Router: RT-AX88U
Merlin Firmware: 386.3_2
VPNs Setup: 1x Server, 1x Client

Issue: I am unable to add or remove users to my OpenVPN Server.

Reproduction:
  1. When logged into the router go to (VPN > VPN Server > Server 1).
    • I can see a full list of my Users, their connection status, etc.
  2. Add in Username and Password
  3. Hit the +
  4. Hit apply
  5. Progress percentage pops up and completes, the user that was added is not in the list
  6. Try the same thing however hit the minus (-) next to a user and the similar results with the exception being that the user still remains in the list after percentage completes

This used to work just fine, connections in on the VPN server have no issues, just one day I was unable to add/remove users from my server. I've tried clearing cache/data of my main browser (Brave) and even moved to Edge as a test, all with the same results. Checking the logs I don't see anything there that gives me any idea of what's happening. Here are the logs when set to
  • VPN Server Log verbosity - 0
  • Default message leg level - debug
  • Log only messages more urgent than - all

Code:
Dec  7 18:31:02 rc_service: httpd 25283:notify_rc restart_chpass;restart_vpnserver1
Dec  7 18:31:02 custom_script: Running /jffs/scripts/service-event (args: restart chpass)
Dec  7 18:31:02 custom_script: Running /jffs/scripts/service-event (args: restart vpnserver1)
Dec  7 18:31:02 ovpn-server1[3871]: --cipher is not set. Previous OpenVPN version defaulted to BF-CBC as fallback when cipher negotiation failed in this case. If you need this fallback please add '--data-ciphers-fallback BF-CBC' to your configuration and/or add BF-CBC to --data-ciphers.
Dec  7 18:31:02 ovpn-server1[3872]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Dec  7 18:31:02 ovpn-server1[3872]: Could not determine IPv4/IPv6 protocol. Using AF_INET
 

eibgrad

Part of the Furniture
A common reason for failure to add/update/remove variables in nvram (where the usernames/passwords are stored) is insufficient nvram.

Code:
nvram get vpn_serverx_clientlist

I also recall some prior threads from users complaining about the same problem, but NOT related to the lack of nvram.

 

wingman1487

New Around Here
That thread you linked to was helpful! Thanks for pointing me over there. From the looks of it, this seems to be a problem happening to a few folks, after reading through I bit the bullet and hit the "Default" button on the VPN Server page and boom, everything is back to working like it should, thanks @eibgrad!
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top