Can't Access CFE to Erase NVRAM After Failed Upgrade

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Goldfish_Vender

New Around Here
So, my Asus RT-AC88U was acting up after internet outages so I thought maybe a firmware upgrade was advised, it failed. I tried putting it in rescue mode but it never worked, and I tried erasing the NVRAM via the WPS button which also didn't do anything.
I learned I could hook up my RPi to it[Here] so I could get in the console and try it all from there. When I power up the router it looks like it is stuck in a bootloop but after about 15-30 minutes of that, it comes out of it and loads up something. I am able to press enter to interrupt it and access a command line, however, nvram erase, doesn't work here even though it is a valid command. If I don't press Enter, it will continue to load and I can access another interface in which I have to enter a username and password(both "admin"). From here nvram erase is also valid but doesn't work.
I learned I could hit crtl+c right as it is powered on to access the CFE but no matter what I do it seems to not work, and it bootloops uninterrupted.
At this point, I don't know what else to do. I don't want to give up on this router because it would be $400 down the drain.
It is late and I need sleep, if its necessary, I can post more information, screenshots, etc tomorrow.
In the meantime, literally any suggestions you may have are appreciated, thanks.
 

Goldfish_Vender

New Around Here
I copied putty's log of the bootloop, or just the beginning of it https://pastebin.com/cCHx60JH. It will continue with this for up to half an hour.

Randomly, when it decides to continue, it reads "Null Rescue Flag." followed by "boot the image..." which is sits at for about a minute before continuing with the rest, as shown here https://pastebin.com/gQAN405M (It starts off at the last boot sequence log) Also to note, in this case, it broke the loop in less than 5 minutes. If i hit Enter where it says "Hit ENTER for console..." It will obviously bring me to a console.

Typing in 'nvram show' here will give me this https://pastebin.com/QrpfrKsF (The first time I did this it showed roughly 700 bytes of data, I don't know why it's less)

If I don't hit Enter it will carry on and when it is done I can hit Enter again to log in to another console which looks slightly different from the first. https://pastebin.com/2DtPXCNa
Typing in 'nvram show' in this console outputs a lot more than the first https://pastebin.com/EGiT26uU

My main question besides figuring out how to get into the CFE is: Does the nvram look right? I have no clue what I'm looking at regarding this.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top