What's new

Voxel Custom firmware build for Orbi LBR20 v.

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Part of the Furniture
Continuation of:

. . .

New version of my custom firmware build:

Changes (vs

1. Toolchain: Go is upgraded 1.20.5->1.21.0.
2. OpenSSL v. 1.1.1 package is upgraded 1.1.1u->1.1.1v (fixing CVE-2023-3817, CVE-2023-3446).
(score 5.3, Medium)​
(score 5.3, Medium)​
3. DNSCrypt Proxy v.2 is upgraded 2.1.4->2.1.5.
4. curl package is upgraded 8.1.2->8.2.1.
5. ethtool package is upgraded 6.3->6.4.
6. bind package is upgraded 9.18.15->9.18.18.
7. iperf3 package is upgraded 3.13->3.14.
8. util-linux package is upgraded 2.38.1->2.39.2.
9. tar package is upgraded 1.34->1.35.
10. less package is upgraded 633->643.
11. zlib package is upgraded 1.2.13->1.3.
12. libnl-tiny package is upgraded 2023-04-02->2023-07-27.
13. nghttp2 package is upgraded 1.54.0->1.55.1.
14. libjson-c package is upgraded 0.16->0.17.
15. lighttpd: add 'mod_h2.so' module to fix WebGUI access by HTTPS (@Ender).
16. Boost of kernel ('-O3', '-ftree-vectorize', '-fvect-cost-model=dynamic' compilation options for the whole kernel).
17. Host tools: upgrade UPX to 4.1.0.
18. Host tools: upgrade xz to 5.4.4.
19. Host tools: upgrade zlib to 1.3.
20. Host tools: upgrade gmp to 6.3.0.

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

Hey I already have an orbi 20 working perfectly fine.

But I'm trying to troubleshoot another one for a friend. It's making the directories but upon reboot the files disappear. It won't even save nvram noarmor 1. I've tried flashing to the original netgear firmware and back to voxel + revert to factory settings. Nothing will save after reboot.

I'm trying to get it to save cell locking upon reboot since it really likes to band hop and cause micro-disconnections. It's really confusing me. I have the current one I'm using right now and its working perfectly fine.

Following this guide https://wirelessjoint.com/viewtopic.php?t=1876

Once again thanks Voxel without you I wouldn't have internet without you. Where do we tip you at?
But I'm trying to troubleshoot another one for a friend. It's making the directories but upon reboot the files disappear.
You should read again the file QuickStart.txt (file in archive with FW). All your changes are not kept after reboot if you do now follow this:
. . .
2. Overlay partition on Circle partition.
Original stock firmware uses tmpfs overlay partition (in RAM). So all you changes in
the files/dirs are kept only until next reboot of router/satellite. If you need to keep
your changed/added files you should use /mnt/circle/overlay directory where you should
add your new or modified files keeping the dirtree of Orbi. For example, if you wish to
use your own /etc/dnscrypt-proxy-2.toml just place it into:
. . .
Just place all of your changes into /mnt/circle/overlay/ directory. For example, you need to create the file /opt/scripts/firewall-start.sh. It means the you should create this file as /mnt/circle/overlay/opt/scripts/firewall-start.sh.
It won't even save nvram noarmor 1.
Proper usage is:

nvram set noarmor=1
nvram commit

Where do we tip you at?

Button [Donate]

Good luck,
That's what I'm saying the /mnt/circle/overlay file gets removed upon reboot. I ssh in and use this command "mkdir -p /mnt/circle/overlay/opt/scripts" reboot and only /mnt/circle remains. It will not save upon reboot. I don't understand I'm using the latest firmware. These exact same commands work perfectly on my main unit Just not this one.
Thinking this router might be just dead. It won't save anything beyond /mnt/circle. And yeah I'm using it doesn't save upon reboot. Tried a bunch of 30-30-30 resets, flashing to latest netgear then back to oldest one before your flash. Just won't save anything upon reboot. Very odd. Unless you have any other ideas I'm just gonna call this thing faulty.
nvram set noarmor=1
nvram commit

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!