Deluge errors 384.13_8 on an Asus RT-AC87U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Morphy99

Occasional Visitor
Hi I wondering if anyone had any ideas why my deluge is throwing up these errors? I've installed as per the wiki and it installed but I had this locale error when installing the webui:
Code:
Unable to initialize gettext/locale!
'ngettext'
Traceback (most recent call last):
File "/opt/lib/python3.8/site-packages/deluge/i18n/util.py", line 118, in setup_translation
builtins.__dict__['_n'] = builtins.__dict__['ngettext']
KeyError: 'ngettext'
It seems to be running and working however I get this error when starting deluged:
Code:
/opt/etc/init.d/S81deluge-web stopUnhandled error in Deferred:
10:09:24 [CRITICAL][twisted :154 ] Unhandled error in Deferred:

Traceback (most recent call last):
File "/base.py", line 1292, in mainLoop

File "/base.py", line 913, in runUntilCurrent

File "/defer.py", line 460, in callback

File "/defer.py", line 568, in _startRunCallbacks

--- <exception caught="" here=""> ---
File "/defer.py", line 654, in _runCallbacks

File "/task.py", line 866, in <lambda>

File "/opt/lib/python3.8/site-packages/deluge/core/torrentmanager.py", line 232, in start
self.archive_state('Bad shutdown detected so archiving state files')
File "/opt/lib/python3.8/site-packages/deluge/core/torrentmanager.py", line 1168, in archive_state
archive_files('state', arc_filepaths, message=message)
File "/opt/lib/python3.8/site-packages/deluge/common.py", line 198, in archive_files
with tarfile.open(arc_filepath, 'w:' + arc_comp) as tar:
File "/tarfile.py", line 1617, in open

File "/tarfile.py", line 1725, in xzopen

File "/lzma.py", line 111, in __init__

builtins.MemoryError:
Temporarily disabling observer LegacyLogObserverWrapper(<bound method="" twistedloggingobserver.emit="" of="" <deluge.log.twistedloggingobserver="" object="" at="" 0xa71bd0="">>) due to exception: [Failure instance: Traceback: <class 'typeerror'="">: findCaller() takes from 1 to 2 positional arguments but 3 were given
/defer.py:568:_startRunCallbacks
/defer.py:962:__del__
/_logger.py:190:failure
/_logger.py:144:emit
--- <exception caught="" here=""> ---
/_observer.py:131:__call__
/_legacy.py:93:__call__
/opt/lib/python3.8/site-packages/deluge/log.py:204:emit
/__init__.py:1481:critical
/__init__.py:1565:_log
]
Traceback (most recent call last):
File "/defer.py", line 568, in _startRunCallbacks

File "/defer.py", line 962, in __del__

File "/_logger.py", line 190, in failure

File "/_logger.py", line 144, in emit

--- <exception caught="" here=""> ---
File "/_observer.py", line 131, in __call__

File "/_legacy.py", line 93, in __call__

File "/opt/lib/python3.8/site-packages/deluge/log.py", line 204, in emit
getattr(LoggingLoggerClass, event_dict['log_level'].name)(
File "/__init__.py", line 1481, in critical

File "/__init__.py", line 1565, in _log

builtins.TypeError: findCaller() takes from 1 to 2 positional arguments but 3 were given
This will keep popping up if I leave SSH logged in. I had a pretty major problem the other day where I ran out of memory and to reboot the router. I'm wondering if these issues are related.

EDIT: So I've solved the error with deluged starting up, must have been a corrupt config file somewhere from power loss or something.
I stopped deluged
Code:
/opt/etc/init.d/S80deluged stop
Backed up the /opt/etc/deluge folder
Removed it then copied back a few .conf files I needed. All good now. Still getting the locale error with deluge-web though.
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top