Entware how to install Python NumPy?

anguschang007

Occasional Visitor
Does anyone know how to install Python NumPy? I installed the NumPy by using pip. However, there have some errors when trying to import the NumPy module. It seems that python can't find the NumPy module.

Traceback (most recent call last):
File "/opt/lib/python3.10/site-packages/numpy/core/__init__.py", line 23, in <module>
from . import multiarray
File "/opt/lib/python3.10/site-packages/numpy/core/multiarray.py", line 10, in <module>
from . import overrides
File "/opt/lib/python3.10/site-packages/numpy/core/overrides.py", line 6, in <module>
from numpy.core._multiarray_umath import (
ModuleNotFoundError: No module named 'numpy.core._multiarray_umath'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/opt/lib/python3.10/site-packages/numpy/__init__.py", line 140, in <module>
from . import core
File "/opt/lib/python3.10/site-packages/numpy/core/__init__.py", line 49, in <module>
raise ImportError(msg)
ImportError:

IMPORTANT: PLEASE READ THIS FOR ADVICE ON HOW TO SOLVE THIS ISSUE!

Importing the numpy C-extensions failed. This error can happen for
many reasons, often due to issues with your setup or how NumPy was
installed.

We have compiled some common reasons and troubleshooting tips at:

https://numpy.org/devdocs/user/troubleshooting-importerror.html

Please note and check the following:

* The Python version is: Python3.10 from "/opt/bin/python"
* The NumPy version is: "1.23.5"

and make sure that they are the versions you expect.
Please carefully study the documentation linked above for further help.

Original error was: No module named 'numpy.core._multiarray_umath'
 

ColinTaylor

Part of the Furniture

I find the above patch that can fix the issue. Does anyone know how to install the patch?
You need to raise it as an issue on the Entware github. But as the patch is for 3.10.3 and Entware in currently on 3.10.5 it might already be included.
 

anguschang007

Occasional Visitor
You need to raise it as an issue on the Entware github. But as the patch is for 3.10.3 and Entware in currently on 3.10.5 it might already be included.
I am using 3.10.5 but the issue is alive! And Entware does not guarantee compatibility with wheels from PyPI.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top