Solved DNSMasq + Pihole?

macster2075

Very Senior Member
I run a few DNSMasq scripts to force SafeSearch network wide and it works well.

but...
I notice If I connect to Pihole's DNS, I lose the SafeSearch Feature.
Is this what is supposed to happen or I should be able to use Pihole' DNS while taking benefit of the router's DNSMasq scripts?

I posted another in the Pihole's forum as I wasn't sure where to post it. It has to with the router and it has to with pihole lol.
 

chongnt

Very Senior Member
It seems assigning pihole as your dns bypassed dnsmasq. Did you put pihole ip in your LAN DNS server? Maybe can leave it blank and try add
Code:
server=<pihole dns ip>
with actual pihole ip address in /jffs/config/dnsmasq.conf.add then run “service restart_dnsmasq” to restart it and see if it help?
 

macster2075

Very Senior Member
I found that I can add it to the Pihole here and works as intended!

piholednsmasq.jpg
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top