Release [DSL-AC68U] AsusWrt Merlin builds for DSL routers

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

patsio

New Around Here
Hi,
First post and 1st try this merlin fork to my old 5-6 years device. Yesterday, the 2.4 wifi band stopped working and i decided to try this one. Everything went smoothly, after a factory reset and the reconfiguration from scratch, is up and working again. Let's see how long it will last, a common issue with the 2.4 wifi band though. I try to upgrade to 384.16 later as i'm working from home almost a month and i don't want to brick it now.
Happy to find this forum, cheers!
 

r0bbieNZ

Occasional Visitor
Hi Gnuton - just came across this post yesterday and have updated to 384.16_0-gnuton1 from stock with no problems

I had nearly given up on custom firmware for the DSL version, as I had come across merlin last week but didn't see any reference to the DSL routers so was moving on....lucky a google search brought this up

Glad I found you and look forward to future releases!
 

r0bbieNZ

Occasional Visitor
Hi Gnuton - just came across this post yesterday and have updated to 384.16_0-gnuton1 from stock with no problems

I had nearly given up on custom firmware for the DSL version, as I had come across merlin last week but didn't see any reference to the DSL routers so was moving on....lucky a google search brought this up

Glad I found you and look forward to future releases!
Just started to get the NVRAM low warning - is this anything to worry about? or is it just a annoying warning ?

62795 / 65536 bytes
 

kernol

Very Senior Member
Just started to get the NVRAM low warning - is this anything to worry about? or is it just a annoying warning ?

62795 / 65536 bytes
I see you found my post with a fix ;).
 

L&LD

Part of the Furniture
@patsio on which router? This fork is for DSL-AC68U, not for the RT-AC68U. :)

If you flash and have no issues, you're golden. If you do, a full M&M Config/Nuclear Reset is the best way to get your router/network back to a good/known state.

Please see the link in my signature below for the guides indicated above and more. :)
 

patsio

New Around Here
@patsio on which router? This fork is for DSL-AC68U, not for the RT-AC68U. :)

If you flash and have no issues, you're golden. If you do, a full M&M Config/Nuclear Reset is the best way to get your router/network back to a good/known state.

Please see the link in my signature below for the guides indicated above and more. :)
@patsio on which router? This fork is for DSL-AC68U, not for the RT-AC68U. :)

If you flash and have no issues, you're golden. If you do, a full M&M Config/Nuclear Reset is the best way to get your router/network back to a good/known state.

Please see the link in my signature below for the guides indicated above and more. :)
I’m talking about my dsl-ac68u and gnuton release [emoji846]. Merlin said that if you jump 2-3 releases it’s wise to do a factory reset, I’m going from 384.14 to 384.16, I’ll give a try without.Thanks for all these useful info in your links!


Sent from my iPad using Tapatalk
 

Zendilar

Occasional Visitor
thank you Gnuton it works fine, I think it's a bit faster when I change pages in the gui .
I will test in the next days and I will report back.
 

umpdcw

New Around Here
Hi All

I've been looking for firmware for my DSL-AC68U that will allow it to run as an AP rather than a router, pretty much the same as whats available with the RT-AC68U.

I've tried Gnutons firmware and it installed fine, and has some nice additions over the stock firmware but it doesn't seem to have the option to run in AP mode that i could find.
I have tried using a lan port for the Wan instead of the DSL which works fine but it still running as a router which doesn't really suit what i need. I really want a single lan with a number of AP's rather than multiple routed lans.
Can somebody please confirm that AP mode is not an option gnutons build ?

So for now I've installed the merlin RT-AC68U firmware on my DSL-AC68U hardware and have it running as an AP. The current ASUS firmware also loads ok but i'll stay with Merlin for now. This solution is fine but it took me a while come to the conclusion that running this way would work and is probably the best solution. I'd be interested in other thoughts and solutions for this.

Cheers
 

Hugga Wugga

New Around Here
Just bought one of the DSL routers with the intention of downloading this firmware. I just wanted to clarify a couple of things before doing so...

I presume it should work fine in the UK?

When I set the router up using the stock firmware, I simply used the Quick setup and selected my ISP from the list. This seems to have have worked perfectly - I'm getting expected speeds and no issues. After flashing with the merlin firmware, will this quick setup still be available or should I take a backup of all my current DSL settings first?

What is the recommended flashing procedure? Is it the same as the standard Asuswrt-merlin procedure? ie through the menu on the web interface?
 

SteevieWeevie

Occasional Visitor
Just bought one of the DSL routers with the intention of downloading this firmware. I just wanted to clarify a couple of things before doing so...

I presume it should work fine in the UK?

When I set the router up using the stock firmware, I simply used the Quick setup and selected my ISP from the list. This seems to have have worked perfectly - I'm getting expected speeds and no issues. After flashing with the merlin firmware, will this quick setup still be available or should I take a backup of all my current DSL settings first?

What is the recommended flashing procedure? Is it the same as the standard Asuswrt-merlin procedure? ie through the menu on the web interface?
UK user here and I had no problems when dirty flashing GNuton firmware onto my DSL-AC68U. It is good practice to have the settings backed up somewhere but when I dirty flashed it, it kept all my DSL settings including access password and username etc.
 

Hugga Wugga

New Around Here
UK user here and I had no problems when dirty flashing GNuton firmware onto my DSL-AC68U. It is good practice to have the settings backed up somewhere but when I dirty flashed it, it kept all my DSL settings including access password and username etc.
What exactly is a 'dirty' flash? Is this the recommended way to install rather than using the menus as per the Asuswrt-merlin installation instructions on the wiki?
 

SteevieWeevie

Occasional Visitor
What exactly is a 'dirty' flash? Is this the recommended way to install rather than using the menus as per the Asuswrt-merlin installation instructions on the wiki?
A dirty flash is simply flashing the new firmware straight over the existing firmware. By comparison, a clean flash is where you clear everything and reset the router before flashing the new firmware.

You still install the firmware the same way. Download GNUton firmware, unzip it. Navigate to router menu for router update and choose the firmware file you just downloaded and upload it to the router for it to install. If you leave all your DSL-AC68U's settings alone beforehand, you have dirty flashed the firmware.

I've done this with both a 68U and a Netgear R7800 with Voxel firmware, numerous times with each. Never had any problems with either of them.
 
  • Like
Reactions: a5m

Zendilar

Occasional Visitor
After a week of operation I can confirm that it 384.16_0-gnuton1 is working flawlessly for me, and yes it has faster response in the gui.
 

roma77roma

New Around Here
Hi to all. today I have install asuswrt on my dsl modem. I have a problem, I select some port forward rules but i can't save them. when i change the page the rules disappear. There is a bug o I wrong some thing?

thanks.
 

kernol

Very Senior Member
Hi to all. today I have install asuswrt on my dsl modem. I have a problem, I select some port forward rules but i can't save them. when i change the page the rules disappear. There is a bug o I wrong some thing?

thanks.
I have 12 port forwards on my DSL-AC68U and have no problems at all.
Have you rebooted after firmware installed and configured?
 

roma77roma

New Around Here
h
I have 12 port forwards on my DSL-AC68U and have no problems at all.
Have you rebooted after firmware installed and configured?
Hi, thanks for reply. yes I have reboot it.. I tried to configure only one rule but nothing, doesn't save. tomorrow I'll try to flash firmware again.

thanks.
 

atkinsom

Regular Contributor
h


Hi, thanks for reply. yes I have reboot it.. I tried to configure only one rule but nothing, doesn't save. tomorrow I'll try to flash firmware again.

thanks.
Try different browsers. Maybe the one you’re using isn’t working right
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top