What's new

Error 0x8007010B on RT-AX88U

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

BlueiPhone

Occasional Visitor
I upgraded to a RT-AX88U from a RT-AC88U. I had two Flash drives on the RT-AC88U and could access them from my Windows 10 Pro 64 with no problems.

I have tried the current firmware RT-AX88U_384.8_2, and the current alpha (RT-AX88U_384.9_alpha1-ga6df015ee), hoping it would correct this error, but “NO” this error has been with me from day one with this router.

I have searched the forum for this error and I see this post:

https://www.snbforums.com/threads/usb3-hdd-on-ac86u-with-merlin-fw.44271/page-2#post-377483

He had the same problem that I currently have and I was wondering if anyone else with a RT-AX88U is having problems creating folders on the USB flash drives connected to their router?

I have tried all the Samba Protocols - SMBv2, SMBv1 and SMBv1+SMBv2

Tried “Simpler share naming”

Thank you.
 

Attachments

  • Picture 2.png
    Picture 2.png
    328.6 KB · Views: 999
After changing SMB version on the router, you need to reboot your computer to force it to re-negotiate the SMB protocol.
 

The RT-AX88U supports SMB v2 and I have that set on.

I have turned off SMB v1 on windows 10 pro 64

I rebooted both the Router and the PC, I still see the error…

I have posted my settings for both the PC and the router..

Thank you for all the suggestions…
 

Attachments

  • Router SMB Settings.png
    Router SMB Settings.png
    328.6 KB · Views: 755
  • Smb v1 off wind 10.PNG
    Smb v1 off wind 10.PNG
    17.3 KB · Views: 756
  • SMB error Window on Windows 10.PNG
    SMB error Window on Windows 10.PNG
    29.3 KB · Views: 863
After changing SMB version on the router, you need to reboot your computer to force it to re-negotiate the SMB protocol.
I did as you suggested... and it took it a step further...

1. Set the router to SMBv2
2. Rebooted the Router
3. Turned off SMBv1 support in Windows 10 pro... I want to used SMBv2
4. Rebooted Windows 10 Pro

Same error...???

I must be missing something...

Thank you for your reply and help...
 
Did you actually try the solution posted in that thread regarding the "store dos attributes" parameter?
Colin,

Change the samba configuration like this and try again.​

store dos attributes = yes => store dos attributes = no​

Code:
pc_replace "store dos attributes = yes" "store dos attributes = no" $CONFIG​

I do not know how to edit the samba configuration file

I thought turning setting the router to SMBv1 or SMB V2 would insert this into the conf file.

I will be happy to modify the conf file, I have installed Putty and have setup SSH access to the router.
Just need the commands to install this option into the SMB.conf file.

Thank you
 
You need to create a custom config file as described here.

The script needs the be called smb.postconf and placed in the /jffs/scripts directory. All file names are case sensitive.

The script should look like this:
Code:
#!/bin/sh
CONFIG=$1
source /usr/sbin/helper.sh

pc_replace "store dos attributes = yes" "store dos attributes = no" $CONFIG

Create the file using whichever Linux editor you are comfortable with, vi or nano. Alternatively you could use the built-in editor of the Windows program WinSCP, instead of PuTTY's command line.

Make sure the file is executable after you have created it by issuing the following command:
Code:
chmod 755 /jffs/scripts/smb.postconf

Restart the router after creating the file and check that it has worked by looking at the output of this command:
Code:
grep attrib /etc/smb.conf
 
Last edited:
You need to create a custom config file as described here.

The script needs the be called smb.conf and placed in the /jffs/configs directory. All file names are case sensitive.

The script should look like this:
Code:
#!/bin/sh
CONFIG=$1
source /usr/sbin/helper.sh

pc_replace "store dos attributes = yes" "store dos attributes = no" $CONFIG

Create the file using whichever Linux editor you are comfortable with, vi or nano. Alternatively you could use the built-in editor of the Windows program WinSCP, instead of PuTTY's command line.

Restart the router after creating the file and check that it has worked by looking at the output of this command:
Code:
grep attrib /etc/smb.conf
Files in /configs/ usually have no executable bit set. Would this code not be better placed in /jffs/scripts/smb.postconf?
 
Files in /configs/ usually have no executable bit set. Would this code not be better placed in /jffs/scripts/smb.postconf?
Doh! Yes you're correct. I've amended my original post. I wasn't paying enough attention when I was doing a copy and paste :rolleyes:.
 
You need to create a custom config file as described here.

The script needs the be called smb.postconf and placed in the /jffs/scripts directory. All file names are case sensitive.

The script should look like this:
Code:
#!/bin/sh
CONFIG=$1
source /usr/sbin/helper.sh

pc_replace "store dos attributes = yes" "store dos attributes = no" $CONFIG

Create the file using whichever Linux editor you are comfortable with, vi or nano. Alternatively you could use the built-in editor of the Windows program WinSCP, instead of PuTTY's command line.

Make sure the file is executable after you have created it by issuing the following command:
Code:
chmod 755 /jffs/scripts/smb.postconf

Restart the router after creating the file and check that it has worked by looking at the output of this command:
Code:
grep attrib /etc/smb.conf


I want to "Thank YOU" for your help and using WinSCP made the task much easier for me...
This was a great learning experience for me...

It now works great and NO error...:)

I can now start using the USB ports on the router
 
That's good news @BlueiPhone.

It looks like something may have changed on the HND routers regarding NTFS support. Maybe they're using a different driver now, or using different mount options. Who knows?:) Anyway, at least you got it working which is the main thing.
 
I was having the same problem.
I created the smb.postconf with the code above.

Weird but now I can't SSH into my router (last month worked for me)using CMD ssh admin@192.168.1.1

I have turned Off "Enable SSH Brute Force Protection", I have LAN only and password required.
It worked last time.
now getting Error:
ECDSA key for HOst 192.168.1.1 Has Changed and you have requested strict
What router admin settings will let me SSH from cmd line on PC?
I ssh'ed last month.
Now getting error
ECDSA host key for 192.168.1.3 has changed and you have requested strict checking.
 
New Info....
I switched to ENABLE Guest Login (with all its warnings) and now the Create File works.
Obviously, I don't want this, and prefer a user / password login which was working, but failed with Create Folder errors.

Any insights?
 
I was having the same problem.
I created the smb.postconf with the code above.

Weird but now I can't SSH into my router (last month worked for me)using CMD ssh admin@192.168.1.1

I have turned Off "Enable SSH Brute Force Protection", I have LAN only and password required.
It worked last time.
now getting Error:
ECDSA key for HOst 192.168.1.1 Has Changed and you have requested strict
What router admin settings will let me SSH from cmd line on PC?
I ssh'ed last month.
Now getting error
ECDSA host key for 192.168.1.3 has changed and you have requested strict checking.

Try this on your terminal:

Code:
 ssh-keygen -R 192.168.1.1

Then SSH into your router:

Code:
ssh user@192.168.1.1

Enter your password when prompted and then type:

Code:
yes

And you should be good to go.




Sent from my iPhone using Tapatalk
 
Last edited:
Try this on your terminal:

Code:
 ssh-keygen -R 192.168.1.1

Then SSH into your router:

Code:
ssh user@192.168.1.1

Enter your password when prompted and then type:

Code:
yes

And you should be good to go.




Sent from my iPhone using Tapatalk
Marin - THANK YOU! TOO SIMPLE!
 
SOLVED (this post is now edited to REFLECT corrections to misteps)


I was still having trouble with the remote FOLDER create etc.
I Completed the following all from above and reference links:
CORRECTED / DETAILED STEPS THAT SOLVED PROBLEM:
1. creation of smb.postconf using Notepad++ and saved for Linux
-->CORRECTION - I misused Notepad++. INSTEAD use DOS2UNIX on router 'inplace' via SSH. THIS WAS CRUX OF MISTAKE
#!/bin/sh
CONFIG=$1
source /usr/sbin/helper.sh
pc_replace "store dos attributes = yes" "store dos attributes = no" $CONFIG
pc_replace "socket options = IPTOS_LOWDELAY TCP_NODELAY SO_KEEPALIVE SO_RCVBUF=65536 SO_SNDBUF=65536" "socket options = IPTOS_LOWDELAY TCP_NODELAY SO_KEEPALIVE" $CONFIG
exit​
2. copied the local smb.postconf to the router /jffs/scripts/ folder via local command line:
SCP smb.postconf admin@192.168.1.1:/jffs/scripts/​
3. SSH into router
4. cd /jffs/scripts/
5. chmod 755 smb.postconf
6. login to router and @menu: Administration>>System set:
Enable JFFS custom scripts and configs = YES​
7. REBOOTED ROUTER
NOTE: afer reboot checking the /etc/smb.conf file (use CAT /etc/smb.conf
NOTE: SHOULD SHOW
"store dos attributes = no" <<<<< this needs to be confirmed to know your new smb.postconf worked after reboot.​
8. Windows 10 connection to remote USB storage //AsusGuy

9. Optional Turned on (under Turn Windows Features on and off) SMBv1.0/CIFS Client


THANKS TO COLIN FOR THE HELP THIS WEEKEND!!!
gschlact
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top