Getting RT-AC66U working with Wiz Connect smart lights - UDP ports?


New Around Here
I am setting up smart lights using the Wiz app.

On set up of a device (in this case a lightbulb) I get an error related to Broadcast on Local Network - no diagnostics or hints, just an X. Everything else has ticks so I assume it only has this issue.

The instructions say:

‘The lamps get the credentials of your router via a protocol named UDP. Please check that UDP is not blocked on your network in your router settings.’

Their support team have said – ‘Suggest you try to check your router setting whether port below are enable?

38899 and 38900 for UDP on local network’

From further trawling of the Internet

It makes a UDP broadcast to port 38899

You will get a response to port 38900

Can you give me some ideas of where this is likely to be set up?

I have looked at port forwarding and port triggering and tried various settings but it’s just guesswork and none have worked.

I assume it would normally use UPnP to get around port issues.

So can you point me in the right direction on how do to ‘enable’ these UDP ports?

I use a VirginMedia as the ISP with their box in modem mode.


Part of the Furniture
Are you connecting your lights to one of the guest WiFi networks? If so try connecting them to your main WiFi network.


New Around Here
Are you connecting your lights to one of the guest WiFi networks? If so try connecting them to your main WiFi network.
Thanks for the reply Colin.
I don't have a guest network.
I'm using the main 2.4Ghz network.
These lamps on work on 2.4Ghz only


Part of the Furniture
I don't know anything about that product but nothing is blocked on the local network. Port forwarding/triggering/UPnP is only applicable if you need to connect to a device from the internet.

Is the device running the app also connected to the 2.4GHz network?

"The lamps get the credentials of your router via a protocol named UDP" is a bit vague. What credentials are they talking about? It sounds like normal DHCP, just like any other client.

What firmware version does your router have?


New Around Here
Firmware is the latest -

This system stores configuration data in the Cloud.

My limited understanding is it uses a couple of UDP ports in the pairing process.
I think the App does a broadcast via UDP port 38899 across the LAN and waits for responses back from unpaired lamps via port 38900.

I agree the advice has been very vague - enable UDP and open a couple of ports.
Good vendors would have the required router settings.

The credentials are (as far as I know) the WiFi SSID and password - they say this is not stored in the cloud.


Part of the Furniture
Looking at this thread the UDP traffic on ports 38899 and 38900 appear to only be local so there shouldn't be a problem.

Have you confirmed that the lamp is still connected to your router's WiFi and obtained a valid IP address?


New Around Here
I've not seen evidence of a successful connection and valid IP address.
It seems to fail early in the pairing process
Fails on 'Broadcast on local network' I think the App checks everything before it proceeds. You can still carry on but it fails, even the manual pairing.

What would prevent the Broadcast?

Thinking of a factory reset of the router.

I have a network extender but that has different SSIDs and I've set up a lamp a few feet from the router so definitely no signal problems.


New Around Here

This is the error


Part of the Furniture
Sorry, I don't really understand how these kind of devices get setup. The port 38899/38900 UDP traffic would be used to connect to the device after it is successfully connected to your WiFi.

It sounds like this "broadcast" error means that the lamp cannot connect to your WiFi SSID. Do you see any messages in the router's System Log and Wireless Log related to the lamp attempting to connect?

Your picture is too small to read.


New Around Here
OK I've made some progress.

It looks like the Broadcast error is a red herring.

Not sure exactly why it has sprung into life but I did a factory reset of the router. Still got the Broadcast error but the Smart pairing now picks the lightbulbs up and they work in a lamp near the router.

I have a TP Link extender which I have set up to get a signal in the garden room. The phone picks up the signal but I think it is too weak for the bulbs. Either that or something is lost when connecting to the extender. I need a way to get a further boost to the signal in the garden.

So a combination of a spurious error message (which I thought was the showstopper), signal in garden too weak for the bulbs (but no straightforward error message telling me), a messy, inconsistent, pairing process and possibly something cleared by a factory reset of the router.

Thanks for your help Colin.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!