Google dns forcing

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

OBENZ

Regular Contributor
Looks like I have 2 rogue devices bypassing my dns set-up. I'm using a phone set-up with my ac86u on latest Merlin. Among other things, i have a nvidia shield tv and the samsung q95t both of them seems to be using some forced Google dns hardcoding. I use netflix as an example, i use my phone and my other tv to test. I live outside the US so I'm using a smartdns which is only used for streaming services to circumvent geo blocking.
Set up is as follows;
Pihole is using unbound and dnsmasq
Ac86u is set to route both Google dns requests to the pihole IP so force using the local resolver
On the dnsmasq settings in my pihole (just like x3m routing) i address a bunch of server and domains used by streaming services to be forwarded to my smartdns IP the rest will use my unbound resolver

Test 1:
Android phone connects to netflix, i can play Dave chappelle shows just fine
Test 2:
On my Q95t i do the same thing but I'm greeted by the "you appear to be using a proxy
Test 3:
On my nvidia shield TV, same show same proxy message
Test 4:
On my other samsung tv same show and it plays just fine

I tried with other shows, netflix is showing US catalogue but US listings are not playing on those 2 devices, such as Snowden, dexter and some more

I also enabled dns filtering on those 2 clients and specified the the Pihole IP as dns server but doesn't seem to do a thing

Looking for solutions
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top