What's new

iPhone not connecting to ASUS RT-AC88U

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
Suddenly only one of our apple device can't connect to this router. I have done so much research that all I understand is that it's a matter of view. From Apple's view, it's the router's problem, from ASUS's view the fault is with Apple. Here are all the facts below and everything I've done. Any help figuring out what's going on will be greatly appreciated. I got things working now, but the science guy inside of me really want's to understand what's going on. Sorry for the long post.

1. This particular iPhone 6s Plus has been using this router's wifi reliably and without problem for about a year. During this time all applicable OS and firmware updates have been installed on both devices.
2. iPhone auto updated to 12.4.1 overnight, next morning not able to connect to router. So logically assume it's the update.
3. Phone can connect to all other wifi routers and every other device (both Apple and not) can connect to ASUS router without problems.
4. Assuming the problem is with the phone, I start there. These are all the things I did with the phone in no particular order.
- hard reboot the phone
-reboot router
-reboot modem
-open guest networks
-turn 5G back on (more on this later)
-change SSID/password
- forget network and try again
-reset network settings
-erase phone and restore from backup
-roll back update to 12.4
5. At this time since all 20+ devices can connect without issue to router we still assume it's with the phone, so take it in to Verizon. They suggest that maybe how the iPhone encrypts passwords for wifi is corrupt. They suggest to take it in for warranty.
6. After about a month of all this, we notice other devices start having connection issues. Soooo maybe it's with router.
7. Go through all the crap again rebooting router/modem. Finally decide to due a factory reset of router.
8. Start setting up wifi again, and iPhone in question can now suddenly connect just fine. WOW!
9. Change IP from back to, suddenly NOTHING connects. So, change it back to factory IP
10. Can't access nursery wifi because of ASUS Smart Rule thing. Background info here: Originally when I bought this router a couple of years ago I noticed we couldn't connect to camera, printer, and TVs using our phones. The camera could only connect to 2.4G, and if our iPhones were using 5G we could see the camera, but if our iPhones were using 2.4G, then it couldn't connect to the camera. Never figured that out, but when I disabled the Smart Rule and the 5G radio button everything worked. So left it disabled.
11. iPhone from step 1 couldn't connect again!
12. So re enabled the Smart Rule and 5G and viola the iPhone connected, but not the other devices again.
13. Disabled Smart Rule, but left 5G enabled and named the SSID with the extension 5G. If iPhone uses the 5G it connects just fine to the router. If it uses the 2.4G it can't connect to router.

So at this moment, my band-aid fix is OK, but I'm not sure what to do. ASUS is really no help, and so is Apple. I don't really want to buy a new router just for this dilemma.
I came across this on a clients android phone, the only fix was to set a static IP on the device, not sure if you tried that, it’s worth a try and posting an update

Resetting was a good measure to attempt, for the static IP go to configure IP > manual.

Let us know.
Yeah, I forgot to mention in the above thread that I have set things to manual IP. That did not help either. Also, as I said earlier I have reset everything in the phone and the router. That includes resetting the network settings on the phone and when I did a factory reset of the phone those settings for reset again.

When I woke up this morning I discovered I had zero network. Neither the wired or the wireless was working anymore. Since then I have done a another factory reset using the button on the back of the router. And I cannot connect to the router through a wired connection to configure it.I know that the default IP is but even though I am directly connected my laptop cannot seem to find it. I am thinking that my router is bricked. My wireless devices can connect to the default ASUS SS ID, and no Internet.

I’ve reset the modem and contacted my ISP they can find nothing wrong with the modem. The Internet light on the modem says it’s connected while the Internet light on my router is red. However, like I said even if it was connected to the Internet I cannot log into the router and configure anything. Cables are fine nothing changed at all over the course of the night in that department so like I said earlier I’m thinking the router is toast.

Now do you all have any recommendations on another router?

Yea might have been a funky unit from factory, or if you have dirty power(unless its on a UPS or CleanVolt) that would cripple it too. Im not sold on these big gaming wifi routers, they're monsters and take up valuable space.

Why not check out one of these critters, bit of a learning curve but complete enterprise and a ton of features...
one will give you a whack of ports while the other tri-radio and meshing.





  • mikrotiks.png
    117.8 KB · Views: 435

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!