What's new

RT-AC86U: Repeater mode connecting to Android hotspot (or via USB)

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Heya folks,

I'm waiting for some more permanent internet and meanwhile I've been using my tablet (Samsung Galaxy Tab S7 FE) to share the 5G network with that. As I have several devices that needs ethernet, I've been looking at using my RT-AC86U to provide the connection for them.
I had a "proper" 5G internet service for about a week, and while the 5GHz wifi from their Router was incredibly unreliable, it worked half decent with 2.4GHz and the Asus in repeater mode, even if my Asus Router was acting up half the time. It was latest firmware with the latest security holes fixed (

I've attempted two solutions for this - figured I'd add the actual need I have above, in case someone has good ideas for what other things I can do.

1) Connect the tablet via USB and enable USB Tethering on the tablet with the router in wireless router mode. Max speed 16-17mbit, otherwise this works really well. But we're two households sharing the same internet, streaming all our TV and internet usage, and it's just not enough bandwidth. It's USB-C in the tablet, and the cable it comes with is quite thin, with USB-A in the other end that I plugged into the router. Tried both USB 2.0 and 3.0 in the router. ** Seems to be something with the tablet, as my phone at 4G gives 200+mbit, and my old 4G phone gives 60-70mbit np.

2) Set up a separate wifi network on the tablet with the router in Repeater mode connected to the tablet, sharing internet for my ethernet devices. I run into two different issues with this.

- If I try to share internet from the tablet using 5GHz wifi, the wifi does not appear in the list the router gives me when trying to set it up. I didn't see any other 5GHz networks either, so assuming it was a bug of sorts, I decided to give Merlin a try. After installing latest Merlin build for my router, I now see other 5GHz wifi networks, but still not the tablet wifi. I see the 5GHz tablet network with my mobile phone and can connect to it, and it works. If I try to manually add it, I'm given message that the password is wrong. It isn't though, so guess it's just a generic "I can't connect" message.

- If I share internet from the tablet using 2.4GHz, then this works and I connect at a much higher rate (150ish) than the 1st attempt with usb tethering. However, for some reason, I no longer get IP addresses from the Tablet. So whether it's the tablet that refuses requests through the router (repeater), or the router not letting the requests through, I have no idea. I also don't quite know where to start looking. I've tried local IP with both using DHCP on the router, and setting a static IP (which is always a risk since I can't controll it on the tablet). If I could've, I'd have wanted to run the DHCP server on the router, which is why the 1st option would've been ideal, since the DHCP server isn't available in repeater mode.

2.4GHz worked alright with the proper 5G internet I had for a week, however I also had partially the issue with dhcp requests not going though. It worked sometimes, but if I touched it, it was likely to fail and I had to set it up over again. I also saw 5GHz wifi back then, but that didn't work at all (I blame the ISP router on that one).

Any suggestion for how I can get this to work? Ideally I'd get better speeds on the 1st solution with usb tethering, but if I could get DHCP to work properly on the second that would be decent as well.

Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!