Issue after enabling access to bridged modem UI - AC3100

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Mad Hoser

New Around Here
Hello all - I'm by far not a networking guru,

I over the past week have purchased an ASUS RT-AC3100, installed asuswrt-merlin (so awesome!), and then pihole alongside my Emby server ( using these instructions: - https://www.reddit.com/r/pihole/comments/dfm5j4/guide_for_asuswrtmerlin_users_with_screenshots/ ). Latest versions of all btw.

Everything has been rocking along swimmingly, until I tried doing the no-script access to my bridged ISP Modem ( https://github.com/RMerl/asuswrt-merlin/wiki/Access-modem-Web-UI-on-WAN-port-(no-script) ). The script worked for about 2 minutes and then my network came down to a craaaaaaaawl and no-dns resolution for anyone / any device. Even getting to the router web gui took a good 1 minute or more using the IP address. Once I changed "Get the WAN IP automatically" back to YES, everything went back to normal! I'm thankful for not having to do a hard factory reset...

Router IP = 192.168.1.1
PiHole is on = 192.168.1.40
Modem is on = 192.168.100.1

Any insights on what may be happening, or even what I can turn on debug/log wise if I decide to try and enable the no-script UI access again to work the issue out?
 

ColinTaylor

Part of the Furniture
It sounds like that wiki technique simply doesn't work with your type of modem. (Personally I've never come across a model where that would work.)

Did you confirm that Internet services are available from your modem when using the alternative IP address (192.168.0.1 in the wiki example)?
 

Mad Hoser

New Around Here
It sounds like that wiki technique simply doesn't work with your type of modem. (Personally I've never come across a model where that would work.)

Did you confirm that Internet services are available from your modem when using the alternative IP address (192.168.0.1 in the wiki example)?

I know that in premise it does function as I had done something similar with my old router and Tomato firmware. To be fair however, pihole wasn't in place then, so I'm not sure how that would factor in.
 

ColinTaylor

Part of the Furniture
So what IP address, subnet mask and gateway address are you using for the router's WAN interface?

What model modem do you have?
 

Mad Hoser

New Around Here
So what IP address, subnet mask and gateway address are you using for the router's WAN interface?

What model modem do you have?

When it broke I used:

IP Address 192.168.100.2
Subnet Mask 255.255.255.0
Default Gateway 192.168.100.1 <== the IP of the Modem

It is a Hitron 4582.

In Tomato the settings where like so (not actual screen shot from my older system - but it was the same)

upload_2020-2-20_23-24-32.png
 

ColinTaylor

Part of the Furniture
I don't believe the "no-script" method is appropriate for what you're trying to do. All that seems to do is allow you access to the modem at the expense of disconnecting internet access.

In the first instance I would simply try accessing your modem at 192.168.100.1 without any changes to the router. In many cases (like my own) this "just works".

If you have a modem that only allows access to devices on its own subnet then you will need to create a couple of scripts. This is the same as what that option does in the Tomato setup. The scripts can be seen in this post: https://www.snbforums.com/threads/access-modem-configuration-page.11957/page-2#post-289752

Of course for testing purposes you could just type those commands in from a SSH session to make sure they work for you.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top