LED setting not surviving reboot

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

helloguys

Occasional Visitor
RT-AC86U, Merlin 386. It looks like when the router reboots, the LED lights will turn on regardless the previous settings.
 

KevTech

Very Senior Member
Does this happen with the setting in the GUI or pushing the button on the back of the router?
 

helloguys

Occasional Visitor
With settings in the GUI. Here's the way to reproduce the problem:

1) From GUI (either web portal or iPhone App) set the LED to off. Visual confirm that the LED is off on the router chassis).
2) Reboot the router. All LED come back on.
3) From GUI, the setting is still showing "off" (which is contradicting with what's showing on the router chassis). In order to turn the LED off, I'd have to:
a) Put the setting to "On" position.
b) Put the setting to "Off" position again.

Does this happen with the setting in the GUI or pushing the button on the back of the router?
 

Wisiwyg

Senior Member
With settings in the GUI. Here's the way to reproduce the problem:

1) From GUI (either web portal or iPhone App) set the LED to off. Visual confirm that the LED is off on the router chassis).
2) Reboot the router. All LED come back on.
3) From GUI, the setting is still showing "off" (which is contradicting with what's showing on the router chassis). In order to turn the LED off, I'd have to:
a) Put the setting to "On" position.
b) Put the setting to "Off" position again.
Can confirm this. Has been happening for most of the Alpha & Beta versions for my AX88U. But It hasn't bugged me because you can run #3 and leds go off. Bigger fish...
 

KevTech

Very Senior Member
What happens if you just turn off the LED with the button on the back of the router?
 

Diamond67

Senior Member
RT-AC86U, Merlin 386. It looks like when the router reboots, the LED lights will turn on regardless the previous settings.

With my router (AC68U) I use the "manage LED control" (lc) of amtm (or is it provided by Diversion?). Anyway, after every reboot it remembers that I wanna have LEDs off.
 

RMerlin

Asuswrt-Merlin dev
Can't reproduce on my own RT-AC86U. What is the output from:

Code:
nvram get led_disable

Make sure you don't have something else overriding this setting (for example a script).
 

Wisiwyg

Senior Member
What is the output from:

Code:
nvram get led_disable
I ran the code and received "0"

Then ran:
Code:
nvram set led_disable=1

And set it to 1. I'll see if this sticks.


Update: This appears to have worked - I have to wait for a time when no one is using the internet before I can test this sort of thing.

For full update:

SSH to your node - use the IP address in your DHCP assignment list, use the same ID/PW as main mesh router.

issue code
Code:
nvram get led_disable
should return just "0"

issue code
Code:
nvram set led_disable=1
nvram commit

you can try "nvram get led_disable" again to confirm you return "1"

reboot to confirm, either by looking at the mesh node and confirming no leds or using SSH and "nvram get led_disable" to confirm =1
 
Last edited:

Andy1932

Senior Member
I ran the code and received "0"

Then ran:
Code:
nvram set led_disable=1

And set it to 1. I'll see if this sticks.


Update: This appears to have worked - I have to wait for a time when no one is using the internet before I can test this sort of thing.

For full update:

SSH to your node - use the IP address in your DHCP assignment list, use the same ID/PW as main mesh router.

issue code
Code:
nvram get led_disable
should return just "0"

issue code
Code:
nvram set led_disable=1
nvram commit

you can try "nvram get led_disable" again to confirm you return "1"

reboot to confirm, either by looking at the mesh node and confirming no leds or using SSH and "nvram get led_disable" to confirm =1
Thanks for this. I was having the same issue with a 58u as an aimesh node.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top