What's new

Limiting RAM when using Transmission

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

JGMan

New Around Here
Hey All,

ASUS Merlin 388.2_2 on RT-AX88U

I’m trying to keep the RAM usage under control when I use transmission via entware. I have a 2GB SWAP file setup and I’ve configured transmission to use my 256GB pen drive attached. Downloads do complete successfully.

400MB (40%) free RAM before downloading a torrent. Once the torrent starts, it eats the RAM up until 97% utilised.

I’m assuming the torrent is being downloaded into RAM, then either using the SWAP file, or copying direct to the destination. This is a problem, as even when the torrent is done, the RAM is permanently full until I remove/trash the download. Assuming RAM at 97% will be having a negative impact to other services on the router, including WiFi

I’ve tried changing the “cache-size-mb”, “peer-global-limit” and “peer-limit-per-torrent” but no difference.

Have I got a configuration error here? Is there a way to download straight to storage/SWAP, or even just restrict how much RAM transmission can use?

Thanks in advance!
 
Sounds like a similar issue others have experienced, and commented on, when writing files to a USB device attached to the router. The RAM usage goes to 97% and stays there for a while or until the file is deleted or the cache is otherwise emptied out. Some have indicated the router should intelligently handle the cache and that the high RAM usage isn't something to be concerned about. There are various lines of code (see my post here) one can run via SSH to clean out the cache if one is concerned about the RAM hitting the high 90's after writing files to the USB device. Example line of code to run via SSH on the router:
Code:
sync && echo 3 > /proc/sys/vm/drop_caches
 
@JGMan As alluded to in the previous post this is really nothing to do with Transmission. It is the normal memory management mechanism of Linux when writing to storage devices. So there's nothing to fix. You could periodically clear the system cache but then you would be negatively impacting the performance of the storage device.
 
Thanks for the advice and guidance, all!

Considering I am now trusting that the RAM will effectively manage itself, how do you think I should approach the “cache-size-mb”, “peer-global-limit” and “peer-limit-per-torrent” settings?

Considering it will likely always be at 97%, do these settings really matter? Or should I calculate the numbers to use, based on 400MB free RAM?
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top