What's new

MoCA - Ethernet - PC works. MoCA - Ethernet - Switch - PC does not. Confused.

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

kingleif

New Around Here
I have an odd problem. I've been using a MoCA network for over 6 months with no issues. In our basement we had a MoCA adapter going to a simple 8-port Dlink switch connected to several devices, and everything worked fine.

Something changed, now, if I plug the ethernet from the MoCA adapter in the basement directly into a PC, that PC grabs an IP, gets the internet, everything works fine.

If I take the same ethernet cable, plug it back into the switch, and plug the PC into the switch, the PC gets an IP address, but can't access the internet. I swapped out the switch (which works fine in another part of the house/network), still not working. I even replaced both ends of the MoCA network with new MoCA adapters (previously had an ISP supplied Actiontec EBC6200xx) and that hasn't changed anything. I've powered the whole network down, turned things on in order, I've even swapped routers.

I'm stumped.

Has anyone seen anything like this?
 

Attachments

  • HomeNetwork.png
    HomeNetwork.png
    52.6 KB · Views: 74
Which components have you not substituted while trying to debug this? I'm suspicious of the cable from the switch to the PC, and maybe even the PC itself.

A month or two back I wasted much of a Saturday trying to debug a roughly comparable problem, and eventually realized I hadn't pushed the ethernet cable into the device's RJ45 jack hard enough to latch. So it worked for a little bit (long enough to grab a DHCP address) but not so much after I'd let go. Moral: doesn't hurt to question your own reconnection efforts along with the devices ...
 
Thanks for the reply!

I did need to question my troubleshooting efforts. It wasn't a cable, but a combination of powering everything down for a longer period of time as well as doing a full factory reset on the router. Whatever gremlin snuck in seems to have gone.

I think something was happening with dhcp leases and conflicting IP's.
 
I had a similar issue with my MoCA adapters and the DHCP server. It took me a while to figure it out. Our computers seemed to be connected to the network but were not accessing the internet. It seems like you've figured it out your issue by rebooting, which I initially did as well after a reboot, only for it to happen again.

So I will offer what ultimately helped me in case it happens to you again. Do you have a POE MoCA filter? I don't think you mentioned if you had this or not? it looks something like this:
1675127290152.png


Your ISP may have installed one on the coax cable to prevent signal leakage outside your property. It would be somewhere near the point of entry in your home.

Anyway, when I installed my MoCA adapters I just assumed I needed to move this filter to be on the coax cable closer to the coax point of entry than the MoCA adapter. This seemed ok for a time, but then I had issues with the DHCP and IP addresses. After some rearranging I realized I needed a second POE filter, near the router/modem of the second MoCA adapter.

I think the issue could be that your MoCA adapter is sending IP requests to the wrong DHCP server (maybe to your ISP modem?). At least that's what I think happened to me. The second POE filter helps to contain signals between the MoCA adapers and the designated DHCP server of your home router.

So bottom line, for me, I need two POE filters, one on the coax line between the first MoCA adapter and where the cable enters my property, the second on the coax line between the second MoCA adapter and the router/modem. Almost like bookends for the two adapters.

Not sure how clear that explanation is.
 
That is the std install practice where the frequency bands between MOCA2 and DOCCIS do not overlap. It will be an issue as DOCCIS roll outs continue that use bands that overlap with MOCA2.
 
Interesting... I clearly missed that when researching for MoCA installation.
I thought generally only one filter was needed, and discovering that I needed a second was related more to my specific setup.
 
if the coax using moca is isolated from the cable modem, then yes, only at the input port on the highest level splitter in the layout. Some moca splitters have this built in.
If shared with modem, then additional filtering needed to reduce interference on the modem even though on separate bands. The modems are not specifically designed to filter out the moca frequencies in all cases. They generally were designed without thinking about moca or satellite for that matter.
 
I still don't know what happened in my particular case. Everything has been working since I last updated.

I don't have any MoCA filters installed. My ISP uses fibre to the house, so I've disconnected the cable connection to the outside world (the outside world being the other competing ISP in my city - that does use DOCCIS). Am I correct in assuming that I don't need a filter? What would I be filtering?
 
the MOCA POE filter would improve the signal quality for the MOCA network. It is always recommended, but may not be "required" by the specific installation.
All coax must be terminated with either a 75 ohm resistor cap or equipment. This includes unused splitter ports. Otherwise, RF reflections are created or the piece of coax becomes an antenna. The noise created on the coax may or may not be significant for the installation but it does increase the noise floor reducing usable signal.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top