What's new

Need help with syslog being spammed with kernel messages

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Davidncali001

Regular Contributor
I don’t know why my syslog is jam packed with these kernel messages. I don’t know what is going on or how to remove them.

The router is working fine and doesn’t seem to be a problem, however I’m not sure if it’s something I should be concerned about.

Thanks,

David



12:00:04 RT-AC86U-3E70 kernel: x17: 00000000004311d8 x16: 0000007f9e236340
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x15: 081a171b01000000 x14: 0015094128000000
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x13: 0000000000000000 x12: 000000000000001f
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x11: 0101010101010101 x10: 0000000000000006
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x9 : 7f7f7f7f7f7fffff x8 : 00000000000001a9
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x7 : 000000011b171a08 x6 : 000000011b171a08
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x5 : 081a171b01000000 x4 : 0000000000000000
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x3 : a9a2afa480000000 x2 : 0000007f9de6dec0
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x1 : 0000007fd1151938 x0 : 0000000000000040
Nov 4 12:00:04 RT-AC86U-3E70 kernel: dig[27306]: syscall 425
Nov 4 12:00:04 RT-AC86U-3E70 kernel: Code: aa0503e4 aa0603e5 aa0703e6 d4000001 (b13ffc1f)
Nov 4 12:00:04 RT-AC86U-3E70 kernel: CPU: 0 PID: 27306 Comm: dig Tainted: P O 4.1.27 #2
Nov 4 12:00:04 RT-AC86U-3E70 kernel: Hardware name: Broadcom-v8A (DT)
Nov 4 12:00:04 RT-AC86U-3E70 kernel: task: ffffffc01e04f480 ti: ffffffc012c88000 task.ti: ffffffc012c88000
Nov 4 12:00:04 RT-AC86U-3E70 kernel: PC is at 0x7f9de6dee4
Nov 4 12:00:04 RT-AC86U-3E70 kernel: LR is at 0x7f9dd853a4
Nov 4 12:00:04 RT-AC86U-3E70 kernel: pc : [<0000007f9de6dee4>] lr : [<0000007f9dd853a4>] pstate: 20000000
Nov 4 12:00:04 RT-AC86U-3E70 kernel: sp : 0000007fd11518c0
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x29: 0000007fd11518c0 x28: 0000000000000003
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x27: 0000000000000000 x26: 0000000000000000
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x25: 0000000000000000 x24: 0000000000000000
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x23: 0000000000000100 x22: 0000000000000000
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x21: 0000007f9dda363c x20: 000000003ef85cc0
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x19: 0000007f9dda3000 x18: 0000000000000000
Nov 4 12:00:04 RT-AC86U-3E70 kernel: x17: 00000000004311d8 x16: 0000007f9e236340
 

Attachments

  • IMG_5183.png
    IMG_5183.png
    137.4 KB · Views: 31
Do you have entware installed with dig installed?
I have Entware installed but I haven’t installed Dig. I have Diversion, Scribe, ScMerlin and Skynet installed and I’m currently on the latest version of RMerlins firmware for my router.

Is this a Dig problem? If so could you please let me know how to go about fixing it?

Thank You
 
There is a problem with dig, which is used by one or more of your addon scripts. Try updating Entware.

Code:
opkg update
opkg upgrade
 
There is a problem with dig, which is used by one or more of your addon scripts. Try updating Entware.

Code:
opkg update
opkg upgrade
Hello, I tried running those two commands but the Dig is still showing Kernel errors. I changed USB sticks and reformatted JFFS and the USB Drive, then resonated all the same scripts I had before but I’m still getting those pesky spam messages about Dig and the Kernel.

Would doing a full reset of my router and reformatting my USB stick again after resetting the router help out any you think?

I guess it’s not a big deal because everything still runs fine as far as I know. It’s just the pages and pages of Dig Kernel spam that gets to me.

If you think I should just leave well enough alone I will. If you have any more tips I would appreciate it greatly.

Thank You,

David
 
Same problem has been reported in other threads. It was a bug in Entware. See this post and the following one:


So based on that try this:
Code:
opkg update
opkg remove --force-depends bind-dig
opkg install bind-dig

opkg remove --force-depends bind-libs
opkg install bind-libs

opkg remove --force-depends libuv
opkg install libuv

But if you had wiped your USB drive and reinstalled Entware the commands above ought not to be necessary. :confused:
 
Last edited:
After some digging ;) I had them again after an clean install. I deleted uiDivStats and rebooted. Clean logs.
 
After some digging ;) I had them again after a clean install. I deleted uiDivStats and rebooted. Clean logs.
Thank You, uninstalling uiDivStats and a reboot did the trick for me as well. No more spammed Kernel Dig messages.

Thanks to everyone who made suggestions to me, I really appreciate it!
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Members online

Top