Diversion New user of amtm - application will not start - newbie help please

wobbli

New Around Here
Running fw version 384.13_10 on RT-AC3200 - cannot start application - any pointers?
_____________________________________________

Initializing amtm for first run

Getting from fwupdate.asuswrt-merlin.net
! Module amtm.mod download failed
! using fallback server diversion.ch
! Module amtm.mod download failed

All download attempts failed,
exiting amtm now.

Check that both domains properly resolve
on this router:
- fwupdate.asuswrt-merlin.net
- diversion.ch

******@RT-AC3200-18A0:/tmp/home/root# ping diversion.ch
PING diversion.ch (80.74.145.140): 56 data bytes
64 bytes from 80.74.145.140: seq=0 ttl=56 time=126.524 ms
64 bytes from 80.74.145.140: seq=1 ttl=56 time=123.358 ms
^C
--- diversion.ch ping statistics ---
7 packets transmitted, 7 packets received, 0% packet loss
round-trip min/avg/max = 123.358/126.736/133.624 ms

******@RT-AC3200-18A0:/tmp/home/root# ping fwupdate.asuswrt-merlin.net
PING fwupdate.asuswrt-merlin.net (104.21.28.144): 56 data bytes
64 bytes from 104.21.28.144: seq=0 ttl=55 time=36.412 ms
64 bytes from 104.21.28.144: seq=1 ttl=55 time=33.204 ms
^C
--- fwupdate.asuswrt-merlin.net ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 31.343/34.156/36.412 ms
 

ColinTaylor

Part of the Furniture
There is a known issue trying to run the built-in version of amtm on such an old firmware. Try downloading the current version manually:

Code:
curl -Os https://diversion.ch/amtm/amtm && sh amtm
 

wobbli

New Around Here
thanks for the quick response; I appreciate it

I had tried that but there's a certificate error so removing s (silent) and adding k (insecure) to the command line provides

Code:
curl -Ok https://diversion.ch/amtm/amtm

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 37153 100 37153 0 0 25120 0 0:00:01 0:00:01 --:--:-- 46038

so appears to download any update, then

Code:
sh amtm

gives same result above
 
Last edited:

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top