What's new

YazFi Prevent guests from being given IPv6 access

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Deetlemore

Occasional Visitor
I'm in a bit over my head when it comes to configuration outside of the GUI, so I figured I'd ask this before I spend the next few days fumbling around on my own.

Is there a simple way to prevent guests from being given IPv6 access when using YazFi's one-way option? I don't necessarily need guests to have IPv6 access, and the threads and Github page I've been pouring over aren't sinking in. I figured just blocking all IPv6 to/from guests may be the easier route, but I'm not sure where to start.
 
I'm in a bit over my head when it comes to configuration outside of the GUI, so I figured I'd ask this before I spend the next few days fumbling around on my own.

Is there a simple way to prevent guests from being given IPv6 access when using YazFi's one-way option? I don't necessarily need guests to have IPv6 access, and the threads and Github page I've been pouring over aren't sinking in. I figured just blocking all IPv6 to/from guests may be the easier route, but I'm not sure where to start.
That is strange, none of my guests have ipv6 when on guestnetworks using yazfi, do you mind sharing some of your statistical findings showing that actual ipv6 is working on these guest networks? Yazfi doesn't even create the extra routes necessary for ipv6 to work on the yazfi created interfaces.. Are you experiencing this on guest network 1 with aimesh options enabled? I ask because yazfi does not support the use of the aimesh guest option present on guest network options.🤔 you really need to be specific such as sharing your statistical findings supporting the ipv6 claim. Also you need to share screenshots of both of your enabled non-yazfi and yazfi guest network settings.

@Martinski did ipv6 work with your guest clients when you were improving YazFi?
 
Last edited:
These two threads document the issue:


If I connect to my guest network, I am given an IPv6 address with the same prefix as my LAN, whereas IPv4 uses a different subnet. I'm using guest network 2, and have native IPv6 enabled.

I'll just stick to the stock guest network for now, I don't have the brains for network config at this level.
 
These two threads document the issue:


If I connect to my guest network, I am given an IPv6 address with the same prefix as my LAN, whereas IPv4 uses a different subnet. I'm using guest network 2, and have native IPv6 enabled.

I'll just stick to the stock guest network for now, I don't have the brains for network config at this level.
Maybe I will just write a tutorial for properly enabling ipv6 support on YazFi.
 
These two threads document the issue:


If I connect to my guest network, I am given an IPv6 address with the same prefix as my LAN, whereas IPv4 uses a different subnet. I'm using guest network 2, and have native IPv6 enabled.

I'll just stick to the stock guest network for now, I don't have the brains for network config at this level.
I reached about this far:
https://github.com/ZebMcKayhan/WireguardManager#setup-yazfi-for-ipv6-subnet-to-route-out-wg-vpn
I never did manage to get them to not be assigned a lan ipv6, my only solution was to kick the guest interfaces out of the br0 bridge. The guide is for using Wireguard but it may give you some ideas.

Perhaps @SomeWhereOverTheRainBow has manage a better solution? I kind of stopped when reaching this far and didnt bather searching other ways as it was working.
 
I reached about this far:
https://github.com/ZebMcKayhan/WireguardManager#setup-yazfi-for-ipv6-subnet-to-route-out-wg-vpn
I never did manage to get them to not be assigned a lan ipv6, my only solution was to kick the guest interfaces out of the br0 bridge. The guide is for using Wireguard but it may give you some ideas.

Perhaps @SomeWhereOverTheRainBow has manage a better solution? I kind of stopped when reaching this far and didnt bather searching other ways as it was working.


The biggest challenge is there are so many inner workings to consider. I think you were very close.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top