1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

RT AC68U USB Tethering Fails After LG V30 Android 9 Update

Discussion in 'ASUS AC Routers & Adapters' started by NotInKansasAnymore, Oct 22, 2019.

  1. NotInKansasAnymore

    NotInKansasAnymore New Around Here

    Joined:
    Oct 21, 2019
    Messages:
    2
    Network: T-Mobile
    Booster: Cel-Fi DUO+
    USB Tether:LG V30 phone
    Router: ASUS RT-AC68U
    Firmware: 3.0.0.4.384_81049-gbd61205

    For lack of any other (non-satellite) internet provider at a remote location, this configuration was implemented because the clients did not want Wi-Fi but needed adaptive QOS for gaming and video streaming via Ethernet to ~10 devices.

    The cell tower barely provided enough signal for a booster. Cell phones had to be held near the windows facing the tower prior to boosting. Phones were chosen over hotspot devices due to features, flexibility and USB tethering.

    The pre/post Android 9 network was also tested with:
    • a second Android 8 LG V30
    • a T-Mobile Personal Cellspot (RT-AC68U running proprietary software)
    • a second Cel-Fi DUO+.
    All worked satisfactorily prior to updating. After Android 9, the RT-AC68U router thinks the network cable is disconnected, though it recognizes the cellphone's USB3 connection and identifies the phone. The other router also fails to connect to the internet.

    Both Android 9 phones' USB tethering was tested with individual PCs running Windows 7 64 bit OS. So the network without a router works fine, regardless of which PC, phone or booster used.

    ipconfig shows that Windows 7 networking, without the ASUS router, utilizes IPv6 to access the internet through the T-Mobile network, but the ASUS router cannot, though its running its latest firmware.

    I have tried various published IPv6 configurations for the ASUS router, but nothing avails an internet connection, for the router, or devices on the LAN.

    To force the network to use IPv4, IPv6 was disabled in the router, and the APN set to IPv4 in the phone. No internet access.

    Has anyone utilized USB tethering in this manner and have overcome the IPv4/IPv6 hurdles?

    Thanks!
     
    Last edited: Oct 26, 2019
  2. Greg72

    Greg72 Regular Contributor

    Joined:
    Sep 24, 2019
    Messages:
    124
    Location:
    Central Illinois
    Turn off IPv6.
     
  3. NotInKansasAnymore

    NotInKansasAnymore New Around Here

    Joined:
    Oct 21, 2019
    Messages:
    2
    Thanks Greg!
    I set the phone's APN to IPv4 and disabled IPv6 in the router.
    Still no router internet access ...
     
    Last edited: Oct 25, 2019