What's new

RT-AX86U can't upgrade from and settings won't save

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

I asked for help from another forum member (ColinTaylor) and after trying some stuff, he said it's most likely a flash memory issue and I would have to RMA, ASUS support has been unhelpful as always refusing to RMA, so I'll try calling them tomorrow to see if anything changes but I'm just going to give up at this point and never buy anything asus again.

OK, sorry to hear no resolve currently for you. I read your conversation with him and others. I only asked because I only saw you mention manual download from the site vs updating through the router directly. Anyway, hope Asus comes through for you.
I had the same issue with AX86S, I was blocked with Merlin 388.2.2 for almost 6 months.
I was not able to upgrade to any of the Merlin's firmwares, but I was able to upgrade to the latest official Asus firmware 300438824231.
Now I am still not able to upgrade to any of Merlin firmwares.
Now I am still not able to upgrade to any of Merlin firmwares.
While on stock, do a factory reset making sure to check the box. Reboot, let it settle for 5 min, then Flash RMerlin Firmware.
After RMerlin, do another reset, let settle, enter basics let settle, then enter your custom changes and reboot.

ASUS Factory Reset.JPG
It worked finally to move from stock firmware to Merlin.
I think what it helped is the 5 min shutdown and that I had removed the USB stick.
The 5 minute shutdown certainly didn't hurt, but I'd guess the real winning move (and likely sufficient in itself) was yanking the USB stick.
Actually, I was having a different issue and now I understand it.
In the last months I started having very very slow WiFi upload speed <500Kbps from my laptop to any LAN device. Initially I thought it was from my router or from the connection between router and QNAP nas.
I isolated recently that the issue was only from my laptop, so I tried updating the WiFi driver but still nothing. I removed Hyper-V and its virtual ethernet cards and boom the upload speeds came back to normal :cool:

I remembered that actually uploading the firmware file from my laptop to the ASUS router it was taking more than usually (> 4-5 min) and most probably there were some timeouts in the firmware upgrade steps.
Now I have tried to update the AiMesh node firmware and it uploaded the firmware in <1min and the firmware updated successfully.

In conclusion, the problem was from my laptop's wifi driver (interference with Hyper-V virtual cards). Very strange ...

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!