RT-AX88U Hates One Specific Client

warrius

Occasional Visitor
Hello folks. I'm at the absolute end of my rope with this problem and I'm hoping to get some assistance as I'm running out of ideas and am trying to avoid spending money I don't have to.

Problem description:
I have a RT-AX88U that's been doing well for the couple of years that I've had it. Roughly a month ago I noticed that LAN speeds were well below what we were supposed to be getting and did a factory reset of the unit as part of troubleshooting the issue with my ISP. I set up the same SSID and password as before and everything came back online as expected; except one. My wife's 2017 Macbook Pro is now a wifi pariah of my network and I'm unable to figure out why. When connected to our router it will "drop" somewhere between 5-45 minutes. When this happens, the laptop shows that it is still connected, but is unable to ping anything, router included, until wifi is toggled or the computer is restarted. This will "fix" the matter for a period of time but it reoccurs without fail a short time later.

Router Specs:
- Model: RT-AX88U
- Firmware (Stock): 3.0.0.4.388_20558-g9ebe4e1 (Note: Issue has persisted across multiple firmware versions)


Laptop Specs:
2017 MBP Mid Spec

Steps taken to test/resolve:
  • OS Update/grade (persists)
  • OS Refresh (persists)
  • Test User creation (persists)
  • Removal of VPN client (persists)
  • Location removal (persists)
  • Network removal and re-add (persists)
  • Test Admin creation (persists)
  • Safe Mode boot (persists)
  • Hardware Diag (clean)
  • Wired testing (no issues)
  • Wireless diag (nothing of note)
  • Apple Store extended testing
  • Antenna Module replacement (persists)

I'm used to fiddling with this sort of thing with Windows machines, so OSX tomfoolery is new to me. I'm staring down the barrel of either a $500 repair job for the laptop, over a grand for a new laptop (trade in is laughable), or replacing the router (one week out of warranty, naturally). I've gone through the router logs and nothing of note is coming up as best I can tell. I haven't been able to test at length on other networks due to life obligations (infant) but concerningly the issue doesn't appear to be happening when connected to a phone hotspot.

Can anyone suggest some steps to take on the router side of the equation? I'm going to do another factory reset tonight, but I'm not optimistic about that working.
 
Last edited:

warrius

Occasional Visitor
Following up, post formatting the router again the issue persists. I've reviewed the general log in the router's UI, but there is no mention of the client (IP or MAC address) when the disconnect occurs. I'm retesting again to see if if something was coming up earlier and I missed it.
 

BreakingDad

Very Senior Member
Try putting that device on a guest network. 2.4ghz only.

Had to do this for my wifes iphone SE.

They don't care about speed, just a solid connection.

Profit
 

warrius

Occasional Visitor
I'll give that a shot, but I'd be extremely interested in the root cause here and what paths there are to address it, if any. I'll be setting up shop in a starbucks for a bit this afternoon and seeing about replicating the issue there. I'm not super into the thought of having a seperate network/subnet as I'd have to go update my reverse proxy access controls, but that's just another CIDR to add to the filter I suppose.
 

degrub

Part of the Furniture
have had the same issue with multiple apple laptops over the years using cisco APs. laptop goes weeks/months without a reboot, which is the only thing that solves it. Finally put them on lan connection to reduce the frequency. It seems to be an apple/user issue as none of the other devices - win laptops, ipads, iphones, have the issue.

That being said, check the wifi signal strength ( not bars on the macbook, get a real utility) and monitor over time for interference and signal level - both at the macbook and what the AP sees from the device. If the RSSI is below (more negative ) than about -60- -65 dB, the client tends to not let go, even to the point of no response for the user. The AP may not be seeing a great signal level from the macbook ( client can be weaker radio).
 

warrius

Occasional Visitor
I'll look into that, if you have a writeup with pictures or small words on how to do that I'd appreciate the reduction of time and frustration on my end. The matter has persisted with LOS to the router in question so I'm not super up on that being the matter, but lord knows I've been wrong before (and usually am by default).

Update of note: The laptop has been happily ping-ing away for about an hour now on the dedicated 2.4Ghz guest network I set up for testing, which is as long as it's ever managed without issue since this all started (~45 minutes). That prompts some assumptions as to what may be happening here:
  • The SSID is somehow poison to this NIC (doubtful)
  • The device suddenly can't handle Smart Connect's blended bands and handoff b/t frequencies is the root cause (possible?)
  • Malevolent deities/gremlins (possible depending on your personal predilections)
  • DNS (assumed true)
  • Universe is hinting for me to go whole hog and join the Ubiquiti club

Having a dedicated guest network for just this one client seems....wasteful to me, but it may have to do until the laptop is replaced at some point in the future. It may also be a decent excuse to set up a dedicated GN for my assorted IOT devices because why not. Does having the router serve multiple SSIDs like that degrade performance/overhead of whatever band is being shared with the main wireless whatsit and the GNs?
 

bbunge

Part of the Furniture
Try putting that device on a guest network. 2.4ghz only.

Had to do this for my wifes iphone SE.

They don't care about speed, just a solid connection.

Profit
You could also use the Wireless MAC Filter and deny the client from the 5 GHz band.
 

warrius

Occasional Visitor
Oh is that what that setting does? I meant to ask if that was possible. That'll be my next test case after the offsite testing (wife wants to get out of the house and away from the baby). That would still bother me a bit as the damned thing should just work, but less than having another SSID dedicated to the cause. I'd be interested to see if the matter still happens if the device is restricted to 5ghz as well.
 

bbunge

Part of the Furniture
Keep in mind that the local Starbucks, or other provider of expensive coffee and snacks, will be single band "N" at the most and could be "B" WIFI. Not a good test as compared to an AX WIFI.
The Pumpkin Spice Latte is still great! If you want great coffee for home look up Driftaway Coffee.
 

gspannu

Senior Member
@warrius

Have you tried
a) resetting the NVRAM on your MacBook Pro?
b) try resetting the SMC?

How to reset NVRAM?
  • Shut down your Mac.
  • Turn on your Mac, then immediately press and hold these four keys together: Option, Command, P, R.
  • Release the keys after about 20 seconds, during which your Mac might appear to restart. For example, you might hear a startup sound more than once, or see the Apple logo more than once.
How to reset SMC?
 

degrub

Part of the Furniture
I'll look into that, if you have a writeup with pictures or small words on how to do that I'd appreciate the reduction of time and frustration on my end. The matter has persisted with LOS to the router in question so I'm not super up on that being the matter, but lord knows I've been wrong before (and usually am by default).

Update of note: The laptop has been happily ping-ing away for about an hour now on the dedicated 2.4Ghz guest network I set up for testing, which is as long as it's ever managed without issue since this all started (~45 minutes). That prompts some assumptions as to what may be happening here:
  • The SSID is somehow poison to this NIC (doubtful)

nope
  • The device suddenly can't handle Smart Connect's blended bands and handoff b/t frequencies is the root cause (possible?)

quite possible. Should not need it.
  • Malevolent deities/gremlins (possible depending on your personal predilections)

we call those electromagnetic waves ;-)

  • DNS (assumed true)

nah. only used to look up the host initially.

  • Universe is hinting for me to go whole hog and join the Ubiquiti club

pick your poison.
Having a dedicated guest network for just this one client seems....wasteful to me, but it may have to do until the laptop is replaced at some point in the future. It may also be a decent excuse to set up a dedicated GN for my assorted IOT devices because why not. Does having the router serve multiple SSIDs like that degrade performance/overhead of whatever band is being shared with the main wireless whatsit and the GNs?

If you do not have any clients that need a,b,g then turn those off on the radio. If you have to keep g, then turn off a,b
 

warrius

Occasional Visitor
@warrius

Have you tried
a) resetting the NVRAM on your MacBook Pro?
b) try resetting the SMC?

How to reset NVRAM?
  • Shut down your Mac.
  • Turn on your Mac, then immediately press and hold these four keys together: Option, Command, P, R.
  • Release the keys after about 20 seconds, during which your Mac might appear to restart. For example, you might hear a startup sound more than once, or see the Apple logo more than once.
How to reset SMC?

Yes and yes on that. The SMC reset make it cooperate for a bit longer than usual, but the matter came back.

nope


quite possible. Should not need it.


we call those electromagnetic waves ;-)



nah. only used to look up the host initially.



pick your poison.


If you do not have any clients that need a,b,g then turn those off on the radio. If you have to keep g, then turn off a,b

The DNS was in jest, but it's always DNS. Even if it's working. I'll make a note to look into cutting off a and b. The only thing I can think of that would be potentially affected would be an ancient raspberry pi 1 I have doing ADS-B work up in the attic, but I'd presume whatever dongle I have in it doing wifi handling is new enough to not need it.


Testing update: While restricted to the normal network and restricted to 2.4 per the MAC filtering (very helpful, thanks) the unit hummed along with no issues returned for a solid 90 minutes before I cut things off. That's well past double the length of time maxed out before. I'm now going to repeat with it limited to 5GHz.


For posterity's sake all I'm doing for testing is locking the screen to be on/unlocked and running a constant ping to google and the router in different terminal tabs. It's not the most "thorough" method, but it's good enough for government work.
 

warrius

Occasional Visitor
Oh that's interesting. The connection failed in the OS UI instantally and prompted for a password despite it not supposedly needing one. It hemmed and hawwed for a bit there, but it's on 5Ghz now. That make me think the handoff might be behind things and it's not passing auth creds from one to the other for lord knows what reason. I kind of half suspect this will go the distance on testing and that the problem won't come back if I put it back on the network unrestricted.

But I'm getting ahead of myself, testing commencing.
 

warrius

Occasional Visitor
Gonna need to quantify "close" there, but in non plane terms of scale no. I cannot speak to the DFS element. If you could elaborate or tell me where/how to check I'd be happy to verify.
 

warrius

Occasional Visitor
5Ghz only testing came back clean. Trying out just testing with the normal working config (both bands, no restrictions).
 

degrub

Part of the Furniture
 

warrius

Occasional Visitor
Well, that appears to have fixed it. I let things rock for 3 hours straight while we were out and there wasn't a problem to be had. Whatever was going on, it appears to be rooted in the moving of the client from 2.4Ghz to the 5Ghz band and the credentials not being passed/accepted b/t the two. After entering in the credentials after the error proc'd on the 5Ghz only testing everything appears to be working as expected. The question becomes, why? Is this an Asus bug? An OSX one? Should I go raise the matter with both to try and get a patch put in place to keep other poor bastards like myself from having to deal with this?
 

Brad H

Occasional Visitor
Are you using Smart Connect? If so, you may want to disable it ... Split out the 2.4 / 5 Ghz bands to their own SSID's (or as someone else suggested, you can do the same thing with a guest network). For me, SmartConnect worked for most things but I had a few devices that would always drop after a few hours. I tried adding these devices to the "Deny" list for 5Ghz....didn't help. As a temporary solution, I used a guest network but when I upgraded the firmware, I did a reset and left SmartConnect off. Solved my issues.
 

warrius

Occasional Visitor
It very likely may be an issue with SC. However I do enjoy having that be a single SSID and thing sorting themselves out so I'm content to leave well enough alone for now; especially as we have known working methods to get things playing nice again. Should something get weird again in the future I should be able to fix it via the same steps here, failing that SC can go.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top