Significant WAN speed drop on Asus RT-AC68U after a few hours


New Around Here
I'm on a 100Mbps fibre connection (yes, internet in my country is slow). My router tends to work perfectly for a while - 100 up and down but keeps dropping down to 2Mbps after a few hours. I haven't worked out the exact timing.

I am using the latest ASUSWRT-Merlin firmware (386.3_2), but the problem was occurring on stock firmware too. It's not a local network issue - the firmware speed test is showing the same results. CPU usage and RAM are fine. QoS is not enabled, and I have tried disabling STP. Hardware acceleration is on.

Just unplugging the WAN cable and plugging it back in (without resetting the router) seems to correct the issue, at least temporarily. I'm set up with a static IP.

I have tried skipping the router and connecting straight to a PC and didn't seem to have the issue, but it's possible I didn't wait long enough. It was an old laptop so couldn't stress test too easily.

I'd appreciate any ideas anyone might have on what might be driving this.

EDIT: This may be linked to my work VPN (Pulse Secure). There's a vague correlation between the problem and having just downloaded large files from a work shared drive. Note that the slow speeds are not limited to traffic actually using the VPN and the slow speeds persist even after VPN traffic is clear. The VPN is also set up on my PC, not the router so not sure how it could impact things.
Also, I tried setting logging to full detail, and nothing seemed to show up between a time when everything was working fine and when it had slowed down.
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!