What's new

SSH Issues on AX86U with Merlin 388.2_2

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Sonofdavidsfather

Occasional Visitor
My USB stick recently died, and when trying to SSH in to the router I've discovered a couple issues. I have SSH enabled, I've tried 3 different ports including 22, I've tried using ConnectBot and JuiceSSH, I have confirmed the password login is enabled, I have changed the router admin password twice, I have made sure the new password does not contain any special characters, and the router was rebooted 1 day and 11 hours ago. This router was originally setup a couple months ago and has only had 1 dirty update. Other than this, I am not finding any issues with how it is running.

The first issue is that the password doesn't work, and I get a message saying "authentication method 'password' failed".

The second issue is that sporadically nothing happens when trying to connect via SSH. There is no error or anything. My client just says "connecting to XXX.XXX.XXX.XXX via SSH". Then after a minute or so the client will give it's on error about not being able to establish a connection.

Does anyone have any ideas on this?
 
The first issue is that the password doesn't work, and I get a message saying "authentication method 'password' failed".
This usually means that you have mistyped the username or password. For example, there is a space at the beginning or end. Check the router's System Log.

Use a PC SSH client rather than a mobile "app". So if you're using Linux or Windows 11, from the command prompt enter ssh admin@192.168.50.1

The second issue is that sporadically nothing happens when trying to connect via SSH. There is no error or anything. My client just says "connecting to XXX.XXX.XXX.XXX via SSH". Then after a minute or so the client will give it's on error about not being able to establish a connection.
After the initial failed login attempts it will block new connections for five minutes.
 
This usually means that you have mistyped the username or password. For example, there is a space at the beginning or end. Check the router's System Log.

Use a PC SSH client rather than a mobile "app". So if you're using Linux or Windows 11, from the command prompt enter ssh admin@192.168.50.1


After the initial failed login attempts it will block new connections for five minutes.
Thank you very much sir. I had to do another reboot, and then I was able to login via SSH. New flash drive is up and running and all my add-ons are set back up and working
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top