What's new

Strange Mesh behavier on 2.4GHz wifi?

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
I have a well working Mesh network with two XT9s. The only thing that puzzles me is the only two 2,4 GHz Wi-Fi devices I have, always connects to the same mesh router also if there is another mesh router near by with a much stronger signal. I do no see this issue on any of my 5 GHz devices, they always connect to the closest mesh router. How can I force my 2.4GHz Wi-Fi devices to connect to the mesh router with the strongest Wi-Fi signal?
Default Roaming Assistant value in Wireless, Professional settings is -70dBm. Change it to -60dBm or -50dBm for the 2.4GHz band and test again. Your 2.4GHz band has better range and perhaps your 2.4GHz devices don't see the need to switch to another AP. The result is not guaranteed though. Roaming depends on multiple factors.
I have some experience with changing this setting and using various 2.4 GHz devices (ex. small IoT devices).
In my case I discovered that if one device is not able to get a connection better than that DB value, it sometimes might eventually become offline and need to be rebooted.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!