What's new

Troubles w/Rosewill RNX-N300RT As Wifi/Ethernet Bridge

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor
Hello and thanks in advance for any light you can shed on this...

I need to replace the old Asus RTN-10 that I have been running w/Tomato as my Wifi/Ethernet Bridge because it is sometimes acting funky...

I have an old but far less used Rosewill RNX-N300RT on which I have installed DD-WRT v3.0-r55630 std (04/03/24) for the TP-Link TL-WR841ND v7 - which appears to be compatible and has worked fine for other things in the past.

I have followed the instructions at this tutorial to the best of my ability. When things did not go quite as planned (see below), I also tried this one and got what seems to be about the same results.

Here is what happens... I have tried this several times...

After rebooting the router upon completion of the tutorial, I find that my connected Windows PC always ends up with a viable, ethernet connection to my main router via the bridge (I see the Rosewill's router name). And Windows even says that there is internet available on that connection. So far, so good!

I can then actually use my browser, email, etc for perhaps 2-4 minutes (certainly no more than 5 minutes) without any problems. I can run speed tests and actually see faster results than with the old Asus/Tomato bridge.

But after that brief interval, internet connectivity simply disappears (although Windows still reports internet available). I can reach the bridge and maybe even the main router in my browser. But I can do nothing else. Pings, emails, web pages, etc - nothing works. They just time out with errors.

I feel that I am on the very cusp of a working replacement for the old Asus device. But I am missing something here.

To be honest, you've got old hardware that is likely beyond the use-by date...
A quick google search turns up OpenWRT deprecating this device for having insufficient storage. I think there are at least two explanations for what you're seeing: device is running out of RAM after a few minutes' operation, or it's overheating. Either way, I doubt it's worth putting effort into. Buy something a tad newer and beefier.
Thanks to all. I agree that it IS OLD. But it has seen very little use. Funny that it seems to work just fine as a plain, old router. I like to try and keep stuff outta the landfill. But this may be a case where I cannot...

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!