1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Unable to get OpenVPN Server to work on RT-AC86U with ASUSWRT-Merin

Discussion in 'Asuswrt-Merlin' started by punkinpun, Feb 15, 2020.

  1. punkinpun

    punkinpun New Around Here

    Joined:
    Feb 15, 2020
    Messages:
    2
    My Router: RT-AC86U

    Without ASUSWRT-MERLIN, the OpenVPN server with the ASUSWRT works perfectly. But it doesn't work after I have upgraded with ASUSWRT-MERLIN firmware. I tried 384.15 and 384.13 with no avail! If I reverted it back to ASUSWRT 3.0.0.4_384_81351 or RT-AC86U_3.0.0.4_384_81049, the OpenVPN server on router works again. All settings remain unchanged as-is in either firmware.

    In the system log, I found TLS Error with ASUSWRT-MERLIN firmware when the client was trying to connect.

    Feb 16 01:18:18 ovpn-server1[1503]: 192.168.1.212:53631 TLS: Initial packet from [AF_INET]192.168.1.212:53631, sid=20cb05c9 6714b29d
    Feb 16 01:19:18 ovpn-server1[1503]: 192.168.1.212:53631 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Feb 16 01:19:18 ovpn-server1[1503]: 192.168.1.212:53631 TLS Error: TLS handshake failed
    Feb 16 01:19:18 ovpn-server1[1503]: 192.168.1.212:53631 SIGUSR1[soft,tls-error] received, client-instance restarting
    Feb 16 01:19:23 ovpn-server1[1503]: 192.168.1.212:63868 TLS: Initial packet from [AF_INET]192.168.1.212:63868, sid=4a8ecf69 8b8cf5d5

    1.png

    Any suggestion or help to fix? Thanks.
     
    slytho likes this.
  2. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    13,024
    After flashing the RMerlin firmware (384.15_0 recommended), did you do a full reset to factory defaults followed by a minimal and manual configuration to secure the router and connect to your ISP?

    See the M&M Config and the Nuclear Reset guides to get your router to a good/known state.
     
  3. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    12,105
    Location:
    UK
    Test the connection from outside your LAN and it should work.
     
    slytho, punkinpun, CaptainSTX and 2 others like this.
  4. punkinpun

    punkinpun New Around Here

    Joined:
    Feb 15, 2020
    Messages:
    2
    Yes, it works! Testing from outside works like a charm:)
    Many thanks.
     
  5. slytho

    slytho Occasional Visitor

    Joined:
    Jun 16, 2013
    Messages:
    38
    Thank you for your post. :) I have the same problem but no time yet time to write a post.

    May I ask what is the reason for that from the network's point of view? I also created a forward rule, reverted changed settings like DNS to standard ... but to no avail, I had the same error as punkinpun posted.