What's new

Unable to connect to VPN with specific ISP (and more weird symptoms)

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
Hi All. I've been experiencing some very weird behavior and wondering if anyone could help point me in the right direction.

I am lucky to have 2 separate fiber providers with infrastructure in my house. For the last couple of months I've been using both of them with the Dual WAN feature with load balancing (I use a GT-AX11000). I decided recently to test out both connections to see which is better and just go with that one. Dual WAN hasn't been the most reliable.

I use VPN director to route a few devices' traffic through a TorGuard connection for streaming. So when testing out both ISPs, I wanted to test their speed directly, and through the VPN. But oddly enough when connected through one of the two ISPs, I could not connect to the VPN. I contacted the ISP and they claim they're not blocking anything.

I tried switching ports between the two ISPs on the router, and it made no difference.

Another really weird symptom - with the VPN-able ISP, when I click on the "Check" button in the Firmware Upgrade page, it connects and works. When I click the button using the VPN-disabled ISP, it doesn't work and I get the error: "The router cannot connect to ASUS server to check for the firmware update. Please download the latest firmware from ASUS Product Support Site and do manually upgrade. "

Ok - paused the writing of this question and did some more work and I have narrowed down the problem. When connected to the problematic ISP, NTP is not working and the time is off. Maybe they're blocking that port? Hence the inability to connect with a secure connection to TorGuard and also apparently the Asus server.

How can I get around this problem with this ISP? (it's actually the faster of the two, this is why I'm pushing to figure this out).
What does the logs show for any errors? Have you tried a manual domain lookup? Have you tried a different NTP server?
I don't see any specific errors for NTP, but it could be I'm missing it. Nslookup resolves pool.ntp.org fine, but I think the issue is the port for the actual NTP lookups.

I just tried a factory settings reset. All I entered was the Username/PW for the PPPoE and changed the WAN port to the 2.5Gbps port. Still no dice. It's definitely not settings related.
Ok, tried "pinging" port 123 on pool.ntp.org while connected to the two different ISPs using Telnet and nc. On the problematic ISP, both tools simply timed out. When I tried it on the working ISP, I got "connection refused" immediately with both tools.
Yeah, that is weird Still, I'd be very surprised if an ISP is blocking NTP. NTP is just one of those staples of networking.

Does your ISP have their own NTP server?
I've tried searching but haven't found anything yet. I'm in Israel and there's something like a national time server but that also isn't working.

I've also tried asking my parents for help getting into their ISP supplied router (same ISP) to see if I could find the NTP settings, but their equipment is only accessible through their app and it's way too user friendly.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!