USB Drive: Create folder issue

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Maverick

New Around Here
RT-AC1900P, and brand new windows 10 Home edition. I've turned on Samaba, SMBv1 and SMBv2, as well as guest login but I can't create new folders on the external USB drive. I've tried the drive in both USB ports, and can read files on the drive without a problem. When I try to create a new folder, or copy files to the drive, I get the "Error 0X80070032: The request is not supported" error. Nothing on my home network changed other than my PC. I'm running 384.19 and have even tried re-flashing back to non Merlin firmware. In "OptionalFeatures" SMB 1.0/CIFS client is checked. Any help?
 

L&LD

Part of the Furniture
Can you create a folder, within a folder (i.e. not on the root)?
 

bennor

Regular Contributor
Have you granted the account Read/Write privilege in the router's "Network Place (Samba) Share / Cloud Disk" section?

What is the format of the USB drive? NTFS or other?

One may need to follow this guide to setting up a USB hard drive to properly work with the Asus Merlin firmware. Skip the section on installing amtm and the step to create the swap file if you don't want to use one. One formats the drive initially on Windows for NTFS, then reformats the drive within the Asus Merlin command line terminal (using amtm) for EXT2 or EXT3 or what ever version of EXT the router supports.
 

Maverick

New Around Here
Thanks Bennor. Not sure what exactly I did, but it's working. My drive was working and didn't want to format the entire thing. I started following some of your instructions provided, changed the USB port to 2.0 from 3.0, removed the external drive and tested with a thumb drive (worked fine). Connected the HD to my PC and scanned it, then properly ejected it and re-connected it to the router. As per the instructions, takes about 10 minutes to actually register it's there, but I can write to the folders now.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top