Voxel Very inconsistent network performance with Orbi RBR50

Loof

Occasional Visitor
I switched back to (the latest) Voxel release for RBR50 and these network issues confound me!
I switched to the neatgear release because my family was tired of dealing with my experimentation.
It does not have these issues.

Some sites work at excellent speed and others are ridiculously slow from a client side.
The same sites that are fast on the client are sluggish directly from the router.
I switched to the downloaded ookla speedtest client to ensure consistency.
These results are very repeatable!
FYI, dslreports shows 40mb-150mb and often fails completely.

I've tried changing tcp tuning, congestion algorithms, ecn, same MTU across devices, different qdisc schedulers.
Nothing seems to make a significant difference (though a few things did make the 'good' connections perform even better).

Does anyone have a clue what might be going on here and what I can try to change?

FYI, I put _ in the city name because this forum considers I.n.d.i.a to be an inappropriate word (fragment).

On the router:
[email protected]:~/speedtest# ./speedtest -s 11441

Speedtest by Ookla

Server: LightBound - Indi_anapolis, IN (id = 11441)
ISP: Comcast Cable
Latency: 24.44 ms (1.51 ms jitter)
Download: 938.97 Mbps (data used: 1.7 GB )
Upload: 42.14 Mbps (data used: 48.4 MB )
Packet Loss: 0.0%
Result URL: https://www.speedtest.net/result/c/00adfce9-012e-466d-b71b-08e4f41ca81e
[email protected]:~/speedtest# ./speedtest -s 12665

Speedtest by Ookla

Server: Smithville Communications - Ellettsville, IN (id = 12665)
ISP: Comcast Cable
Latency: 23.69 ms (1.45 ms jitter)
Download: 666.34 Mbps (data used: 595.3 MB )
Upload: 42.01 Mbps (data used: 44.5 MB )
Packet Loss: 0.0%
Result URL: https://www.speedtest.net/result/c/5b4f6836-5db9-409c-a31f-9feed02afe3d

On a linux client:
[email protected]:~/src/ookla# ./speedtest -s 11441

Speedtest by Ookla

Server: LightBound - Indi_anapolis, IN (id = 11441)
ISP: Comcast Cable
Latency: 37.02 ms (1.21 ms jitter)
Download: 132.40 Mbps (data used: 237.8 MB )
Upload: 41.44 Mbps (data used: 38.2 MB )
Packet Loss: 0.0%
Result URL: https://www.speedtest.net/result/c/97064a70-1a6e-4af8-aa41-a7c8e3e4a48e
[email protected]:~/src/ookla# ./speedtest -s 12665

Speedtest by Ookla

Server: Smithville Communications - Ellettsville, IN (id = 12665)
ISP: Comcast Cable
Latency: 24.06 ms (1.32 ms jitter)
Download: 946.37 Mbps (data used: 1.2 GB )
Upload: 41.57 Mbps (data used: 42.8 MB )
Packet Loss: 0.0%
Result URL: https://www.speedtest.net/result/c/929fad8f-6c8b-4701-9c59-ffde7f95006e

On a windows client:
.\speedtest -s 11441

Speedtest by Ookla

Server: LightBound - Indi_anapolis, IN (id = 11441)
ISP: Comcast Cable
Latency: 23.74 ms (0.38 ms jitter)
Download: 67.42 Mbps (data used: 120.2 MB )
Upload: 41.64 Mbps (data used: 52.3 MB )
Packet Loss: 0.0%
Result URL: https://www.speedtest.net/result/c/54bbfe7c-3e1e-4601-9040-10d15b62cf17
.\speedtest -s 12665

Speedtest by Ookla

Server: Smithville Communications - Ellettsville, IN (id = 12665)
ISP: Comcast Cable
Latency: 46.04 ms (0.62 ms jitter)
Download: 939.12 Mbps (data used: 1.7 GB )
Upload: 41.86 Mbps (data used: 74.6 MB )
Packet Loss: 1.6%
Result URL: https://www.speedtest.net/result/c/223e5d31-4b12-4777-8e87-fa4e0916cf6e
 

bbunge

Part of the Furniture
Speed testing, actually bandwidth testing, these days is a roll-the-dice game as far as what the results will be. The Orbi is at its best a fair consumer router/mesh system even with the good Voxel firmware. I had an Orbi RBR/RBS50 at one time. Tried the Voxel firmware, too. Just did not work for my control/security needs and the performance wasn't that great. I gave it away and have never heard how it worked for the other guy.
 

Loof

Occasional Visitor
Well, these results have been consistent... I tried a dozen or so different services and it seems random (even based on traceroute/tracepath) which are fast and which are slow... but they are REPEATABLY fast or slow for the same server.
This doesn't just affect 'speed tests', of course, it hits random Internet sites which means my browsing/streaming experience is very spotty.

I've own the Orbi system for quite a while. When it works well, I've been able to play VR in different rooms without issues and there are 6 of us in a large home who share the wifi network without trouble.
There are a few tweaks (such as limiting my 'guest' network to 2.4ghz or running smartdns on the router that the Voxel firmware allows me to do easily.
However, once I upgraded to a 1g connection the limitations became obvious. I'll have to try a much older release to see if it used to work better and this is just a coincidental regression.

What did you switch to instead of the Orbi?
The issue is also price point, my budget is not infinite :)
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top