XD4 AiMesh keeping clients on specific nodes

rayone

Occasional Visitor
Hi.

Asus XD4 3 nodes in AP AIMesh mode + ethernet backhaul., opnsesne FW/DHCP.
I use my laptop aroud the house and it stays connected to specific nodes until pages don't even load.
Dining room = node 2
Living room = node 1
Office = Router

If I go from the living room to the office, my laptop stays connect to the living room and it works until a page or stream stops, then I check the wifi and see signal is poor, I disconnect and reconnect and everything is fine again.
I thought Mesh was specifically designed to avoid this.

How can I resolve this?
 

OzarkEdge

Part of the Furniture
Hi.

Asus XD4 3 nodes in AP AIMesh mode + ethernet backhaul., opnsesne FW/DHCP.
I use my laptop aroud the house and it stays connected to specific nodes until pages don't even load.
Dining room = node 2
Living room = node 1
Office = Router

If I go from the living room to the office, my laptop stays connect to the living room and it works until a page or stream stops, then I check the wifi and see signal is poor, I disconnect and reconnect and everything is fine again.
I thought Mesh was specifically designed to avoid this.

How can I resolve this?

Is "Office = Router" the AiMesh root node in AP Mode?

What is the linear distance between the nodes... perhaps they are too many/too close together?

OE
 

rayone

Occasional Visitor
Is "Office = Router" the AiMesh root node in AP Mode?

What is the linear distance between the nodes... perhaps they are too many/too close together?

OE
  1. Yes.
  2. 18m separate floors.
    Presently node 2 is off. Define too many/too close together with references. I am unable to find anything in Asus manuals that defines a minimum distance.
    It's like they are acting as separate APs with the same SSID and not Mesh with client management logic.
 

L&LD

Part of the Furniture
Roaming is more dependent on the client device than the router.

The actual distance between nodes isn't the real issue, particularly in this case, it is how 'easily' the client device sees the various APs.

Are your laptop WiFi drivers fully up to date? Have you ever changed any defaults within the drivers? If so, you may want to reset your network settings.

On the main router itself, you may want to test different Control Channels and power levels too.

If possible, put the APs even further apart (you're using wired backhaul anyway).

If your laptop's WiFi adaptor can be upgraded, do so. The Intel WiFi 6E AX210 (genuine) card is highly recommended and is a cheap fix to better WiFi (not just range, throughput, and lower latency, but also behaviorally too). And it can be found for little money too ($20).
 

OzarkEdge

Part of the Furniture
  1. Yes.
  2. 18m separate floors.
    Presently node 2 is off. Define too many/too close together with references. I am unable to find anything in Asus manuals that defines a minimum distance.
    It's like they are acting as separate APs with the same SSID and not Mesh with client management logic.

18m/60ft apart is a fair distance, depending on signal strength and path, and any obstacles to radio propagation.

Generally speaking, you want the weaker 5.0 signals to overlap a bit at some 'midpoint' dBm power level so that the client has a decent roaming choice as its current connection fades in strength past the 'halfway there' point. The client decides when to roam, subject to whatever roaming standards are implemented in the client and the node, if any (I don't know this for your equipment).

There is also Roaming Assistant (RSSI signal power dBm threshold per band) in the firmware that is suppose to 'encourage' a client to roam when its connection signal power drops below the RSSI threshold... more negative (node steering).

And Smart Connect that is suppose to encourage the client to connect to the better node band/signal when using the same SSID for all bands (node band steering).

One approach is to simplify and see how your clients behave on their own for the given radio layout. So, disable RA and SC and define different SSIDs per band and connect your client to the preferred band/SSID. Then you can focus on what the client is deciding relative to the radio layout... you may decide to move the nodes farther apart or remove a node (too much radio). You can later return to using RA and/or SC, or not. RA encourages sticky clients to roam, but first you want to be sure of your radio layout before tuning the RA RSSI threshold. A WiFi Analyzer app is handy for 'seeing' all ambient WiFi signals and their rough power level at various points.

Note that wired locations are not necessarily the best node/radio transmitter locations... except in commercial buildings that are engineered in advance before being wired for APs, and then the APs may be tuned power-wise upon installation.

Since the client decides when to roam, consider any client network adapter settings that might influence this decision. For clients that you maintain, consider updating the OEM driver, if not current.

OE
 
Last edited:

shoman94

Regular Contributor
There should be some roaming options in your wifi adapter settings in the laptop as well. I know my phone jumps without dropping but I also know that it's very random which node my clients connect to. It's not always the closest one.....

...but you're right.... AiMesh does not work as well as other mesh devices such as the Eero 6 Pro.
 
Last edited:

leerees

Senior Member
Hi.

Asus XD4 3 nodes in AP AIMesh mode + ethernet backhaul., opnsesne FW/DHCP.
I use my laptop aroud the house and it stays connected to specific nodes until pages don't even load.
Dining room = node 2
Living room = node 1
Office = Router

If I go from the living room to the office, my laptop stays connect to the living room and it works until a page or stream stops, then I check the wifi and see signal is poor, I disconnect and reconnect and everything is fine again.
I thought Mesh was specifically designed to avoid this.

How can I resolve this?

You need to work on the node placement and if required power levels.

I'd also look at the bounce detect rules.

A combination of these factors could be causing stuck clients. Your goal should always be ensuring the crossover zone is a place no devices will occupy. For example, a hallway. Obviously some devices may linger there and bounce detect will take care of that.

Increasing the number of bounces will take care of stuck clients, but you must deal with the cross over area as you don't want clients bouncing around in areas where coverage is important.
 

shoman94

Regular Contributor
You need to work on the node placement and if required power levels.

I'd also look at the bounce detect rules.

A combination of these factors could be causing stuck clients. Your goal should always be ensuring the crossover zone is a place no devices will occupy. For example, a hallway. Obviously some devices may linger there and bounce detect will take care of that.

Increasing the number of bounces will take care of stuck clients, but you must deal with the cross over area as you don't want clients bouncing around in areas where coverage is important.
So do some of the Smart Connect Rule settings work without enabling SmartConnect?...Such as Bounce detect?
 

rayone

Occasional Visitor
Thanks for the replies.

Placement is dependent on available ethernet ports which are at opposite ends on the house. I'm going to install another over Christmas.
So smart connect settings work without enabling Smart Connect.

I'm still not seing any benefit over separate APs using the same SSID., and there seems to be a slight initial latency.
 

leerees

Senior Member
So do some of the Smart Connect Rule settings work without enabling SmartConnect?...Such as Bounce detect?
I can't answer that. However, the reason for buying an AIMesh router is to take advantage of smart connect.

If you don't want smart connect (and AI Mesh), you would probably be better off with a traditional router and range extender. A traditional setup would place all of the roaming duties on the client. Your clients would roam when they detect a stronger signal.

I haven't used non AI Mesh for a few years now so I'm not sure how much the technology has improved. One of the big draws to AI Mesh was the seamless roaming when in the middle of a WiFi VOIP phone call. With my old range extenders, the calls would drop when moving between the CAP and the AP.

Another benefit of the mesh is only having 1 SSID. With split bands, non technical users won't know the difference between 2.4ghz and 5ghz and could inadvertently connect to the slower band when their device actually supports 5 ghz.

Mesh is a user friendly solution and the system chooses the best possible connection and band for the device, as opposed to the user. This is a good idea for those with busy WiFi networks who just want their WiFi to work. A perfect environment for mesh is a busy household where you have lots of people doing different things such as streaming, gaming and work.

AImesh can also load balance to ensure one high traffic user doesn't saturate the whole network.

It's not 100% perfect, but it does get it right 90% of the time. I no longer get any complaints from users since switching over to the mesh.
 
Last edited:

shoman94

Regular Contributor
Asus AiMesh just does not work right. It doesn't connect devices to the stronger AP after a reboot of the network or over time after a reboot. The only way is to refresh the network after a reboot...... Then it will balance out.
 

leerees

Senior Member
Asus AiMesh just does not work right. It doesn't connect devices to the stronger AP after a reboot of the network or over time after a reboot. The only way is to refresh the network after a reboot...... Then it will balance out.
You need to click optimise on the aimesh screen after you set it up. From then on devices should roam to the strongest AP automatically. The thresholds can be tweaked as well.
 

shoman94

Regular Contributor
Mine are connected via Ethernet so that option isn't available.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top