What's new

Zenwifi ET12 Poor Uplink performance

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor
Hi Gurus!
I had a AiMesh (AP Mode) of 7 XD6/XD6S and they worked fabulous. Wireless throughputs on a 1G Fiber WAN (router is a Edgerouter 6P) can go as high as 950mpbs in both up/down directions according to speedtest.net and fast.com

So just acquired a pair of ET12s to add 2.5G WAN/LAN and 6G capability to my home network for my 6E capable devices (Samsung ZFold3/ZFold4/Tab S8+/Asus Flow X13(2022)/Z13/Zenbook Pro 16X OLED). Oh boy was I disappointed......

Current Setup
A ET12 is setup as the primary node (AP mode) to manage the AiMesh network. Firmware
Backhaul is all CAT7 connecting to a 10GBe switch. WAN is 1G fiber to a Edgerouter6P which is fully capable of saturating the 1G WAN link.
All the XD6/XD6S and the other ET12 are reconfigured to be managed by the primary ET12 as a single AIMesh network.

First, the upload speed on 5G/6G when devices are attached to ET12 is only half of what the downlink speed is. For instances, while I can get 900mbps with my devices connecting to the ET12, I only get roughly half that on upload. This is happening on both 5G/6G band with the ET12 nodes. When the devices are connecting to 5G band to any of the XD6/XD6S I can get as high as 950mbps up/down when I am next to the nodes.

Second. May not be entirely Asus's fault but they really oughta sort it out with Samsung. My Samsung ZFold3 and ZFold4 can ONLY CONNECT TO 6GHz NETWORK ON THE PRIMARY NODE. I tried setting up the individual ET12s as standalones and the phones can connect to either unit without problem. As soon as one becomes a node to AiMesh, neither my ZFold3/ZFold4 will connect to the mesh nodes in 6GHz EXCEPT THE PRIMARY NODE.

Third. Maybe my fault. The ET12 unit is huge physically. Which is somewhat of a problem for me in terms of placement amongst furniture. The XD6/XD6S is way easier to place and much more inconspicuous.......

Is there any solution to the slow upload throughput and connectivity issues with Samsung devices?

On the other hand, my Asus laptops uses both Intel Wireless AX211 and MediaTek MT7922 and they both work fine on either 5G/6G band with the ET12. They do suffer the same issue of half uplink throughput the same as the ZFold3/ZFold4.
Last edited:
I have noticed that on the ET12, when backhaul is connected via a 2.5G link (either 2.5GWAN or 2.5GLAN), the throughput drops. When the link is only 1G (be it 2.5G port in 1G speed) or any of the other 1G LAN ports, speed is normal. Something is wrong with the 2.5G ports on the ET12. This is repeatable and I am connecting the ET12 directly to Netgear XS508M unmanaged multi-gig switch. Tried different cables and still the same so not a cable issue......

The decrease in throughput is happening when the node is connected directly via cable to the 2.5G port on the main node as well. So there is some issue with the 2.5G ports on the ET12. I have the same problem with all 4 of my ET12 units.

Bummer. This defeats one of the purpose of me adding the ET12 to my home network in the first place.
Last edited:
Are the speeds normal to an AC-powered computer without the switches in between?
Are the speeds normal to an AC-powered computer without the switches in between?
I don't have desktop computers anymore. But the laptops are of very high spec gaming machines. Right now I am on my ROG Flow X13 2022 with the XGmobile. Specs are 6900HS/32G RAM/AMD 6850m and a 2.5G ethernet port. It also has the Mediatek 802.11ax/6E card. The other machines are ROG Flow Z13/Zenbook Pro 16X OLED which are equipped with 12900H/16G/Intel AX211 card. So they are fully capable of saturating a 1G WAN link and more.

In fact, I just tested again on the X13 connecting to the 6GHz band of a single ET12. When it is connected to Netgear XS508 multigig switch at 2.5G, I am getting around 750mbps upload throughput. As soon as I connect the ET12 to a 1G port via an XD6, I get over 940mbps upload throughput with nothing else changed.......
The temporary solution for me which has ONLY a 1Gbps WAN connection, seems to be using a separate router (I use EdgeRouter 6P), and use the 1G LAN ports on the ET12 for wired backhaul. I will have to live with the LED on the ET12 being red, or turn it off for the time being. Upload speed down to sub 700mbps on a 1G fiber WAN connection is too high a price to pay for the white light on the ET12 units.

Another problem with this kludge is that I won't be able to manage the AiMesh nodes as they all come up as disconnected in the primary node webpage, as the ET12 requires uplink port to be one of the 2.5G ports. I guess I needed a legacy 1G switch to fix all these issues, which sucks......
Last edited:
I did a complete reconfig of my network, ditching the EdgeRouter 6P and used an ET12 as the router, connected to the Netgear XS508m at 2.5G link rate and network throughput are back to symmetrical again. So my issue appears to be router related with ET12 on the network. I am baffled at why this happens but happy about network throughput for now.....

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!