4G USB WAN half solution and reconnect command issues

0x1D12ED

New Around Here
After countless hours, countless days of reading in order to find a solution to my problem, having folders of bookmarks saved, I still was only able to decrease the daily disconnection quantities.

I`ve got an RT-AC68u Firmware Version: 384.13 (with Entware and a mini Debian), I`m in the UK, my ISP is 3. I have a Huawei E3372 4G stick flashed to serial mode. I have public IP (3 has three APN: three.co.uk, internet and 3internet. The last one gives you public IP. :) )

I`ve literally tried everything to eliminate the issue with no luck. I couldn`t even watch Netfix on my TV because I got disconnected every 10-15 minutes.
But one day my TV broke (The PSU gave up), and while it was in the service to get repaired, my internet was more stable (Only 1-3 disconnects per day).

I remembered that I`ve set up internet on the TV manually and gave Google`s 8.8.8.8 as DNS.
I think my ISP disconnects me if I use other DNS server than theirs (UK filtering policies) so I reconfigured my TV.


I still did get disconnected frequently, so I thought let`s stop my VPN clients maybe they interfere and this is where I noticed something.
There is an option at the VPN Clients page "Accept DNS Cofiguration" which is set to "Relaxed" by default. This only adds the connected VPN`s DNS server to list and even tough I only have my VPN clients connected, but no real traffic and have only two entries in "Rules for routing client traffic through the tunnel" (one is my TV the other is my PS4 which also caused disconnection problems) and both set to WAN iface it seems the VPN Client somehow gets some DNS resolved through the VPN server.

Disabled "Accept DNS Cofiguration" on my VPN clients. Network is sort of stable so far.



My issue now is that I may still get disconnected (but at least not every 10 mins) and I couldn`t find a working method to reconnect.
I SSH-d into my router and tried to reconnect WAN but no luck


Is there a way to reconnect USB WAN without rebooting the router?
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top