Solved AC68 AiMesh - pingloss with backhaul connected

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

redbird71

Occasional Visitor
Hi Everyone,

so this is my Setup: I've got a AC68U as my main router and an AC66_B1 as a node connected via cable with backbone activated. There is a switch between those 2 routers which serves several devices in the living room. Behind the node there is a cable connected PC and if I ping 8.8.8.8 f.i. from that PC I get one hit with normal latency - one lost, or several lost one hit or sometimes it might just work.

I did a fresh install - WPS reseted both devices - only set up minimal settings to get the internet working - did a network restart after, still the same. Eventually I got it to work the other day after I ordered JFFS format and restarted the main router. Worked without losing any pings, but after the next restart it went back to the where I was before. Tried to do the same again - but it does not work a second time.

The strange thing I'm observing is that if I do a network restart from the AiMesh tab - ping will look good for a few seconds when it goes down - and again look good when it is just starting up - only to go back to this erratic behavior after a few seconds.

If I ping from any device connected before the node there is no problem at all. I also observed problems with devices wifi connected to the node. This will go away instantly if I force them to connect to the main router even though I'm standing next to the node.

I blamed it on alpha first - waited for the final build - now I'm on 386.1_2 on both devices - WPS reseted and minimal install - no scripts - no usb stick - still can't get it to work.

Any ideas will be appreciated.
 

L&LD

Part of the Furniture
It may be the switches you're using. Can you either use a dedicated Ethernet cable run directly between the two routers for the wired backhaul or use a separate (new) unmanaged switch between them instead?

The following notes may be helpful to determine where you may have done things differently and if you need to start again.

Best Practice Update/Setup Router/AiMesh Node(s) 2021


And the link below is the proper method (depending on the router model) for the WPS Button reset for your routers too.

[Wireless] ASUS router Hard Factory Reset | Official Support | ASUS Global
 

redbird71

Occasional Visitor
I don't have a cable long enough to connect both devices directly so I tried switching the switch.

Attached the file how it looked pingwise from the PC I'm having problems with.

I'm actually pinging my main router here. Still observing this strange behavior where it would work for a few seconds after I reconnect the cable, which makes me think it is actually a software problem in the node.

If there is no other ideas I might interchange the positions of the router and the switch for more tests.
 

Attachments

  • Ping after switching the switch.txt
    3.9 KB · Views: 16

Make WiFi Great Again

Regular Contributor
is spanning tree enabled on all the devices? if not, try enabling it and then restart everything and give everything a few minutes to settle down after the last device is finished restarting and finally try your tests again.
 

bbunge

Part of the Furniture
From the root router, click on AiMesh/(A Mesh Node)/Management/Backhaul Connection Priority and set to 1G WAN first

I have found that sometimes the node can try to switch between Ethernet and WIFI. Going through a switch might make this worse. And you should have an unmanaged switch.
 

Calkulin

Regular Contributor
I dealt with a lot of packet loss from the node to the main router on multiple AC66U_B1 & AC68U AiMesh setups that I manage since 386.1 and I discovered it was related to the using slot 1 in Guest network. When I moved the Guest to slot 2, the issue went away. My AX88U and AX58U didn't suffer from this issue but I had 3 AiMesh setups that were only AC68s and 1 that was just 2x AC66U_B1s and they were all suffering the same packet loss issue. There could be other AC models that are affected but I've only seen the AC68U firmware doing it since the 386.1 alpha's to the current 386.2_alpha1-gc52b410e89 that still suffers from that issue,
 

redbird71

Occasional Visitor
is spanning tree enabled on all the devices? if not, try enabling it and then restart everything and give everything a few minutes to settle down after the last device is finished restarting and finally try your tests again.
Yes. Apparently it is enabled by default.
 
Last edited:

redbird71

Occasional Visitor
From the root router, click on AiMesh/(A Mesh Node)/Management/Backhaul Connection Priority and set to 1G WAN first

I have found that sometimes the node can try to switch between Ethernet and WIFI. Going through a switch might make this worse. And you should have an unmanaged switch.
This option seams to be fixed in '1G WAN only' once you enable ethernet backhaul mode.
 

redbird71

Occasional Visitor
I dealt with a lot of packet loss from the node to the main router on multiple AC66U_B1 & AC68U AiMesh setups that I manage since 386.1 and I discovered it was related to the using slot 1 in Guest network. When I moved the Guest to slot 2, the issue went away. My AX88U and AX58U didn't suffer from this issue but I had 3 AiMesh setups that were only AC68s and 1 that was just 2x AC66U_B1s and they were all suffering the same packet loss issue. There could be other AC models that are affected but I've only seen the AC68U firmware doing it since the 386.1 alpha's to the current 386.2_alpha1-gc52b410e89 that still suffers from that issue,
This did the trick! Thank you so much! No ping loss anymore!

It's a shame because I use the first guest network slot to span a wifi for IOT devices that shall NOT have access to intranet. Those devices are in different locations of my house - so the ability to span a single network for them was one of the main reasons to change form main-router+AP to AiMesh in the first place. Is this a known issue? Is it part of ASUS closed source?
 

brummygit

Very Senior Member
This did the trick! Thank you so much! No ping loss anymore!

It's a shame because I use the first guest network slot to span a wifi for IOT devices that shall NOT have access to intranet. Those devices are in different locations of my house - so the ability to span a single network for them was one of the main reasons to change form main-router+AP to AiMesh in the first place. Is this a known issue? Is it part of ASUS closed source?
I'm pretty sure it's been documented on the official betas as well so an ASUS fix.
 

redbird71

Occasional Visitor
Huge thanks to everyone for the help. You are great!

I changed the name of the thread to make it easier to find and marked it as solved. Said that I would be greatful if someone could post here if he finds out that this issue has been solved in a future build so I can move my guest network to slot 1 again.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top