AiMesh not working properly on RT-AC5300

sleeps1007

Regular Contributor
Hi,

I have an RT-AX88U as my main and RT-AC5300 as mesh mode and recently I've been having connection issues. After doing some troubleshooting and looking at the system logs I noticed the connection to the AC5300 was not working, it kept disconnecting/reconnecting. If I connected to my AX88U everything works fine so I rebooted the AC5300 and same thing still happened then I removed the node which factory reset the AC5300 and when I attempted to setup the AiMesh that option was not there so I set it with default settings so I could log into the router and setup the mesh mode and after doing so the issue continued to happened. I'm thinking the mesh mode somehow broke but don't know how it could of happened. It has the latest version of Merlin (386.7_2) and I haven't done any changes to either routers.
 

L&LD

Part of the Furniture
Your post is a little confusing.

The option to set up AiMesh isn't there on the main router (RT-AX88U)?

Have you tried using a wired connection to set up the AiMesh node (via the RT-AX88U's GUI)? After it has been successfully completed, you can move the node to where you need it (and have it use a wireless backhaul).

Going into the node to set up AiMesh is a sure way of having issues.

Fully reset the node (use the appropriate WPS Button method below). Do not touch the node again.

[Wireless] ASUS router Hard Factory Reset | Official Support | ASUS Global

How to Connect an AiMesh Node


Hopefully, the tips above will help.
 

OzarkEdge

Part of the Furniture
Hi,

I have an RT-AX88U as my main and RT-AC5300 as mesh mode and recently I've been having connection issues. After doing some troubleshooting and looking at the system logs I noticed the connection to the AC5300 was not working, it kept disconnecting/reconnecting. If I connected to my AX88U everything works fine so I rebooted the AC5300 and same thing still happened then I removed the node which factory reset the AC5300 and when I attempted to setup the AiMesh that option was not there so I set it with default settings so I could log into the router and setup the mesh mode and after doing so the issue continued to happened. I'm thinking the mesh mode somehow broke but don't know how it could of happened. It has the latest version of Merlin (386.7_2) and I haven't done any changes to either routers.

There are posts here suggesting latest ASUSWRT-Merlin breaks AiMesh.

OE
 

L&LD

Part of the Furniture
No, it doesn't. Even if the posts are.
 

OzarkEdge

Part of the Furniture

sleeps1007

Regular Contributor
Your post is a little confusing.

The option to set up AiMesh isn't there on the main router (RT-AX88U)?

Have you tried using a wired connection to set up the AiMesh node (via the RT-AX88U's GUI)? After it has been successfully completed, you can move the node to where you need it (and have it use a wireless backhaul).

Going into the node to set up AiMesh is a sure way of having issues.

Fully reset the node (use the appropriate WPS Button method below). Do not touch the node again.

[Wireless] ASUS router Hard Factory Reset | Official Support | ASUS Global

How to Connect an AiMesh Node


Hopefully, the tips above will help.
No the option wasn't on the AC5300. After it factory restored you have to go through the setup process as if it was out of the box and when selecting what type of connection the only options were "wireless router", "AP", "Repeater", and "Media Bridge". There was no AiMesh option until I after I completed the setup using defaults and went into the admin to set it as aimesh.

I always had it set as a wired connection.
 

OzarkEdge

Part of the Furniture
No the option wasn't on the AC5300. After it factory restored you have to go through the setup process as if it was out of the box and when selecting what type of connection the only options were "wireless router", "AP", "Repeater", and "Media Bridge". There was no AiMesh option until I after I completed the setup using defaults and went into the admin to set it as aimesh.

I always had it set as a wired connection.

You do not directly configure nodes. Hard Reset the AC5300 firmware to its defaults and then search/add that node from within the AX88U webUI.

Reset FAQ
Reset button/webUI Restore/node removal - clears settings in NVRAM; reboot restores fw defaults from CFE (fw defaults)
Hard Reset via WPS button/webUI Restore+Initialize - also clears data logged in /jffs partition (fw defaults+clear logs)

Also, ASUSWRT-Merlin is not required on nodes per its AiMesh installation instructions: AiMesh · RMerl/asuswrt-merlin.ng Wiki · GitHub

Try the above with ASUSWRT on the AC5300. If that fails, you could try reverting the AX88U to a previous ASUSWRT-Merlin version... or to the latest ASUSWRT... install firmware, reset firmware, and configure from scratch for best results when unsure of things.

OE
 

Tech9

Part of the Furniture
There are posts here suggesting latest ASUSWRT-Merlin breaks AiMesh.

AiMesh wireless node discovery is broken*. The initial setup process may require extra steps. It often does require extra steps, if AiMesh uses mixed generation routers. @sleeps1007 has a different issue. I would check if AC5300 radios are operational first. This router has some 5GHz radio issues history.

* - here is my last post on the subject. Read again carefully what's broken, please. You can recreate the issue easily on first try with your available AX86U and AC86U routers.


There was no AiMesh

You don't need to touch the node. Reset it and add it to AiMesh using wired connection, in main router's GUI. Then shut it town, disconnect the wire and move it to the desired location. When you turn it on it will fail back to wireless backhaul. If it doesn't, you may have 5GHz radio issue on AC5300.
 

L&LD

Part of the Furniture
No the option wasn't on the AC5300. After it factory restored you have to go through the setup process as if it was out of the box and when selecting what type of connection the only options were "wireless router", "AP", "Repeater", and "Media Bridge". There was no AiMesh option until I after I completed the setup using defaults and went into the admin to set it as aimesh.

I always had it set as a wired connection.

Reread post 2 again, and follow the suggestions to get a working setup.
 

OzarkEdge

Part of the Furniture
* - here is my last post on the subject. Read again carefully what's broken, please. You can recreate the issue easily on first try with your available AX86U and AC86U routers.

I trust I can, but I don't use ASUSWRT-Merlin.

OE
 

3320099

New Around Here
I think it's bug of Merlin. I have same problem. I have an RT-AX88U as my main and RT-AC66B1, AiMesh can work with offical fireware.
 

Demontager

New Around Here
I also running AC5300 on 386.7_2 Merlin acting as aimesh node and it works very strange. I can't get 5300 works on 5Ghz(only 2.4Ghz Weak signal) nevertheless it located 30m away from main AC3100 router. Just for test I have another AC3100 as Aimesh node and placed it in same position as 5300 and it gets full 5Ghz signal.
I was able to get 5Ghz on 5300 only when placed 3m away from main router. I think it also might be some hardware problem.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top