Any way to overclock new RT-AC68U?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

ColinTaylor

Part of the Furniture
Maybe it's just not possible with your hardware.

What do you get from this:
Code:
nvram get boardtype
nvram get clkfreq
 

Fenrir

Occasional Visitor
board type- 0x0646
clkfreq- 1000,666

do you think the changes i made to the CFE would be overidding the script? or should the script override the CFE?
I'm contemplating trying to flash an older version of the CFE, just not sure what the chances of me bricking it are if i try that...
 

ColinTaylor

Part of the Furniture
I'm contemplating trying to flash an older version of the CFE, just not sure what the chances of me bricking it are if i try that...
Don't. As far as I can tell your router has the 4709c0 CPU. If you flash an older CFE that isn't compatible with that processor you're probably screwed. It's not worth the risk for the minimal benefit overclocking might have IMHO.
 

Grisu

Part of the Furniture
What is written in CFE will replace NVRAM values after a reset to factory defaults. So it is dangerous to set it to 1400 if your router cant run it, you'll end up with a brick!
Changes in NVRAM will take place if you change it afterwards.
But newer (stock and maybe Merlin) firmwares will replace clock values with them from CFE every few hours, so you need a script to change it back every time to what you want it to be.
Only bogomips will tell your the truth how fast it really runs.
I can remember that I have seen this running with 100MHz (or very very slow) once, but sorry, cant remember what I did wrong to get this. Maybe set to a wrong value, inserted a blank after comma or equal sign or something like that.
Try it again 1200,666 with each command in one line. RAM-speed wont make it really faster, so stay at 666, possibly not every router is able to run 800 RAM-clock!
Allowed values for RAM-clk are 533/666/775/800 and 800/1000/1200/(1400) for cpu.

If you get it done in cfe you wont need any scripts or whatever, thats the great advantage, they are sticky.
 
Last edited:

Fenrir

Occasional Visitor
sorry what do you mean with "each command in one line"?

Aslo are you suggesting this:
nvram set asuscfeclkfreq=1200,666 && nvram set asuscfecommit=1
nvram set clkfreq=1200,666 && nvram commit && reboot
 

Grisu

Part of the Furniture
'&&' is adding more commands in one line, you can input each one seperately.
yes, thats what you could use (only if you know your router is able to run 1200MHz CPU!!!).
 

Wallace_n_Gromit

Regular Contributor

Wallace_n_Gromit

Regular Contributor
board type- 0x0646
clkfreq- 1000,666
I also tried the 2 commands that @ColinTaylor suggested and got:
board type- 0x0646
clkfreq- 800,666

But when I entered [cat /proc/cpuinfo | grep BogoMIPS] at command prompt I get:
BogoMIPS : 2798.38
BogoMIPS : 2798.38

It doesn't appear that [nvram get clkfreq] actually shows the current condition of the real clock speed. I suspect [nvram get clkfreq] just shows the content of either the CFE or NVRAM before you do any overclocking. I have Asus Bootloader (CFE) 1.0.2.0 on my 68U and have my 68U OC'ed to 1400Mhz

EDIT: Just an additional note. I have noticed following @ironclad's directions on safely overclocking my 68U an important caveat. When you power down your router and do a cold boot, the CPU runs at the original speed (in my case 800,666). When you do a reboot from the asuswrt GUI it will return to it's Overclocked speed (again, in my case 1400,800). I couldn't figure out until after some time why this behavior was manifesting itself (it's in the "safe" nature of ironclad's method--as a newbie I understand it) .

When I had overclocked the router to 1600Mhz it failed to start. I merely had to Power down/Press WPS and continue to press WPS for 30 seconds after powering up the router. It restarted at default settings. (had made backups of the router/JFFS config file(s), installed them and was as good as new)

Also the CPU speed showing on the TOOLS section of GUI is not necessarily accurate. Have to enter [cat /proc/cpuinfo | grep BogoMIPS] from the command prompt in ssh to know truely the CPU speed.
 
Last edited:

JackFrost

New Around Here
Is overclocking possible on AC68U hardware v3? Tried it but bogo mips goes to 100Mhz after OCing to 1200 and I had to revert to stock 1000Mhz.
 

Wallace_n_Gromit

Regular Contributor
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top