AX88U_386.8 The configuration of service is not well, causing dnsmasq to run abnormally

VaMpIrE-KiNg

Occasional Visitor
AP mode

use defined configration file for dnsmasq /usr/sbin/dnsmasq -C /jffs/dnsmasq.conf

Log:
Sep 22 00:26:16 rc_service: service 8367:notify_rc stop_dnsmasq
Sep 22 00:26:16 rc_service: service 8370:notify_rc start_dnsmasq
Sep 22 00:27:16 rc_service: service 9084:notify_rc stop_dnsmasq
Sep 22 00:27:16 rc_service: service 9087:notify_rc start_dnsmasq
Sep 22 00:28:15 rc_service: service 9790:notify_rc stop_dnsmasq
Sep 22 00:28:15 rc_service: service 9793:notify_rc start_dnsmasq
Sep 22 00:29:15 rc_service: service 10506:notify_rc stop_dnsmasq
Sep 22 00:29:15 rc_service: service 10509:notify_rc start_dnsmasq
Sep 22 00:30:15 rc_service: service 11225:notify_rc stop_dnsmasq
Sep 22 00:30:15 rc_service: service 11228:notify_rc start_dnsmasq
Sep 22 00:31:15 rc_service: service 11942:notify_rc stop_dnsmasq
Sep 22 00:31:15 rc_service: service 11945:notify_rc start_dnsmasq
Sep 22 00:32:15 rc_service: service 12659:notify_rc stop_dnsmasq
Sep 22 00:32:15 rc_service: service 12662:notify_rc start_dnsmasq
Sep 22 00:33:15 rc_service: service 13372:notify_rc stop_dnsmasq
Sep 22 00:33:15 rc_service: service 13375:notify_rc start_dnsmasq
Sep 22 00:34:15 rc_service: service 14089:notify_rc stop_dnsmasq
Sep 22 00:34:15 rc_service: service 14092:notify_rc start_dnsmasq
Sep 22 00:35:15 rc_service: service 14805:notify_rc stop_dnsmasq
Sep 22 00:35:15 rc_service: service 14808:notify_rc start_dnsmasq
Sep 22 00:36:15 rc_service: service 15531:notify_rc stop_dnsmasq
Sep 22 00:36:15 rc_service: service 15534:notify_rc start_dnsmasq
Sep 22 00:37:15 rc_service: service 16247:notify_rc stop_dnsmasq
Sep 22 00:37:15 rc_service: service 16250:notify_rc start_dnsmasq
Sep 22 00:38:15 rc_service: service 16966:notify_rc stop_dnsmasq
Sep 22 00:38:15 rc_service: service 16969:notify_rc start_dnsmasq

Tested commands:
service stop_dnsmasq sucessful
service start_dnsmasq not sucessful
service restart_dnsmasq not sucessful
 

ColinTaylor

Part of the Furniture
dnsmasq should not be running in AP mode.
 

ColinTaylor

Part of the Furniture
Even if it does not support running in AP mode, it can not cause user-defined program running poorly.
I do not understand what you are trying to say. You will have to explain what exactly you are doing and what the problem is.

What is your user-defined program? How are you running it?
 

VaMpIrE-KiNg

Occasional Visitor
I do not understand what you are trying to say. You will have to explain what exactly you are doing and what the problem is.

What is your user-defined program? How are you running it?
user-defined program=Dnsmasq is not autorun in AP mode, so I have to run this command manually.
 

Tech9

Part of the Furniture
Yes, because it's not needed in AP Mode. What do you need it for?
 

ColinTaylor

Part of the Furniture
I cannot recreate your problem.

You will have to describe in more detail how you have configured your AP and what customisations you have made.
 

VaMpIrE-KiNg

Occasional Visitor
I cannot recreate your problem.

You will have to describe in more detail how you have configured your AP and what customisations you have made.
I did these following commands as below:
echo 1 > /proc/sys/net/ipv4/ip_forward
echo 1 > /proc/sys/net/ipv4/tcp_mtu_probing
echo "nameserver 8.8.8.8" > /etc/resolv.conf
/usr/sbin/dnsmasq -C /jffs/dnsmasq.conf
brctl addif br0 bond1
route add -net 192.168.2.0/24 gw 192.168.1.1
iptables -t nat -A POSTROUTING -j MASQUERADE
#Enable WAN bonding
ifconfig eth0 down
ifconfig eth1 down
ip link set eth0 master bond1
ip link set eth1 master bond1
ip link set bond1 up
 

ColinTaylor

Part of the Furniture
I did these following commands as below:
echo 1 > /proc/sys/net/ipv4/ip_forward
echo 1 > /proc/sys/net/ipv4/tcp_mtu_probing
echo "nameserver 8.8.8.8" > /etc/resolv.conf
/usr/sbin/dnsmasq -C /jffs/dnsmasq.conf
brctl addif br0 bond1
route add -net 192.168.2.0/24 gw 192.168.1.1
iptables -t nat -A POSTROUTING -j MASQUERADE
#Enable WAN bonding
ifconfig eth0 down
ifconfig eth1 down
ip link set eth0 master bond1
ip link set eth1 master bond1
ip link set bond1 up
That looks like a completely bespoke configuration so I'm not surprised that it is incompatible with the router's services.

You could try killing the watchdog processes to see if that helps. If it doesn't then I'm out of ideas.
Code:
killall wanduck watchdog check_watchdog
 

VaMpIrE-KiNg

Occasional Visitor
That looks like a completely bespoke configuration so I'm not surprised that it is incompatible with the router's services.

You could try killing the watchdog processes to see if that helps. If it doesn't then I'm out of ideas.
Code:
killall wanduck watchdog check_watchdog
Yes, as you said this is a completely bespoke configuration, because I just need the hardware to provide AP, Dnsmasq and LACP functions, all other settings are completed by the uplink device Mirkrotik CCR2004-16G-2S+

Now dnsmasq running well, I have write a watchdog
 

VaMpIrE-KiNg

Occasional Visitor
Sorry I found the problem, because I have writed a cron.sh, this contain service stop_dnsmasq and serivce start_dnsmasq commads, but Since I upgrade to 386.8. the service command no longer support dnsmasq.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top