What's new

AXE-16000 slow internet speeds via Ethernet

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here

I have a 2Gbps connection with Xfinity. When running a speed test on the AXE-16000 router I am getting anywhere from 1500 to 1650Mbps.

Screenshot 2024-04-22 at 11.54.46 PM.png

I tested the speed between my Macbook pro and Asus AXE-16000 using iperf3 and I see ~1.5Gbps speed (seems like my home network is not too great)

Screenshot 2024-04-22 at 11.55.29 PM.png

I expect to see close to ~1.48 Gbps when I run a speed test on the router as the router is able to hit 1.5+ Gbps directly with the cable modem. But I see really poor speed test speeds. I have tried multiple speed testing sites and none of them go above 600Mbps. Here is a sample to speedtest.net

Screenshot 2024-04-22 at 11.57.05 PM.png

I am totally puzzled about why this is happening. I tried connecting directly via Wifi while sitting right next to the router using my phone and it is not able to go past ~600Mbps either. So I suspect there is something wrong on the router and I am clueless how to troubleshoot this further.

Note: I am running the Beta firmware on the router as I need the "Guest Network Pro" and I have created one vlan for all my IOT devices. I am not sure if this is what is causing the problems, but I thought that this is worth mentioning.

Any help trying to resolve this problem would be much appreciated!

Edit: Editted for clarity
Welcome to the forums @raoden.

Testing right next to the router with a handheld (or other) device isn't a proper test.

The speeds look fine to me. What are you expecting? Your full ISP speeds, wirelessly?

As for the speeds indicated on the router, at the ISP speeds you have, the router (depending on how it is configured, what options and features are enabled, and how long it's been rebooted) may not show accurate speeds.

What does a PC (plugged into a wall AC outlet, with the power plan set to Performance) achieve when directly connected to the main router?
Sorry I wasn't clear, the speedtest.com results that I posted is speedtest run using wired ethernet. The wired ethernet speed to the internet also does not go over 600Mbps. So this is what I am observing

Internet speed tested on the AXE16000: ~1650Mbps
Wired Ethernet transfer speed between AXE-16000 and my Macbook pro using iperf3: ~1500Mbps
Internet speed tested on my Macbook pro while on ethernet: ~600Mbps
Internet speed tested on my Macbook Pro while Wifi sitting right next to the router: ~600Mbps

So the ethernet is capable of doing ~1.5Gbps, the router is able to do ~1.6Gbps. But while accessing the internet from the mac while wired or wireless is only able to do ~600Mbps. I don't understand how this can be happening.
Try to give a more complete picture of how your network/router is configured.
2.5G port connected to XB8 modem
10G port connected to Trendnet 10G switch

Asus ET-12
2.5G port connected to same Trendnet 10G switch
2.5G port connected to Macbook pro via Caltech hub with 2.5G interface

QOS, AiProtection disabled.
Router and Satellites are running beta firmware

I have additional vlan for IOT devices with a max speed of 100Mbps.

I have enabled SSH on Routers and Satellites and confirmed I can get about 1.5Gbps between each of the components (Satellites to Router, Macbook pro to Router, etc) using iperf3. The router is able to do about 1.6Gbps via the modem. But any internet access from my Macbook pro wired or wireless is never able to go beyond 600Mbps. I am able to transfer large files at 940Mbps (as the host has a 1G interface) without any issues. But can never get to more than 600Mbps on internet (wired or wireless) though the router by itself is able to do close to 3 times that speed.

Let me know if you need any other details. Thank you!
I finally figured out my problem. I thought QOS was disabled but there are QOS settings under the gaming section. Not only was QOS enabled for but for some odd reason it was set to "Bandwidth Limiter". Though the hosts list was completely empty. Not sure why this was causing issues, but I disabled QOS under the gaming settings and now I am getting close to 2.2Gbps from my Macbook pro. Pretty happy with it now!!
Are you facing any random wifi dropouts with AXE-16000? I got mine last week but getting random signal dropouts, separated SSID's and still the same. Is it possible to share an image with your WiFi settings such as channels etc that will be great.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!