What's new

AiMesh Nodes take SSID of 5G-1 but channel of 5G-2 (1x AXE-16000/5x AX-3000's)

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here

I am a new user here but have read these forums for a number of years. Today, I have an issue that is puzzling me and while I believe I may be able to SSH into the system to change the variables, I want to confirm with the community first. Currently, I have a wired ethernet back haul between my primary AiMesh router, the AXE-16000, and five AX-3000 AiMesh nodes. With the 5G-1 radio enabled and 5G-2 radio disabled, on the AXE-16000, the AX-3000 nodes take both the SSID and Channel assignment of 5G-1. HOWEVER, if 5G-2 is enabled, with a different channel and SSID, the AiMesh nodes then take the SSID of 5G-1 and the Channel assignment of 5G-2, creating interferance....I know this from using the Linux CLI tool "wavemon" and the network scan confirms this information.

In my research, I found instructions on SSH access to the primary router and commands for setting the wireless radio channel "nvram set wl1_chanspace=52/80." However, how would I SSH into the individual AiMesh nodes? Furthermore, does Merlin firmware for the ASUS AXE-16000 resolve this bug? I am on the most recent STOCK ASUS firmwares. Thank you for reading and helping me solve this issue.

To summarize the matter and clarify, I want 5G-2 to use it’s own SSID ”Network B” and operate on Channel 149, while 5G-1 and the AiMesh Nodes use Channel 52 and their own SSID “Network A.”
  • Primary Router radio 5G-1 enabled/5G-2 Disabled = AiMesh Nodes use SSID of 5G-1 & Channel of 5G-1
  • Primary Router radio 5G-1 Enabled/5G-2 Enabled = AiMesh Nodes use SSID of 5G-1 & Channel of 5G-2
I found a thread with a user with the opposite issue:

AXE-16000: Operation Mode:Wireless router, Firmware Version:
RT-AX-3000 (AX58-U): Operation Mode: AiMesh Node, Firmware Version:
Last edited:
- not sure why you need 1x router with 5x more nodes
- 5GHz-1 and 5GHz-2 work on different channels, no interference
- your 5x nodes constant fight for airtime on the same channels is much worse
- on multi-band routers 5GHz-2 is usually reserved for backhaul in AiMesh configuration, perhaps where your "issue" comes from
Hello Tech9,

-The facility for this installation is quite large and compartmentalized with very dense building materials between Access Points "AiMesh Nodes." After conducting a site survey, the nodes are placed in areas where, according to Wavemon, the signal quality drops to below 50%, -75 dBm. To confirm, I am not using 5GHz-2 as a wireless back-haul, I am strictly using wired Ethernet between all nodes. In my situation, 5G-1 and 5G-2 are not directly conflicting with each other, but the AiMesh nodes are configuring themselves as the SSID of 5G-1 and the Channel of 5G-2. I would wish for the AiMesh nodes only take the SSID/Channel assignment of 5G-1.
Last edited:
In this case your hardware choice is wrong. AiMesh has very limited control and you can't change the preset behavior. Instead of playing with home routers I would invest in proper business equipment with controller run PoE APs. It may even come cheaper or close to the price you've paid. Quite large property needs proper planning with proper tools. Your Wavemon was perhaps running on a mobile device and showing you what this particular device sees around through it's own Wi-Fi interface. This may be close to the real environment situation, but can be also quite far from it for other devices. Your "nodes" are simply no control wired APs blasting all the time at full power. The more you add the bigger the mess in your wireless environment.
I do conquer with your statement, Tech9. While I understand the limitations of the functionality of ASUS compared to commercial-grade equipment, I do find the bug I found to be puzzling for me, as I find the same issue even with a single AIiMesh node. To confirm, I conducted my analysis with Wavemon at each AP installation as to not over saturate the air space. The users of the system expect roaming to function between AP's while on a mobile "wifi-calling" phone, otherwise I would have used separate 20Mhz wide channels between each area. All is functioning well except for the issue with enabling 5G-2 at the primary router location which causes the AIMesh nodes to change channels. I will further investigate via the CLI and report back my findings, and any solution. I do appreciate your counsel and will seek to invest in PoE and commercial AP's when the budget is avaliable. For now, I am looking to trouble shoot this issue with the ASUS equipment.
See what you can find, but I've seen reports of nodes binding automatically to 5GHz-2 settings because of how AiMesh is preset to work. Since your AX3000 routers are all wired you can convert them into AP Mode and avoid AiMesh issues altogether. The roaming will be the same and you'll have channel and Tx power control per individual AP. What you'll lose is GN1 propagation to nodes. AiMesh roaming is on a slow side compared to other "mesh" options, unfortunately. There is no "seamless" roaming with any setup, but some just switch faster. Some controller run systems have the ability to learn the environment and track clients adjusting dynamically Tx power per AP to encourage AP switching. It's just on another level.
Last edited:
I briefly attempted to ssh into each AiMesh node and set the channel, however it would not deviate from auto or "0." I then decided to forgo AiMesh and give AP-Mode a try. I set each AP to a static IP address and via the web gui set all the AP's to the same SSID/Channel/bandwidth/Power Saving TX-level along with Roaming Assistant set to -60. All is working well...

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!