What's new

Solved Cannot access SMB share from Android

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

SenhorHotpants

New Around Here
Salutations,

I've recently upgraded the firmware of my GT-AX6000 to a Merlin version, so that I can set SMB2 protocol for my Samba share (= ssd attached to the router via USB3 port).
I can access this share from Windows pc no problem. However, on Android devices I have a strange problem:
- I can access the share via VLC or Kodi to stream movies;
- I cannot access the share through any file explorer apps. Before the upgrade to Merlin, FX File Explorer worked when SMB1 protocol was used. However, now with SMB2 I cannot. The app attemps to connect for a while and then gives an error.

The android devices are on the same network. Connection settings of FX File Explorer are set to "SMB 2+" protocol. I can't find any solutions on the internets so far.

Any help is appreciated.
 
Last edited:
There was a similar problem with my Android phone, using CX file manager. I could not access my network files. The problem was that I had installed McAfee on my Andoid that had added a VPN to my system. It had even prevented my logging in to the network hub I was using. When I switched VPN off, I had full access to my network.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top