What's new

cifs to USB3.0 external hdd seems to have stopped working

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor
Hi all,
Been a very long time ASUS/Merlin user on an RT-AC86U router. Its been working flawlessly for years and years and I always keep it up to date regarding merlin firmware. I'm currently on .12_4
For a few weeks now I can no longer mount the external USB 3 attached hdd that I use as a backup repository. The failure messages appear as no permissions to username/password errors, etc. I've tried resetting, deleting users, rebuilding users, etc to no avail.
My primary desktop is a Linux Mint 21.2 and I've defined a cifs mount in my fstab file.
While I'm quite experienced in networking I seem to have tried all that I can think of so I was hoping someone who is familiar with CIFS access can describe their mount efforts and what they would do to diagnose this error.
I guess my brain is just getting tired. Thanks to anyone who can provide this assistance.
If you can ssh into the AC68U, try this:

/sbin/modprobe md4

I had a similar issue a few firmwares back and we found that the md4 loadable module was not getting loaded.

Worth a shot - won’t hurt anything if it’s already loaded.

The other thing to check is CIFS level. VER=?
Well thanks for the suggestions. Eventually I did get the HDD mounted again. Although I cannot tell exactly it appeared to be some mismatch between the definition parameters on the router and the fstab mount command. After I tried the suggestions (thank you) I then went back and did a one by one elimination/replacement and eventually it mounted. Go figure.
I appreciate the help. Happy Holidays all! 😊

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!